2000c on Bed and Hot End



  • Hi there,

    Running a duet maestro 2 on a creality ender 3 machine.
    I am having issues with my heaters that have decided to stop following my guidelines. In the DWC they both show 2000c no matter if the thermistors are connected or not, the bed heater shows to be off, while the hotend shows a fault. I have tried to swap the e0 temp with the e1 temp and change the config files so that it was mapped to the hotend heater with no success. I have tried to check if the VSSA fuse was blown, but testing it with a multimeter gives me a resistance value of 2 ohms which, from what i have read, seems rto be reasonable. I have no idea what to do, does any of you guys have any hint?

    Here is my config.g

    ; Configuration file for Duet Maestro (firmware version 3)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.4 on Thu Sep 10 2020 09:33:05 GMT+0200 (Ora legale dell’Europa centrale)
    
    ; General preferences
    G90                                                ; send absolute coordinates...
    M83                                                ; ...but relative extruder moves
    M550 P"My Printer"                                 ; set printer name
    
    ; Network
    M552 P0.0.0.0 S1                                   ; enable network and acquire dynamic address via DHCP
    M586 P0 S1                                         ; enable HTTP
    M586 P1 S0                                         ; disable FTP
    M586 P2 S0                                         ; disable Telnet
    
    ; Drives
    M569 P0 S0                                         ; physical drive 0 goes backwards
    M569 P1 S0                                         ; physical drive 1 goes backwards
    M569 P2 S1                                         ; physical drive 2 goes forwards
    M569 P3 S0                                         ; physical drive 3 goes backwards
    M584 X0 Y1 Z2 E3                                   ; set drive mapping
    M350 X16 Y16 Z16 E128 I1                           ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400.00 E741.00                  ; set steps per mm
    M566 X600.00 Y600.00 Z60.00 E300.00                ; set maximum instantaneous speed changes (mm/min)
    M203 X9000.00 Y9000.00 Z600.00 E6000.00            ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00 E5000.00               ; set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E900 I30                       ; set motor currents (mA) and motor idle factor in per cent
    M84 S30                                            ; Set idle timeout
    
    ; Axis Limits
    M208 X0 Y0 Z0 S1                                   ; set axis minima
    M208 X235 Y235 Z260 S0                             ; set axis maxima
    
    ; Endstops
    M574 X1 S1 P"xstop"                                ; configure active-high endstop for low end on X via pin xstop
    M574 Y1 S1 P"ystop"                                ; configure active-high endstop for low end on Y via pin ystop
    M574 Z1 S1 P"zstop"                                ; configure active-high endstop for low end on Z via pin zstop
    
    ; Z-Probe
    M558 P0 H5 F120 T6000                              ; disable Z probe but set dive height, probe speed and travel speed
    M557 X10:220 Y10:220 S20                           ; define mesh grid
    
    ; Heaters
    M308 S0 P"bedtemp" Y"thermistor" T98801 B4185      ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0                              ; create bed heater output on bedheat and map it to sensor 0
    M307 H0 B0 S1.00                                   ; disable bang-bang mode for the bed heater and set PWM limit
    M140 H0                                            ; map heated bed to heater 0
    M143 H0 S80                                        ; set temperature limit for heater 0 to 80C
    M308 S1 P"e0temp" Y"thermistor" T98801 B4185       ; configure sensor 1 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1                               ; create nozzle heater output on e0heat and map it to sensor 1
    M307 H1 B0 S1.00                                   ; disable bang-bang mode for heater  and set PWM limit
    
    ; Fans
    M950 F0 C"fan0" Q20                                ; create fan 0 on pin fan0 and set its frequency
    M106 P0 S0 H-1                                     ; set fan 0 value. Thermostatic control is turned off
    M950 F1 C"fan1" Q20                                ; create fan 1 on pin fan1 and set its frequency
    M106 P1 S0 H1 T45                                  ; set fan 1 value. Thermostatic control is turned on
    M950 F2 C"fan2" Q20                                ; create fan 2 on pin fan2 and set its frequency
    M106 P2 S0 H1:0 T45                                ; set fan 2 value. Thermostatic control is turned on
    
    ; Tools
    M563 P0 S"HotEnd" D0 H1 F0                         ; define tool 0
    G10 P0 X0 Y0 Z0                                    ; set tool 0 axis offsets
    G10 P0 R0 S0                                       ; set initial tool 0 active and standby temperatures to 0C
    
    ; Custom settings
    M918 P1 E4                                         ;Enable 12864 LCD with 1 menu item per encoder click
    
    ; Miscellaneous
    M575 P1 S1 B57600                                  ; enable support for PanelDue
    M501                                               ; load saved parameters from non-volatile memory
    M911 S21 R23 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; set voltage thresholds and actions to run on power loss
    T0                                                 ; select first tool
    
    
    

  • Moderator

    @asape what firmware version? Send M115 to see. You have a config for RRF 3, but your board may be running RRF 2.

    Ian



  • @droftarts FIRMWARE_NAME: RepRapFirmware for Duet 2 Maestro FIRMWARE_VERSION: 2.05.1 ELECTRONICS: Duet Maestro 1.0 FIRMWARE_DATE: 2020-02-09b1

    Yep you are right , that's because i have tried to reinstall the firmware as the original issue was with the hotend only, I'll try to upgrade the firmware and report back, thank you.



  • Make sure you update from 2.0.5-1 to 3.0 to 3.1.1
    Direct upgrading won't work



  • Hi, thank you all for your help.

    The firmware update did improve the situation, i have probably panicked and overlooked it.
    Now the bed thermistor is working fine, though the hotend is giving me a reading of -273,1C no matter if i put it on e0temp or on e1 temp, just to be clear i have mapped the sensor to a different different pin by changing this line

    M308 S1 P"e1temp" Y"thermistor" T98801 B4185       ; configure sensor 1 as thermistor on pin e1temp
    

    did I do it correctly?

    And if so would you say i have a problem with the hotend hardware or specifically with the thermistor? Would you go about changing all the the hotend or just try replacing the thermistor? I do know that the VSSA fuse is not blown because of the 2 ohms reading i get when i tested it with a multimeter.

    Thanks again for your help



  • can you measure the resistance with a multimeter



  • @Veti I did and it briefly measured a resistance value of some Megaohms before going to open circuit, so I guess that's the culprit.
    I'll try buying a new therrmistor and see if that will solve the problem.
    Thanks a lot I don't know why I had gone on thinking it was a hardware issue, i'll keep my fingers crossed and see if the thermistor swap will get the printer back to work. Thanks again


  • Moderator

    @asape I expect it's a wiring issue; -273 is a open circuit, +2000 is a dead short (or mis-configured firmware!). If you want to test the Duet, put a 100k ohm resistor on e1temp pins. I have these for testing:
    alt text
    Or, as you're using the same thermistor for bed and hot end, plug the bed thermistor wire into e1temp.

    Ian


Log in to reply