BlTouch not triggering, tried everything



  • Hi,
    I purchased the latest BlTouch but for the life of me can't get it to work. Got all the latest firmware that I know off.
    Using the Duet 2 wifi.
    Heater PWM 7 input
    Everywhere i look it says something different so im really quite stuck...
    attached is my config file, if someone could point me as to where im going wrong i will be so thankful!

    ; Configuration file for Duet WiFi (firmware version 3)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.4 on Mon Sep 14 2020 09:23:59 GMT+0100 (British Summer Time)
    
    ; General preferences
    G90                                                ; send absolute coordinates...
    M83                                                ; ...but relative extruder moves
    M550 P"XL Printer"                                 ; set printer name
    
    ; Network
    M552 S1                                            ; enable network
    M586 P0 S1                                         ; enable HTTP
    M586 P1 S0                                         ; disable FTP
    M586 P2 S0                                         ; disable Telnet
    
    ; Drives
    M569 P0 S1                                         ; physical drive 0 goes forwards
    M569 P1 S1                                         ; physical drive 1 goes forwards
    M569 P2 S1                                         ; physical drive 2 goes forwards
    M569 P7 S1                                         ; physical drive 7 goes forwards
    M584 X0 Y1:4 Z2 E7                                   ; set drive mapping
    M350 X16 Y16 Z16 E16 I1                            ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400.00 E150.00                  ; set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00                ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E1200.00            ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00 E250.00                ; set accelerations (mm/s^2)
    M906 X800 Y1500:1500 Z800 E800 I30                      ; set motor currents (mA) and motor idle factor in per cent
    M84 S30                                            ; Set idle timeout
    
    ; Axis Limits
    M208 X30 Y0 Z0 S1                                  ; set axis minima
    M208 X630 Y350 Z350 S0                             ; set axis maxima
    
    ; Endstops
    M574 X1 S0 P"!xstop"                               ; configure active-high endstop for low end on X via pin !xstop
    M574 Y1 S0 P"!ystop"                               ; configure active-high endstop for low end on Y via pin !ystop
    M574 Z1 S2                                         ; configure Z-probe endstop for low end on Z
    
    ; Z-Probe
    
    M950 S0 C"exp.heater7"                             ; create servo pin 0 for BLTouch
    M558 P9 C"^zprobe.in" H5 F120 T6000                ; set Z probe type to bltouch and the dive height + speeds
    G31 P1000 X0 Y40 Z2.5                              ; set Z probe trigger value, offset and trigger height
    M557 X45:215 Y15:195 S50                           ; define mesh grid
    
    ; Heaters
    M308 S0 P"bedtemp" Y"thermistor" T100000 B4138     ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0                              ; create bed heater output on bedheat and map it to sensor 0
    M307 H0 B1 S1.00                                   ; enable bang-bang mode for the bed heater and set PWM limit
    M140 H0                                            ; map heated bed to heater 0
    M143 H0 S120                                       ; set temperature limit for heater 0 to 120C
    M308 S1 P"e0temp" Y"thermistor" T100000 B4138      ; configure sensor 1 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1                               ; create nozzle heater output on e0heat and map it to sensor 1
    M307 H1 B0 S1.00                                   ; disable bang-bang mode for heater  and set PWM limit
    M307 H7 A-1 C-1 D-1 
    
    ; Fans
    M950 F0 C"fan0" Q500                               ; create fan 0 on pin fan0 and set its frequency
    M106 P0 S0 H-1                                     ; set fan 0 value. Thermostatic control is turned off
    M950 F1 C"fan1" Q500                               ; create fan 1 on pin fan1 and set its frequency
    M106 P1 S1 H1 T45                                  ; set fan 1 value. Thermostatic control is turned on
    
    ; Tools
    M563 P0 D0 H1 F0                                   ; define tool 0
    G10 P0 X0 Y0 Z0                                    ; set tool 0 axis offsets
    G10 P0 R0 S0                                       ; set initial tool 0 active and standby temperatures to 0C
    
    ; Custom settings are not defined
    
    ; Miscellaneous
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; set voltage thresholds and actions to run on power loss
    
    
    


  • post your retract and deploy script



  • @ChrisF3D

    1/ what version of the firmware are you using . try M122
    ( you are on version 3 of the config.g , but have you upgraded to version 3 firmware )
    2/ Are you getting the red light and getting the in and out power on self test



  • Supposedly auto-generated from their new tools.

    ; deployprobe.g
    ; called to deploy a physical Z probe
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.4 on Mon Sep 14 2020 09:23:59 GMT+0100 (British Summer Time)
    M280 P0 S10 ; deploy BLTouch
    
    
    ; retractprobe.g
    ; called to retract a physical Z probe
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.4 on Mon Sep 14 2020 09:23:59 GMT+0100 (British Summer Time)
    M280 P0 S90 ; retract BLTouch
    
    
    


  • Board: Duet WiFi 1.02 or later (duetwifi102)
    Firmware: RepRapFirmware for Duet 2 WiFi/Ethernet 2.03 (2019-06-13b2)
    Duet WiFi Server Version: 1.23



  • You config is for the 3.xx firmware version.



  • @ChrisF3D

    YEP , you are running the version 3 config file , but still running version 2 firmware ..

    upgrade to version 3 firmware or use the version 2 configurator



  • Ive tried upgrading to 3.0 but it doesnt seem to update the firmware... I used "duet2and3firmware-3.1.1.zip" and uploaded it



  • @ChrisF3D

    You need to upgrade to I THINK version 3 ? , then 3.1.1 .
    I know you can't do it in one go !!!



  • Lifesavers!!! yes 3.0 first worked!
    Thank you all so much... hopefully, it's plain sailing now!



  • This post is deleted!


  • @ChrisF3D

    The bits which you normally get it wrong is offsets ( G31 ) , Which you say is level on the X axis , but the probe is 40mm behind the nozzle on the Y axis ?

    And how you home !!! You need to use G30 to home Z


  • Moderator

    G31 P1000

    Try G31 P25 instead.


Log in to reply