Fan Settings in config.g



  • Hi and thanks for your help.
    Firmware Name: RepRapFirmware for Duet 2 WiFi/Ethernet
    Firmware Electronics: Duet WiFi 1.02 or later
    Firmware Version: 2.05.1 (2020-02-09b1)
    WiFi Server Version: 1.23
    Web Interface Version: 1.22.6

    I again today noticed that my tool fan is not running at 100% and that I have to turn it up from the UI.
    These are my settings:
    ; Fans
    M106 P0 S0 I0 F500 H-1 ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    I read what it says here but I don't understand everything, yet. Can you please help me setting the tool fan to run @ 100% when it runs? I slice with Cura and it is set to turn on the fan & run at 100% from layer 4.

    Thank you very much. (I only have the 2 fans. The "main" one can remain as is.)



  • If you want it to always be 100%, you can use the L parameter in M106 https://duet3d.dozuki.com/Wiki/Gcode#Section_M106_Fan_On
    i.e.

    M106 P0 S0 I0 F500 H-1 L1
    


  • @jay_s_uk
    Thanks. That is the article I quoted but don't understand everything.


Log in to reply