Restart extrusion amount after resuming the pause (M226)



  • Hi guys,

    I often use the M226 command in the GCODE to pause the print after a certain layer and insert metallic parts such as nuts and magnets into a print and then resume the print via the PanelDue resume button.

    This works great except for one thing - every time I resume the print head comes back into position and then extrudes a pile of plastic on my print (I guess this is the restart filament amount) and then resumes the print normally. This is a problem since with my hotend (Mosquito) I do not need the restart amount and it just messes up the print potentially making the print head hit that big chunk thereby ruining the print.

    Is there a command or setting where I can turn off this "resume filament extrusion amount" or whatever it is called.

    Thanks a lot in advance.


  • administrators

    Take a look inside your resume.g file, that's where the re-prime command will be.



  • Great, thanks!
    I completely forgot there is a resume.g. 🙂



  • @omni

    It is the first time I fitted a filament out to my duet wifi and found the same problem , pause retracts 10mm of filament and resume put it back , but if you change filament and push filament until you see the new filament come out you get a 10mm big blob on resume.
    So I now retract 10mm before I resume .


Log in to reply