PanelDueFirmware 3.2-RC1 released


  • Moderator

    I am please to annound the release of PanelDueFirmware 3.2-RC1.

    Pre-Release 3.2-RC1

    This version is major rewrite of the underlying communication protocol between PanelDue and RepRapFirmware to enable a more flexible configuration in RepRapFirmware to be displayed correctly on PanelDue.

    Upgrade notes:

    • This release is compatible with RepRapFirmware 3.2-beta1 or later. It will partially work with RepRapFirmware 3.1.1 but not with any older version.
    • Flashing this release will reset the configuration to defaults

    Limitations

    • Due to the lack of RAM this build will not run on version 1 or early version 2 PanelDue boards that use the ATSAM3S2B chip (models shipped until around the end of 2015). It is expected to work on later version 2 PanelDue boards using the ATSAM3S4B chip. If you have a PanelDue using the ATSAM3S2B chip, we suggest you replace the board by a version 3 PanelDue board, which can drive your existing LCD.

    New and changed features:

    • This release uses the RepRapFirmware ObjectModel instead of limited status responses
    • Support for spindles with current RPM as well as active RPM
    • Bed heater will only be shown if it is configured
    • Support for chamber heaters (will only show if bed heater + number of tools <= 6)
    • Tools and assigned heaters and extruders can be numbered arbitrarily (e.g. tool 1 can use heater 8 and extruder 2)
    • A simple screensaver has been added to help preventing screen burn-in on long-lasting prints
    • Tool buttons will reflect the tool status
    • Prevent flickering if values did not change

    Bug fixes

    • Axes will be shown as they are configured, i.e. if configured axes are XYZA then PanelDue will display them like this instead of XYZU

    Downloads and Instructions

    Binaries can be found at https://github.com/Duet3D/PanelDueFirmware/releases/tag/3.2-RC1

    EDIT: A new preliminary release with some bugs fixed can be found at: https://www.dropbox.com/sh/zbj590lu8udha8d/AADTx7RdBuGIhri8Xk18jNvua?dl=0

    Flashing instructions can be found at https://duet3d.dozuki.com/Wiki/PanelDue_Firmware_update

    Release plan

    This is a release candidate and will either be followed by another release candidate in case bugs will be found or will be promoted to a final version.



  • uses the RepRapFirmware ObjectModel

    Oooooh! (Although presumably this "breaks" the DIY approaches that rely on listening to M408 replies?)


  • administrators

    @bearer said in PanelDueFirmware 3.2-RC1 released:

    uses the RepRapFirmware ObjectModel

    Oooooh! (Although presumably this "breaks" the DIY approaches that rely on listening to M408 replies?)

    Yes, it will. Those DIY approaches will need to be modified to listed to the M409 responses instead.



  • Duet3 standalone, 3.2beta1 + PanelDue 3.2-RC1

    When I setup a tool0 (first extruder) temperature, it sets heatbed instead 🙂
    Also switching chamber active/stby resets temp settings for it.
    Chamber button is not switching colors for active/stby like others do, and does not deactivate chamber heater at all.
    Extruder buttons are yellow when switching tool from stby to off
    Heatbed button does not change colors at all.

    That is what I notice djust now.


  • administrators

    @BoA, please post your config.g file so that @wilriker can try to reproduce your configuration.



  • config.g

    In dynamics_normal.g there is just this:

    M913 X100 Y100 Z100 E100 ; set XY motors current to 100%
    M566 X900.00 Y900.00 Z18.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X18000.00 Y18000.00 Z1200.00 ; set maximum speeds (mm/min)
    M201 X1500.00 Y1500.00 Z100.00 ; set accelerations (mm/s^2)
    M593 F36.5

    And before someone asks - uart speed has nothing to do. It behaves exactly the same at 57600 and 115200


  • administrators

    Those of you with older version 1 and version 2 PanelDues, please note that we do not expect this release to work on old PanelDue boards that use the ATSAM3S2B chip, due to lack of RAM. However, we do expect it to work on later version 2 PanelDues using the ATSAM3S4B chip. If you have a PanelDue using the ATSAM3S2B chip, we suggest you replace the board by a version 3 PanelDue board, which can drive your existing LCD.


  • Moderator

    @BoA said in PanelDueFirmware 3.2-RC1 released:

    Duet3 standalone, 3.2beta1 + PanelDue 3.2-RC1

    When I setup a tool0 (first extruder) temperature, it sets heatbed instead 🙂
    Also switching chamber active/stby resets temp settings for it.
    Chamber button is not switching colors for active/stby like others do, and does not deactivate chamber heater at all.
    Extruder buttons are yellow when switching tool from stby to off
    Heatbed button does not change colors at all.

    That is what I notice djust now.

    Thanks for reporting. I will look into this now.

    @BoA said in PanelDueFirmware 3.2-RC1 released:

    config.g

    Thanks for providing this information as well. 👍


  • Moderator

    @BoA said in PanelDueFirmware 3.2-RC1 released:

    When I setup a tool0 (first extruder) temperature, it sets heatbed instead 🙂
    Also switching chamber active/stby resets temp settings for it.
    Chamber button is not switching colors for active/stby like others do, and does not deactivate chamber heater at all.

    These have all been fixed

    Extruder buttons are yellow when switching tool from stby to off

    There is a misconception. A tool will never go to the "off" state after being activated for the first time. It will only toggle between active and standby. Only the tool's heaters can go back to off.

    Heatbed button does not change colors at all.

    Fixed as well.

    If you tell me which version of PanelDue you have I can provide you a build to test before doing another release.



  • @wilriker Tools can go off from DWC, and button on panel is still yellow then.

    I use PanelDue 7i


  • Moderator

    @BoA Believe me, the tool itself is not off. You can check yourself by issuing

    M409 K"tools[0].state"
    

    will report standby.
    At the same time

    M409 K"heat.heaters[1].state"
    

    might report off

    You can find the new build at https://www.dropbox.com/sh/zbj590lu8udha8d/AADTx7RdBuGIhri8Xk18jNvua?dl=0



  • @wilriker 6a8c3b20-c2c4-456c-a38b-38dd5d6600a1-obraz.png

    Looks like "off" to me 🙂


  • Moderator

    @BoA Is that before or after the tool has been active at least once?



  • @wilriker After. I can cycle through all 3 state from DWC. From panel only active<->stby, but from DWC all 3.
    Just testem with new FW and it works for heatbed. Buttons go gray when heatbed put to off state.


  • Moderator

    @BoA Starting to feel a bit stupid here but how do you get the tool to go back into the off state via DWC?

    Also for bed and chamber heaters that's something different because these are heaters. Tools have a state separate from their heater's state.



  • @wilriker OK. Nevermind. All You wrote is true. Tool does no goes back to off. only heater does.



  • @wilriker when the tool is in standby, click it again and it goes to off



  • @jay_s_uk On heater - heater will go to off, but clicking on tool switches between stby and active



  • @wilriker This is perhaps small issue with RRF not paneldue, but putting M116 P0 in tpost0.g seems to block refreshing tool status (and temperature refreshing) until temperature is reached.



  • @BoA oh yea, i forget you can click both. ignore my previous comment



  • @wilriker And one small thing - When setting screensaver timeout I can not "unclick" the button to close selection like with i.e. Info Timeout


  • Moderator

    @BoA said in PanelDueFirmware 3.2-RC1 released:

    @wilriker This is perhaps small issue with RRF not paneldue, but putting M116 P0 in tpost0.g seems to block refreshing tool status (and temperature refreshing) until temperature is reached.

    I tried but I cannot reproduce this. Will have to look some more into that.

    @BoA said in PanelDueFirmware 3.2-RC1 released:

    @wilriker And one small thing - When setting screensaver timeout I can not "unclick" the button to close selection like with i.e. Info Timeout

    That's basically for all of the selection. Click on "Setup" on the bottom right to close it.
    EDIT: I put it on the list for the next release to auto-close it.



  • @wilriker My scenario details:

    • tool is off/stby
    • set active temperature like 200*C
    • put tool to active to start heating

    Then refreshing stops until temp is reached.


  • Moderator

    @BoA Thanks for being so precise that always helps!
    I will most likely only get back to it next week, though.

    Did the new build fix the other reported issues?



  • @wilriker Works like a charm 😄


Log in to reply