Cura 4.7.1 Crash with "Duet Plugin"?



  • Hi *,

    my cura (4.7.1) crash very often when I print to my Duet2 via the "Duet RepRapFirmware" (1.0.11) plugin. I run Cura on linux.

    It happens mostly during the upload of a second print. Sometimes some minutes after I started a print.

    I see this message on the console when I start the print. (Already at the upload of the first print, with an remaining Cura.)

    content-type missing in HTTP POST, defaulting to application/x-www-form-urlencoded. Use QNetworkRequest::setHeader() to fix this problem.
    
    

    I get this when Cura crashed:

    /tmp/.mount_UltimaJIVahe/usr/bin//cura.sh: line 14: 443277 Segmentation fault      (core dumped) cura "$@"
    
    

    (Line 14 of "cura.sh": cura "$@")

    I think that I have that problem since I upgraded to Cura 4.7.1 but I'm not 100% sure.

    Does somebody experience the same behavior? I do not want to bother Thomas for a "Chriss only" problem. 😉

    Board: Duet 2 WiFi (2WiFi)
    Firmware: RepRapFirmware for Duet 2 WiFi/Ethernet 3.1.1
    

    Cheers, Chriss


  • Moderator

    I've used with with the Cura master build (same updates as 4.7.1) on windows without issue, so perhaps it's only with the official Cura or linux specific.



  • @Chriss do you have any "exotic" characters in your printer name?
    I've seen other reports of cyrillic names causing a crash...



  • @resam No special characters, the name of the printer is "Homer". And the plugin knows only the IP of the printer.

    @Phaedrux Thanks, you made me think to compile it.... :?

    I will observe "$HOME/.local/share/cura/4.7/cura.log", I hope that I will see more there at the next crash.

    Cheers, Chriss


Log in to reply