Can't get bed heater to work



  • I'm having issues with getting my bed heater to work. It's a 110v ac unit. I have it wired to a SSR. Picture below is how it's wired.
    bedwirng.png

    I've also tried with the wires connected opposite on the psu. To clarify the bed heater is on the AC side of the psu, as the bed heater is AC. This way I didn't have to redo my wiring at the power adaptor . When I try to heat the bed, it blows the fuse in the power plug. I'm trying to do a M303.

    Is it blowing the fuse because it's also connected to the PSU, the PSU is a Mean Well 600w? Do I have to wire it directly to the power plug?



  • Many of the simple ac plugs with built in fuses only have a 5amp fuse in them. That would limit you to a maximum wattage of 600watts and then the fuse will blow. It took me quite a while to find one that actually had a 10amp fuse in it which allowed me to use my 750watt ac heated bed.

    This is the one I use but they are listed as unavailable right now.

    https://www.amazon.com/gp/product/B07KJV7XLS/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1



  • @JamesM Thank you, that's what it was. I had a 10amp AC plug sitting here. Switched it out and it worked. Got my pid tuning finally done.