Help with starting print height after modding a qidi tech 1



  • Greetings, I have a qidi tech 1 that i modded by using a duet wifi and switching to single hot end. I am trying to set the starting print height. The process i used was the bed to touch the nozzle and used g92 z0 followed by m500. i then changed the numbers in the start script to 0 and then 0.50 but its not where i need it to be. i will be including the start script below am i doing this right or missing a step ??? I want to print !!!

    ; Startup Gcode
    G91 ; Relative Positioning
    G1 Z-1 ; Move Z down 1mm
    G90 ; Absolute Positioning
    G28 XY ; Home XY
    M561 ; Clear any bed transform
    G1 X5 Y5 ; Move Head to front left
    G92 E0.50 ; Zero Extruder
    G1 F200 E20 ; Prime the extruder
    G92 E0.50 ; Zero Extruder



  • how does the printer home z?

    post your config.g

    post your homeall.g



  • ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.4 on Sat Jul 25 2020 12:56:48 GMT-0400 (Eastern Daylight Time)
    G91 ; relative positioning
    G1 H2 Z5 F6000 ; lift Z relative to current position
    G1 H1 X235 Y-215 F1800 ; move quickly to X and Y axis endstops and stop there (first pass)
    G1 H2 X-5 Y5 F6000 ; go back a few mm
    G1 H1 X235 Y-215 F360 ; move slowly to X and Y axis endstops once more (second pass)
    G1 H1 Z205 F360 ; move Z up stopping at the endstop
    G90 ; absolute positioning
    G92 Z0 ; set Z position to axis maximum (you may want to adjust this)

    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 Z5 F100 ; lift Z relative to current position
    ;G90 ; absolute positioning



  • ; Configuration file for Duet WiFi (firmware version 3)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.4 on Sat Jul 25 2020 12:56:48 GMT-0400 (Eastern Daylight Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"Qidi nova" ; set printer name

    ; Network
    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S1 ; disable Telnet

    ; Drives
    M569 P0 S1 ; physical drive 0 goes forwards
    M569 P1 S0 ; physical drive 1 goes forwards
    M569 P2 S0 ; physical drive 2 goes backwards
    M569 P3 S0 ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3 ; set drive mapping
    M350 X32 Y32 Z32 E16 I1 ; configure microstepping with interpolation
    M92 X188.2 Y189.5 Z800.00 E415.00 ; set steps per mm
    M566 X900.00 Y900.00 Z180.00 E1200.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X18000.00 Y18000.00 Z180.00 E1560.00 ; set maximum speeds (mm/min)
    M201 X1000.00 Y1000.00 Z150.00 E2000.00 ; set accelerations (mm/s^2)
    M906 X610 Y610 Z610 E850 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X227 Y145 Z152 S0 ; set axis maxima

    ; Endstops
    M574 X2 S1 P"xstop" ; configure active-high endstop for high end on X via pin xstop
    M574 Y1 S1 P"ystop" ; configure active-high endstop for low end on Y via pin ystop
    M574 Z1 S1 P"zstop" ; configure active-high endstop for high end on Z via pin zstop

    ; Z-Probe
    M558 P0 H5 F120 T6000 ; disable Z probe but set dive height, probe speed and travel speed
    M557 X15:215 Y15:148 S20 ; define mesh grid

    ; Heaters
    M308 S0 P"bedtemp" Y"thermistor" T100000 B4138 ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0 ; create bed heater output on bedheat and map it to sensor 0
    M307 H0 B1 S1.00 ; enable bang-bang mode for the bed heater and set PWM limit
    M140 H0 ; map heated bed to heater 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    M308 S1 P"e0temp" Y"thermistor" T100000 B4138 ; configure sensor 1 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1 ; create nozzle heater output on e0heat and map it to sensor 1
    M307 H1 B0 S1.00 ; disable bang-bang mode for heater and set PWM limit

    ; Fans
    M950 F0 C"fan0" Q500 ; create fan 0 on pin fan0 and set its frequency
    M106 P0 S1 H-1 ; set fan 0 value. Thermostatic control is turned off
    M950 F1 C"fan1" Q500 ; create fan 1 on pin fan1 and set its frequency
    M106 P1 S1 H0:1 T45 ; set fan 1 value. Thermostatic control is turned on
    M950 F2 C"fan1" Q500 ; create fan 2 on pin fan1 and set its frequency
    M106 P2 S1 H0:1 T45 ; set fan 2 value. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    M501
    ; Custom settings are not defined



  • ; homez.g
    ; called to home the Z axis
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.4 on Sat Jul 25 2020 12:56:48 GMT-0400 (Eastern Daylight Time)
    G91 ; relative positioning
    G1 H2 Z5 F6000 ; lift Z relative to current position
    G1 H1 Z205 F1800 ; move Z up until the endstop is triggered
    G92 Z0 ; set Z position to axis maximum (you may want to adjust this)

    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 Z5 F100 ; lift Z relative to current position
    ;G90 ; absolute positioning


  • Moderator

    @dakingofhearts2003 said in Help with starting print height after modding a qidi tech 1:

    G1 H1 Z205 F1800 ; move Z up until the endstop is triggered
    G92 Z0 ; set Z position to axis maximum (you may want to adjust this)

    That doesn't make any sense. It moves to the high end of the Z axis and then sets it as Z0.

    Plus your Z endstop is defined as being on the low end.

    M574 Z1 S1 P"zstop" ; configure active-high endstop for high end on Z via pin zstop

    Where are you endstops physically located? I think you've got a motor direction wrong and maybe a homing move incorrect as well.

    You startup gcode doesn't have anywhere that it homes Z either, just X and Y. Are you using homeall or homez at all?

    @dakingofhearts2003 said in Help with starting print height after modding a qidi tech 1:

    he process i used was the bed to touch the nozzle and used g92 z0 followed by m500.

    M500 doesn't work that way, but touching the nozzle to the bed and sending G92 Z0 would set the height correctly.



  • The endstop is bed level 0 and as it prints the bed moves down. Everything homes correctly but it keeps starting the prints about 5 mm above the bed if i can fix that im good. some settings in the config i may have changed without changing the explanation to match. like the endstops, i have no problem homing.


  • Moderator

    @dakingofhearts2003 said in Help with starting print height after modding a qidi tech 1:

    G1 H1 Z205 F360 ; move Z up stopping at the endstop
    G90 ; absolute positioning
    G92 Z0 ; set Z position to axis maximum (you may want to adjust this)

    Ok so if you endstop is located at Z min, then your homing move in homeall and homez is going the wrong way.

    Should be G1 H1 Z-205 F360

    If G1 Z205 is moving towards the endstop, then your Z axis motor is rotating the wrong way.

    When jogging the Z axis does Z+ move the bed and nozzle farther apart and Z- closer together?



  • @Phaedrux i assure you everything is correct i made my own wires and so i had to reverse somethings. If the bed went the wrong way i wouldnf be able to home successfully.


  • Moderator

    @dakingofhearts2003 said in Help with starting print height after modding a qidi tech 1:

    Everything homes correctly but it keeps starting the prints about 5 mm above the bed if i can fix that im good.

    After you homeall are you able to jog the nozzle down so that Z0 has the nozzle just touching the bed?



  • Hi,

    The process you used: Move nozzle to touch bed, G92 Z0 and then M500.

    What do you think M500 does in this case?

    Frederick



  • 20201117_221944.jpg



  • This is how close it is after homing



  • @dakingofhearts2003 said in Help with starting print height after modding a qidi tech 1:

    This is how close it is after homing

    You need to determine how far from the bed the nozzle is at that point.

    Then you need to adjust the G92 Z0 line to specify the actual Z position at that point, and it is clearly not 0.

    Let's say you determine the nozzle is exactly 5mm off the bed.

    Then the line should read G92 Z5.

    So then moving to Z0 would move down 5mm and should touch the bed.

    Frederick



  • @fcwilt i did that and still this is what i get

    20201117_224510.jpg



  • Hi,

    So you modified the G29 Z# line in the homez.g file?

    And the nozzle is now farther away?

    Frederick


  • Moderator

    @dakingofhearts2003 said in Help with starting print height after modding a qidi tech 1:

    i assure you everything is correct

    And yet your nozzle is 5mm above the bed. 🤔


Log in to reply