SOLVED Vertical Line on X Axis



  • I just try using RRF on LPC 17xx and get some problem when XY travel from home to start point, printer get jerk. This is not happen when I'm using Marlin 2. And get vertical line on X axis print. foto2.jpg
    But when I try rotate print on 90 degree and get better result, Y Axis is normal. No vertical line foto1.jpg
    This is my config.g:
    M569 P0 S0 T1.9:1.9:0.65:0.65 ; physical drive 0 goes backwards using DRV8825 driver timings
    M569 P1 S1 T1.9:1.9:0.65:0.65 ; physical drive 1 goes forwards using DRV8825 driver timings
    M569 P2 S1 T1.0:1.0:0.2:0.2 ; physical drive 2 goes forwards using A4988 driver timings
    M569 P3 S0 T1.0:1.0:0.2:0.2 ; physical drive 3 goes backwards using A4988 driver timings
    M584 X0 Y1 Z2 E3 ; set drive mapping
    M350 X32 Y32 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X160.00 Y160.00 Z400.00 E415 ; set steps per mm
    M566 X900.00 Y900.00 Z12.00 E900.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E6000.00 ; set maximum speeds (mm/min)
    M201 X1000.00 Y1000.00 Z40.00 E1000.00 ; set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800 I30 ; set motor currents (mA) and motor idle factor in per cent

    I'm using BMG direct drive extruder and S3D for slicer with printer speed 80 mm/s.

    I'm still search where is the problem. Thanks.



  • it its at a very specific place, it might be mechanical

    since its at both sides at the exact same spot, its a good bet.



  • @Veti if mechanical issue, it can be happen if I use marlin firmware. But no issue if using marlin firmware.
    Thanks.



  • @ak10ng is it happening at layer change points or where there are 'kinks' in the model. If so, I'd say look at pressure advance and retraction. Your RRF one definitely has some bulging at the corners suggesting that you don't have enough pressure advance. https://duet3d.dozuki.com/Wiki/Pressure_advance

    Equally, if those are the start/end points for the perimeters/infill, changing retraction will impact. Are you using firmware retraction? And are you using Z-hop?

    With both retraction and PA, you may have to double-check your extruder motor settings in case they start limiting the motion (though from a quick glance they look okay).

    It's hard to see from your photos, but the marlin one also looks to have some kind of feature at the same locations (though not very clear and could be lighting...). Have you got a link to the part stl?



  • This is my gcode that problem.
    led-docking1mmA.gcode
    This is for rotate model led-docking1mmV.gcode
    And this is my stl led-docking.stl .
    I'm not using PA and not using Z hop.
    Thanks.



  • Which build are you using?



  • @jay_s_uk I'm using led-docking1mmA.gcode with problem vertical line.



  • @ak10ng of LPC RRF.
    Post you M122



  • @jay_s_uk this is
    M122
    === Diagnostics ===
    RepRapFirmware for LPC176x based Boards (biquskr_1.4) version 3.2-beta3.2_1 running on LPC176x at 120Mhz
    Used output buffers: 3 of 16 (16 max)
    === RTOS ===
    Static ram: 4940
    Dynamic Memory (RTOS Heap 5): 1704 free, 1664 never used
    Never used RAM 80, free system stack 22 words
    Tasks: NETWORK(ready,190) HEAT(blocked,338) MAIN(running,359) IDLE(ready,20)
    Owned mutexes: WiFi(NETWORK)
    === Platform ===
    Last reset 00:13:55 ago, cause: [software]
    Last software reset at 2020-12-03 17:33, reason: User, GCodes spinning, available RAM 80, slot 1
    Software reset code 0x0003 HFSR 0x00000000 CFSR 0x00000000 ICSR 0x00425000 BFAR 0xe000ed38 SP 0xffffffff Task MAIN
    Error status: 0x00
    Supply voltage: under voltage events: 0
    Driver 0: position 44480
    Driver 1: position 44000
    Driver 2: position 2040
    Driver 3: position 0
    Driver 4: position 0
    Driver 5: position 0
    Driver 6: position 0
    Date/time: 2020-12-03 17:47:57
    Slowest loop: 158.95ms; fastest: 0.10ms
    Step timer: target 805563946 count 835910751 delta -30346806 late 0
    USBSerial connected 0
    ADC not ready 2 ADC error threshold 10 ADC Init 1
    Ints: 14260; Calls 14254; fast: 2uS; slow 7uS adj 2689 bad 0 big delta 67
    PWM Channels
    Delta 375088068 Start -1 End -1
    === Storage ===
    Free file entries: 4
    SD card 0 detected
    SD card longest read time 46.2ms, write time 93.9ms, max retries 0
    === Move ===
    Hiccups: 0, FreeDm: 100, MinFreeDm: 98, MaxWait: 132327ms
    Bed compensation in use: mesh, comp offset 0.000
    === DDARing ===
    Scheduled moves 319, completed moves 319, StepErrors 0, LaErrors 0, Underruns [0, 0, 0], CDDA state -1
    === Heat ===
    Bed heaters = 0, chamberHeaters = -1
    Heater 1 is on, I-accum = 0.0
    === GCodes ===
    Segments left: 0
    Movement lock held by null
    HTTP is idle in state(s) 0
    File is idle in state(s) 0
    USB is idle in state(s) 0
    Aux is idle in state(s) 0
    Trigger is idle in state(s) 0
    Queue is idle in state(s) 0
    Daemon is idle in state(s) 0
    Autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Slowest loop: 229.91ms; fastest: 0.00ms
    Responder states: HTTP(2) HTTP(0)
    HTTP sessions: 1 of 2

    • WiFi -
      Network state is active
      WiFi module is connected to access point
      Failed messages: pending 0, notready 0, noresp 0
      WiFi firmware version 1.23L263-302
      WiFi MAC address d8:f1:5b:10:fe:c2
      WiFi Vcc 64.00, reset reason Turned on by main processor
      WiFi flash size 4194304, free heap 37712
      WiFi IP address 192.168.254.111
      WiFi signal strength -78dBm, reconnections 0, sleep mode modem
      Clock register ffffffff
      Socket states: 4 0


  • Have you tried printing the same gcode on version 3.1.1?



  • @jay_s_uk this problem on version 3.1.1, I'm just wanna try using this new FW.



  • Vertical line gone after using FW Ver 3.2-beta3.2_1. Thanks all. And no jerk again from home to start point.


Log in to reply