Nozzle to high when printing BLTouch



  • Hi,

    I have issue that when I do z probe in home all when i go to G1 Z0 nozzle is 1mm away from build plate, so when print starts it is 1mm higher than it should have. I have done Z probe calibration many times. Mesh bed compensation also. Baby stepping does not work also I put even -0.5 but nothing happens, but it triggers some error that printer is out of limits... Any advice would be great. I am using latest beta firmware.

    homeall.g config.g



  • if you know that its off by 1mm increase the G31 z offset by 1mm



  • Tried that but noting happens, its like this offset is ignored.



  • @jasko

    maybe you set the offset accidentally in
    M558

    M558 P9 X0 Y0 Z0.5 H5 F120 T6000 ; Set Z Probe to type Switch or Digital output where Z probe connector is used. Used for z only.

    x y z should not be part of the M558 command

    also you should adjust your config properly for dual y setup.
    see
    https://duet3d.dozuki.com/Wiki/Bed_levelling_using_multiple_independent_Z_motors#Section_In_RepRapFirmware_Num_3

    M574 Z2 S1 P"io4.in" ; configure active-high endstop for high end on Z via pin io4.in

    are you really using a z endstop switch?

    G1 H1 X-10 Y-10 u-10 F360 ; move slowly to X and Y axis endstops once more (second pass)
    G92 Y0 ;set current position of y axis to 0

    dont do the G92 Y0 in homing



  • At the end of your config you read the stored values. (M501)
    Please check config-override.g



  • @Veti said in Nozzle to high when printing BLTouch:

    M574 Z2 S1 P"io4.in" ; configure active-high endstop for high end on Z via pin io4.in

    I have removed it but nothing changes. 😞

    I'll make those changes for y axis for now it works.

    Should I eliminate z endstop switch? Can i use it for homing but instead of z probe homing? But I would still like to use mesh bed compensation?



  • @DIY-O-Sphere Those are for headed bed, PID tuning.



  • post the output of G31 send in the console



  • This is result of G31:

    Z probe 0: current reading 0, threshold 500, trigger height 0.700, offsets X0.0 Y0.0
    

    This is from config.g:

    G31 P25 X-38.2 Y-11 Z1.447							   ; Set Z probe trigger value, offset and trigger height
    

  • Moderator

    M558 P9 X0 Y0 Z0.5 H5 F120 T6000                     ; Set Z Probe to type Switch or Digital output where Z probe connector is used. Used for z only.
    G31 P25 X-38.2 Y-11 Z1.447								; Set Z probe trigger value, offset and trigger height
    
    ; Z-Probe
    M950 S0 C"io7.out"                                  ; disable heater on PWM channel for BLTouch
    M558 P9 C"io7.in" H5 F100 T3000                     ; disable Z probe but set dive height, probe speed and travel speed
    M557 X50:840 Y50:1050 S100                         ;defining mesh probe grid 
    

    The order of these commands is the problem. You have two instances of M558 and the G31 must come after M558.

    Change it to this:

    ; Z-Probe
    M950 S0 C"io7.out"                                  ; disable heater on PWM channel for BLTouch
    M558 P9 C"io7.in" H5 F100 T3000                     ; disable Z probe but set dive height, probe speed and travel speed
    G31 P25 X-38.2 Y-11 Z1.447								; Set Z probe trigger value, offset and trigger height
    M557 X50:840 Y50:1050 S100                         ;defining mesh probe grid 
    


  • @Phaedrux Thank you this worked.


Log in to reply