Issues homing X and Y axis



  • Hey Guys,

    I apologize if this has been answered already, but I could not find an answer that would help me.
    I am currently trying to setup my ultimaker 2 (Cartesian axis) with a Duet 2 wifi. Here is the firmware list:
    Board: Duet 2 WiFi (2WiFi)
    Firmware: RepRapFirmware for Duet 2 WiFi/Ethernet 3.1.1 (2020-05-19b2)
    Duet WiFi Server Version: 1.23.

    I am having issues with homing X and Y, and most likely Z, but it wont let me home Z until I home X and Y. I have my endstops set as active low, because I think that the ultimaker uses normally open switches. When the switches are pressed the LEDs by the motor ports light up. However, when I press the Home X or Home Y, all that happens is the Z axis drops a little bit, then I get a G28 error saying "Failed to enable endstops". It almost appears that the X and Y axis don't try to move.
    To trouble shoot the issue, I tried switching the endstops to active High. When I did that the Z-Axis would drop a little and it would say that the X or Y axis was homed. I am guess due to the switches being open. It would then allow me to move all the axis with the movement part of the web-control, and everything moved in the correct direction. I have compared my config file to a few others and I can seem to find the issue.

    If you have any information, that would be great.

    Thanks,

    Andy

    config.g
    homey.g
    homex.g
    homez.g



  • post the output of M119 without endstops beeing pressed and with endstops beeing presses.


  • administrators

    Your M574 commands are wrong for RRF3. Instead of this:

    M574 X1 S0 P"xstop"

    Use this:

    M574 X1 S1 P"!xstop"

    Similarly for Y and Z.



  • Hey Guys,

    Thanks for the quick responses.

    With my current settings. When I use the M119 without the endstops being pressing it says X: no endstop, Y: no endstop, Z: no endstop, Z-Probe at min stop. With the end stops pressed I get the same response. X: no endstop, Y: no endstop, Z: no endstop, Z-Probe at min stop.

    I then followed dc42's instructions on turning all M547 commands back to S1. Now when don't have the switches pressed I get X: at min stop Y: at max stop Z: at max stop Z-probe at min stop. When I have the switches pressed I get X: not stopped Y: not stopped Z: not stopped Z-probe at min stop. Which is the opposite of what I need.
    For the wiring setup I have each sensor on the 1st and 3rd pins of the end stop plugins. Is that correct?
    Here is my new code after updating as dc42 instructed.
    config.g

    Thanks,

    Andy



  • @Ace1992 note the exclamation mark in DC42's command pin name. That inverts the pin which is what you want



  • Oh ok. Thank you for clearing that up for me. I completely missed that. I will give that a try tonight.

    Thanks,

    Andy