Makerbot endstop as delta Z-probe



  • Hi, all. I'm trying to use a Makerbot 1.2 endstop as a Z-probe for a delta printer, and I cannot get it to invert properly - it keeps showing 1000 in the dashboard untriggered, 0 triggered. I've got it connected to E0, I've tried all combinations of the M574 and M558 commands:

    M574 E0 S1 P"e1stop" <both !e1stop and e1stop>
    M558 P5 C"e1stop" H10 F120 T6000 I1 <both I1 and i0>

    What am I doing wrong? I'm using the same stops for the X/Y/Z towers and they work fine, but not here. Many thanks - I'm using an inductive probe right now, but I want to switch to a glass build plate.



  • @hairy918 said in Makerbot endstop as delta Z-probe:

    M574 E0 S1 P"e1stop" <both !e1stop and e1stop>

    remove this for z probe on delta you only need M558

    M558 I parameter is not supported in rrf3 inverting is done using ! on the pin.



  • Thanks, Veti - when I remove M558, then it no longer shows up on the console as a Z-probe and the G30 command fails with "Z probe 0 not found". Putting M558 back in, a Z-Probe sensor shows up again, but registers 1000, and the G30 command fails with "Z probe already triggered".

    I should also have said at the beginning, just upgraded to firmware 3.2 using Duet 2 Wifi.



  • @hairy918 Remove the M574, not M558



  • @hairy918 said in Makerbot endstop as delta Z-probe:

    Thanks, Veti - when I remove M558,

    i never said to remove M558



  • @jay_s_uk: Hah! Got it! So it turns out I tried many but not all perumutations. This worked, I didn't have the ! in the M558 command before:

    ;M574 for e0stop (removed)
    M558 P5 C"!e0stop" H5 F120 T6000

    Thanks!!!


Log in to reply