possible error in firmware 3.2x



  • Hello, since I updated to the 3.2.7 shows my Paneldue 7i 0% on the component fan, even though the fan is running ! On the web interface it is displayed correctly ! The error can only be solved once I set the fan to a desired level on the panel due. from this point on, it then also takes over the correct fan setting at the next fan change in the pressure ! I have now fused on the panel due 3.2.9 and the error is still present ! What could that be? First of all, thank you for your ideas. best regards from Germany

    another funny thing is that since the RRF 3 the component fans continue to run when I pause the print and then break ! I always have to turn it off manually !

    Duet Web Control 3.2.0
    RRF 3.2
    config (1).g



  • @wummelfrosch said in possible error in firmware 3.2x:

    another funny thing is that since the RRF 3 the component fans continue to run when I pause the print and then break ! I always have to turn it off manually !

    For the issue of the fans (and heaters) staying on after canceling, you can create a cancel.g file to turn things off. Just use "M106 S0" to turn off the fan. Here's an example that turns off the bed heater, current tool heater and current tool fan:

    M106 S0 ; turn off the current tool part fan
    M104 S0 ; turn off the current tool heater
    M140 S0 ; turn off the bed heater
    


  • @wummelfrosch I too feel paneldue's new version has bugs. In my case, after running following code my view used to refresh itself. But now it kinda stucks. even though temperature is set and is rising but it is not reflected on screen.

    M104 S205 T0
    M109 S205 T0
    M140 S60
    M190 S60
    


  • @garyd9
    ok thank you ! such variant already came to my mind , I would have tried it over the pause.g :-), but I would have thought that such a thing should also go automatically in the RRF 3.2 πŸ™‚

    I will adapt it



  • Hello, is there already a solution for the component fan problem ? Can I do something wrong? at felt one of 10 print it goes and at all other .. Not.
    I slice with s3D

    even if I manually set the fan on the Panel Due it often does not work !


  • Moderator

    @wummelfrosch Sorry, I missed that thread before. In versions of PanelDueFirmware 3.2.6 there was a change that it will only show the fan speed of the first fan of the currently selected tool. In the just released 3.2.10 it will fall-back to fan 0 in case there is no tool selected. Can you please check if this solves your problem? If not, please post your config.g so I can try to reproduce it.

    Also have you assigned the fan to your tool with M563 Pnn Fnn where Pnn is your tool number and Fnn is the fan number (unless it's 0)?


  • Moderator

    @User3D said in possible error in firmware 3.2x:

    @wummelfrosch I too feel paneldue's new version has bugs. In my case, after running following code my view used to refresh itself. But now it kinda stucks. even though temperature is set and is rising but it is not reflected on screen.

    Which version of RRF are you using? This was a known issue in RRF 3.2-beta versions but has been fixed since.



  • @wilriker
    Hello, thank you for the answer. I've tested it and it's not working. I used the latest RRF and until the update of the Panel Due Firmware it still went. I have to say that I use a Chimera Dual WakΓΌ Hotend and always use both component fans, i.e. right and left at the same time. The firmware was created with the Config tool. In the Config.g, the fans are assigned to both tools ( (F 0:1) ! I need no Hotend fan because i use WakΓΌ. That has always been the case and I haven't changed anything about it.

    config (2).g

    I will try the new Firmware bundle 3.2.2 πŸ™‚


  • Moderator

    @wummelfrosch Thanks, I'll check your config next week - unless you report meanwhile that your issue magically disappeared. πŸ˜‰



  • @wilriker using RRF version - 3.3beta


  • Moderator

    @User3D I put this on the list to investigate. But for clarification, this is (if at all) a problem with RepRapFirmware. PanelDueFirmware is only a passive consumer of status updates and if RepRapFirmware does not send them PanelDueFirmware cannot process them.



  • @wilriker
    Hello, nothing changes even after the update to rrf3.2.2. However, I have now noticed the following : if I print with tool 1 it goes ! only with tool2 it is not possible ! I think that could help a lot in the solution. maybe I can fix it with the slicer startcode ?


  • Moderator

    @wummelfrosch I found the issue. The reason is that you have both fans assigned to both tools and when PD sees an update for fan 0 (it only looks at the first fan of each tool anyway) it will search for the tool that this fan is assigned to and will find tool 0 but since tool 0 is not the current tool it will discard this value.



  • @wilriker
    oh super... Thank you very much. Just how can I solve you best? as written above I always need both fans, no matter which tool I'm using


  • Moderator

    @wummelfrosch You cannot solve it, I have to fix it in the firmware (in fact I already did so but need to release it after testing).

    For version 3.3 a revised fan handling is planned so you can control all fans of all tools in all situations. But no work in this direction has yet been implemented.



  • @wilriker said in possible error in firmware 3.2x:

    For version 3.3 a revised fan handling is planned so you can control all fans of all tools in all situations. But no work in this direction has yet been implemented.

    ok thank you. I wait for v 3.3 and would be happy if this change is implemented then πŸ™‚


  • Moderator

    @wummelfrosch I will do a 3.2.11 probably tomorrow before I start working on 3.3.0-beta1.



  • @wilriker

    Great ! I will test it and give you a feeedback again πŸ™‚



  • @wilriker
    at first... sorry for the delay of my reply, because there are a lot of work in business and at home πŸ™‚

    I have testing the Firmware 3.2.11 and it seems to work fine for me πŸ™‚

    Thank you



  • @wilriker there is a "Tool Fan" slider I'm the DWC that controls all of the fans for a tool. Why doesn't the due show that instead?


Log in to reply