Z Axis Homing ..



  • Almost finished.. X and Y axis'are homing properly.. Extruder is extruding .. but Z axis will not home ..

    Z= and Z- move in the proper direction and I commented out the Probe stuff, just an endstop on the I3 at this time ..

    The Z stops maybe 10 mm from the endstop and if I try to go past the endstop, it just keeps going..

    My config ..

    ; Movement section
    M569 P0 S0 ; Drive 0 goes forwards (change to S0 to reverse it) - X
    M569 P1 S0 ; Drive 1 goes forwards - Y
    M569 P2 S1 ; Drive 2 goes forwards - Z?
    M569 P3 S0 ; Drive 3 goes forwards - Extruder
    M569 P4 S1 ; Drive 4 goes forwards
    M574 X1 Y1 Z1 S1 ; set endstop configuration (X and Y and Z endstops only, at low end, active high)

    M208 X200 Y250 Z200 ; set axis maximam (adjust to suit your machine)
    M208 X0 Y0 Z0 S1 ; set axis minimum (adjust to make X=0 and Y=0 the edge of the bed)

    my homingz

    ; Z homing file for Prusa i3 or similar printer using a Z probe for Z homing
    G91
    G1 Z5 F200
    G90
    ;G1 X100 Y100 F9000
    ;G30
    ; Un-comment the following line if you want the head to actually move to Z=0 after homing
    G1 Z0 F200

    Any help would be appreciated .. Can see the light at the end of the tunnel .. though adding a probe will be next ..
    Regards


  • administrators



  • Perfect ..
    Thanks again ..



  • If I may join in on this, I'm having troubles with Z homing too. I have an NPN NO inductive sensor connected to the E0 endstop header, I did what it says in the link @dc42 sent, but when I send G30 (no parameters, but I also tried the current X/Y, with no difference) the head moves to 0/0 AND BEYOND, mashing the Y axis and grinding the belt. This is after I homed the X/Y axis of course. Version 1.19RC5.



  • ; Z homing file for Prusa i3 or similar printer using a Z probe for Z homing

    You have a switch, right?



  • Yes, but the Z probe is configured in mode 4, switch mode, as per instructions in the wiki.



  • Ok, just wanted to make sure that wasn't the issue. Does the switch change when you run M119? Is there a difference in the Homing files between switch and probe? I haven't looked at the wiki for your particular printer.



  • ; Z homing file for Prusa i3 or similar printer using a Z probe for Z homing
    G91
    G1 Z5 F200
    ;G1 X100 Y100 F9000
    ;G30
    ; Un-comment the following line if you want the head to actually move to Z=0 after homing
    G1 Z-200 S1 F100 ; move Z down until the switch triggers
    G90 ; back to absolute mode
    G92 Z0.3 ; tell the firmware that we are at Z=0.3mm

    What happens if you try this?



  • Sorry, krzaku, thought I was talking with the OP.



  • G1 S1 for Z axis doesn't work, because the Z probe is not connected to the Z endstop port, but to the E0 endstop.


  • administrators

    Actually it will work if you include the Z1 parameter in the M558 command and Z0 in the M574 command, because then the Z probe will be used as the Z endstop too. However, that's not what you should be doing; if you want to home Z using a Z probe you should use G30 not G1 S1.



  • That's exactly what I've been doing, and it's grinding the belt like I said. According to the wiki, G30 with no parameters shouldn't move the head at all. I also tried G29, and it goes to the same position at the start as G30, grinding the belt as well.


  • administrators

    G30 with no parameters will move the head down until the Z probe triggers.

    Have you tested the Z probe? i.e. gradually lower the head towards the bed ands watch the Z probe reading in DWC. For a switch-type Z probe, the reading will change from 0 to 1000 when the probe triggers.



  • But it shouldn't move the head in the X/Y axis, should it? And yes, the probe is working for sure. I also tried it in switch mode, connecting it to the Z endstop header, and homing (with G1 S1) worked fine then. Even if the probe wasn't working, it wouldn't explain why the carriage mashes the Y axis and tries to go beyond while grinding the belt.


  • administrators

    G30 with no parameters should not move the head in the XY plane. Are you finding that it does? If so, please let us know which firmware version you are running, what commands you are sending prior to G30, and post your config.g file.



  • The G30 moving in X and Y sounds awfully like deploy probe is being run. That's exactly what I ran into when upgrading to one of the 1.19 releases (can't remember which one) and I should have read the release notes which state that the deploy and retract probe files should be deleted from .sys. Once I deleted those files (in accordance with the release notes), G30 worked as expected.



  • @deckingman that's it! Removing those files fixed my issue. I skimmed over the release notes, when I should've read them more closely…


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.