M997 S0 suddenly stopped working



  • The SD card appears to be working correctly. Macros and gcodes are viewable from the screen.

    From the screen, M21 outputs "SDHC card mounted in slot 0, capacity 7.95GB" and M39 outputs "SD card in slot 0: capacity 7.95GB free space 7.71Gb, speed 20.00MBytes/sec, cluster size 64kb"

    I used to use "M997 S0" from the screen to make the Duet load the new Duet2CombinedFirmware.bin file. Normally the screen would output dialog saying that its installing new firmware.

    But instead, it seems like the Duet just power cycles. The behavior appears identical to pressing the STOP button.

    Has this happened to anyone before? How did you fix it?

    Note I'm using Firmware version 2.01 on DuetEthernet. M997 S0 had been working fine for many months.



  • why are you still on 2.01?

    it could be that the iap programmer on the sd card got corrupted.

    try downloading it from here.
    https://github.com/Duet3D/Duet-2-Hardware/tree/master/Duet2/SD Card Contents/sys



  • @jml said in M997 S0 suddenly stopped working:

    Firmware version 2.01

    What is the new firmware you want to flash? If it's RRF3.1 or later, you have to flash RRF3.0 first...



  • I’m on 2.01 because I had edited the firmware slightly back in those days and didn’t ever upgrade to anything newer. What I’m trying to upload is a modified 2.01 (simple custom gcode modification). I have been doing this for weeks on this Duet but it suddenly stopped working. I’ll try the download what was suggested above, thank you.



  • Thank you for the suggestion. I downloaded the new Iap4 file, it did not help unfortunately.

    I tried replacing the sys folder with a backed up sys file from November which I know had worked back then, but it also has the same result - M997 S0 just restarts the printer instead of installing new firmware.

    The SD appears to work fine - I can launch a print or macro from the screen no issues there.

    I have internet problems but can try uploading via DWC when it gets fixed. Is that worth a try, or do you think it might be something else? Should I try doing M997 S0 through USB connection? I have been doing it through the screen.



  • I just tried via USB and mac terminal. Same response. M115 works fine. M997S0 just resets the board and the screen has no message or reaction.


  • administrators

    @jml

    can you try 2.5.1 clean install using Bossa, with the SC card contents having the 2.5.1 wifi server etc. If that works then its something weird with your 2.0.1 version.



  • Thanks Tony I'll try that. Will let you know in a day or two, thanks!



  • @T3P3Tony for the 2.5.1 wifi server, do you mean DuetWifiServer1.23.bin? That is the one I see here:
    https://github.com/Duet3D/RepRapFirmware/releases/tag/2.05.1

    I'm using the DuetEthernet by the way, and don't have my internet working currently, so maybe it doesn't matter.


  • Moderator

    @jml If you have a Duet Ethernet the wifi server is irrelevant.



  • I tried a different Duet board and put the same 4 folders (and firmware) onto the SD. M997S0 worked fine (whereas the same 4 folders on the previous Duet didn't work).

    On closer inspection I saw that the fan fuse was actually broken. I had replaced that fuse a while ago and the new one must have been damaged when inserting it in with pliers. I don't think that is the issue though because I then shorted the fuse manually with a metal piece and M997 still didn't work.

    I don't have the time to troubleshoot the anti-M997 Duet board much, but I'm going to classify it as a hardware/electrical issue that probably happened when there was a fan-related short.


  • Moderator

    Take a close look at the other chips and see if you can spot and scorched. Sounds kind of like a short took something out.


Log in to reply