Duet3 : DCS is not started



  • Hello everyone,

    I have been trying for 3 days know to make DuetWebControl work and I always get the same message :"Failed to connect to Duet, please check your connection (DCS is not started)."

    here is what I am currently using (Duet3 MB6HC + RPI4).

    • Fresh SD card with : 2021-02-15-DuetPi.img installed
    • I have successfully run
      sudo apt update
      sudo apt upgrade
    • I have also tried to install the last Duet Firmware using BOSSA which went ok.
    • I have no SD card in my Duet (only in the Pi)
    • I am powering the Duet from a usb Hub (My jumper for 5v selection is well setup
    • My Diag led is constantly blinking.

    Do you have any idea on what I should do ?

    Thanks 🙂



  • can you get the duet 3 up and running in standalone mode and confirm you are running the latest firmware? i.e. 3.2.2



  • There is no other way to see which firmware is install on the duet other than switching to standalone mode?

    In order to switch in standalone mode, il need to prepare a SD card with the good structure and send a M115 via BOSSA right?


  • administrators

    @reFlexlab said in Duet3 : DCS is not started:

    In order to switch in standalone mode, il need to prepare a SD card with the good structure and send a M115 via BOSSA right?

    If the RRF version is recent then any SD card will do, even a blank one. Connect using YAT or another terminal emulator.



  • Hello,
    I have just run the Duet 3 in standalone mode and connected myself via Yat and sended a M115 command, here is what i get :

    M115
    FIRMWARE_NAME: RepRapFirmware for Duet 3 MB6HC FIRMWARE_VERSION: 3.2.2 ELECTRONICS: Duet 3 MB6HC v1.01 or later FIRMWARE_DATE: 2021-02-11
    ok


  • administrators

    That's looking good so it sounds like you may have a dodgy connection between the Duet and the Pi. And of course make sure to remove the microSD card again from the Duet before you power it up for SBC mode.

    When you have the Pi started and you see the error message again, please do the following:

    1. Press F11 to leave fullscreen mode
    2. Open a terminal
    3. Run sudo journalctl -u duetcontrolserver -ef
    4. Check what error message is reported when DCS starts


  • Thank you Chris,

    Here is the error message that I get :

    "Could not connect to duet (Timeout while wainting for transfer ready pin)"
    duetcontrolserver .service : Failed with result 'protocol'





  • can you post a photo of the connection between the duet and the SBC?


  • administrators

    Yes, I suppose there is a problem with the connection of pin 22 from the Duet to the Pi. Any chance you can measure the continuity of that particular pin of the ribbon cable?





  • @chrishamm Apparently, there is continuity .

    Here what we used to check it .

    IMG_20210217_154404.jpg IMG_20210217_154446.jpg


  • administrators

    @reFlexlab Thanks for test this. There are a few more things you can try next to help identify if the problem is the Duet or the Pi:

    1. Please check the continuity of that particular pin with the ribbon cable connected to both sides, that is to the Duet and to the Pi.
    2. With the ribbon cable disconnected from the Pi, connect pin 1 of the RaspPi (3.3V) to pin 22 of the expansion header. Then run gpioget gpiochip0 25 from a terminal. It should output 1 to indicate that the transfer ready pin reads +3.3V. If it reads 0 even with the cable connected, the Pi is damaged and you should replace it.
    3. If it worked, power up the Duet via USB and turn it around. You can then measure the voltage between GND and TfrRdy (pin 22), which should again read +3.3V.


  • @chrishamm said in Duet3 : DCS is not started:

    0

    Thank you , I have tested this setup and the Terminal output 0, when i test for the Raspberry Pi.

    I have also tested the tension between Ground and PIN 22 on the expension Header of the Duet, which output 0 volt

    I will send you the photo of our setup.



  • IMG_20210218_182508-min.jpg IMG_20210218_182503-min.jpg


  • administrators

    @reFlexlab You are not testing with the right pins (see https://pinout.xyz/pinout/pin22_gpio25#) because your cable is connected to GND. When you connect the jumper cable to the +3.3V pin, make sure you do not connect it to +5V, else you'll break your Pi. The previous photo looks OK though.

    If the TfrRdy pin on the Duet stays at 0V even with no SD card in the Duet and RRF 3.2.2 running, I suspect the board is damaged. If you can confirm that you probed the correct pin on the Duet side, I suggest you do a warranty exchange.



  • @chrishamm
    Hello,
    1 - I will test with a new raspberry Pi this afternoon to see if it changeg anything.

    2 - I will send you a photo of my experimental setup to check the Trfdy Pin is working on the Duet.

    If the board is damaged, How its working to make a waranty exchange ?

    Tom



  • @chrishamm
    Hello Chris,

    1- I have retested the Raspberry Pi with the right pin using the

    gpioget gpiochip0 25
    

    here are the results

    IMG_20210225_093759-min.jpg IMG_20210225_093750-min.jpg

    2 - Regarding the Duet, I have tested the TrfRdy Pin again and it seems to display 0 V.
    I think the Duet is Borken.

    IMG_20210224_190202-min.jpg IMG_20210224_190018-min.jpg

    I think i know why this happened :

    I use a power a 24V MeanWell power supply, I think i reversed the VIN + and - . But after reading the How To destroy your Duet I saw that modern power supply could not cause this because of a protection.

    Thank you for your Help.

    Tom


Log in to reply