Hotend always on after updating RRF3



  • Hi,
    I've just updated to RRF3 and I've noticed that the hotend (hetear 1) is already active when I turn on the printer (even if the power supply is off). Look at the picture
    heater on.jpg

    This is my config file:

    ; Drives
    M569 P0 S1 ; physical drive 0 goes forwards
    M569 P1 S0 ; physical drive 1 goes forwards
    M569 P2 S1 ; physical drive 2 goes forwards
    M569 P3 S1 ; physical drive 3 goes forwards
    M584 X1 Y0 Z2 E3 ; set drive mapping
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400.00 E408.50 ; set steps per mm
    M566 X900.00 Y900.00 Z60.00 E120.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z1500.00 E3600.00 ; set maximum speeds (mm/min)
    M201 X2500.00 Y2500.00 Z50.00 E1500.00 ; set accelerations (mm/s^2)
    M906 X1200 Y1200 Z1200 E1200 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X310 Y315 Z265 S0 ; set axis maxima

    ; Endstops
    M574 X1 S1 P"xstop" ; configure active-high endstop for low end on X via pin xstop
    M574 Y1 S1 P"ystop" ; configure active-high endstop for low end on Y via pin ystop
    M574 Z1 S2 ; configure Z-probe endstop for low end on Z

    ; Stall Detection
    ;M915 X Y S7 F0 H200 R2 ; X and Y motor stall detection

    ; Z-Probe
    M558 P1 C"zprobe.in" H5 F250 T6000 ; set Z probe type to unmodulated and the dive height + speeds
    G31 P500 X0 Y0 Z1.20 ; set Z probe trigger value, offset and trigger height
    M557 X50:260 Y20:230 S105 ; define mesh grid

    ; Heaters
    M308 S0 P"bedtemp" Y"thermistor" T100000 B4138 ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0 ; create bed heater output on bedheat and map it to sensor 0
    M307 H0 B0 S1.2 ; disable bang-bang mode for the bed heater and set PWM limit
    M140 H0 ; map heated bed to heater 0
    M143 H0 S100 ; set temperature limit for heater 0 to 100C
    M308 S1 P"e0temp" Y"thermistor" T100000 B4138 ; configure sensor 1 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1 ; create nozzle heater output on e0heat and map it to sensor 1
    M307 H1 B0 S1.00 ; disable bang-bang mode for heater and set PWM limit
    M143 H1 S280 ; set temperature limit for heater 1 to 280C

    ; Fans
    M950 F0 C"fan0" Q1000 ; create fan 0 on pin fan0 and set its frequency
    M106 P0 S0 H-1 ; set fan 0 value. Thermostatic control is turned off
    M950 F1 C"fan1" Q1000 ; create fan 1 on pin fan1 and set its frequency
    M106 P1 S1 H1 T45 ; set fan 1 value. Thermostatic control is turned on
    M950 F2 C"fan2" Q1000 ; create fan 2 on pin fan2 and set its frequency
    M106 P2 S0 H-1 ; set fan 2 value. Thermostatic control is turned off

    ; Tools
    M563 P0 S"Hotend" D0 H1 F0:2 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Miscellaneous
    M501 ; load saved parameters from non-volatile memory
    M911 S22.5 R23.5 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; set voltage thresholds and actions to run on power loss
    T0

    I've already checked the onboard leds: 3.3V is on, 5V is on, e0 Heat as well as Bed Heat are off.
    I've also tried to add "M104 S0" in confing.g but it doesn't work.

    Any advice is welcome. Thanks.



  • @zecchi

    It's active because you have a T0 at the end of your config.g. The temperature is 0 so it's active but not on if that makes sense.



  • Removing T0 at the end of config.g the hotend is no more active but in standby. Is there any way to shut it down?



  • @zecchi I'm not sure but why do you want to? You don't have an active or standby temperature set so it's not going be "On"



  • @Rushmere3D yeah, it's true, it was only to see "off" 😁
    thank you



  • active does not mean its heating.
    it means this tool has been selected



  • @Veti yeah, I've noticed. Thank you for the info



  • @zecchi A "T" followed by negative number will deselect a tool. So using T-0 might make it show as off rather than active at zero degrees. Don't know for sure as I always like to select at least one tool in config.g (because one can't extrude anything until a "Tn" command has been sent.)



  • @deckingman unfortunately T-0 (or any negative value ) doesn't work. At this point I'll leave "T0", as others say there is no difference for me. thank you all!


  • Moderator

    Usually people have the opposite problem where they don't have T0 in config.g and then wonder why the temperature won't change and don't realize that a tool must be selected first.

    Using G10 P0 R0 S0 sets the temps to 0, so in effect, "off". T0 selects the tool, so that it is ready to accept a temperature command.


Log in to reply