Duet Wifi never responds using SAM-BA



  • Heya - running in to some issues here with duet wifi. Here's the steps I went through:

    1. Noticed the wifi was no longer responding. I went over to pronterface.
    2. Proterface didn't recognize the port. It failed to find the device. Also in the device manager, it says it failed to recognize the device.
    3. I reset the firmware with the button on the board.
    4. Downloaded, installed, and ran sam-ba 2.17 - it looks like it recognizes the device since the board at91cap9-dk_mem18 shows up, and it finds the connection on \USBserial\COM3.
    5. After clicking connect, it never responds.
    6. After giving it a few solid minutes to connect, unplugging the usb device gives me an error saying it can't connect. (So this is why I'm guessing it's hanging.)

    Anything else I should check before pinging filastruder (the US distributor) for a replacement? (I really love this board. I think I'm just having bad luck.)

    Edit: Tried a second USB cable to rule that out and a second computer. No dice. Also tried Sam-ba 3.2 as well.
    Edit 2: Also - anything info I should grab off the board (like a serial?) After reading another similar thread it's looking like I'll have to return it. So I'm going to start preparing for that.



  • change the selected board to the at91sam4e8-ek it is a bit down the list but that should fix this issue. Please let me know if it does.



  • @pogo1213 Holy crap you're a ninja!

    I'm connected now! 😄 I'll let ya know how it goes. Thank you!



  • Thanks man! 😄 Firmware is updated and it matches. Apologies for glossing over that detail in the wiki. It's right there. 😄



  • Sounds great! there is a lot of info in the documentation, its easy to speed read past something.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.