Fan 1 setting



  • Hi,

    So finally I have received my DuetWifi and my Paneldue and they are awesome. Now, I wired my heatsink hotend fan to F0 and I configured it as a thermostatically controlled fan and is working great. ( running over 50 degree and shutting down under 50 ). But my F1 fan witch is the Print cooling fan in my case, is running everytime I switch on the printer till I shut it down (I have connected to F1 pins not to always on fan pins) even tough I have set it as a G-code controlled fan. Here's my Gcode:

    ; Fans
    M106 P0 S1 I0 F500 H1 T50 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P1 S1 I0 F500 H-1 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P2 S1 I0 F500 H-1 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned off

    If I send M106 P1 S0 from my web interface F1 will shut down. I want this fan working only when I start a print. How can i do this?

    Thanks!

    BTW for developers, the thing with the online service for costumizing firmware and uploading it as a zip on the web browser straight on DuetWifi is genius. Congrats!



  • I got the same issue and in fact FAN1 is at startup already configured as a thermostatic fan to be used for the heatsink.
    It is a logical choice to do that for one of the fans. If you have a short power failure and the hot end is still hot while recovering, you want that fan to be on too. Other choice would be a permanent on fan…

    I left that FAN1 as heatsink fan and took FAN0 as partcooler.

    see here : https://www.duet3d.com/forum/thread.php?id=2417



  • I got you but….... If I reverse the connections ( Heatsink fan to F1 and Print fan to F0) I'll have now the heatsink fan running continuously (and print fan running over 50 degree) and i want him running only over 50 degree like is set now. The problem is that I don t know how do I set my print fan witch is connected to F1 pins to be gcode controlled by the gcode file( for example when I do a print, i want F1 to start at second layer of the print)



  • You need to link that fan to the tool, with M563:

    M563 P0 D0 H0 F1

    So, the M106 command will use that fan when the tool 0 is selected.


  • administrators

    I'm confused, which fan is connected to which output now?

    The recommended connection is:

    Print cooling fan (controlled by the slicer) to FAN0
    Hot end heatsink fan (thermostatically controlled) to FAN1

    If you use these connections, then you may not need to use M106 commands in config.g at all, because the defaults are suitable for most fans.



  • Ok so for simplicity I've done what dc42 said to do (earlier the connections were reversed). Now my print cooling fan is connected to F0 and my hotend heatsink fan is connected to F1. My config.g looks like this:

    ; Fans
    M106 P0 S1 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T50; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H-1 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned off

    Now my heatsink fan (F1) is working properly (over 50 degree is running and shutting down under 50 degree) but still my print fan witch is F0 is always on when I switch on the printer till I switch it off. I don t want to be like this. I want to be off everytime I switch on the printer till I start a print and then it's controlled by the gcode generated from slicer. How can I do this?



  • The "S" parameter turns that fan on or off https://duet3d.com/wiki/G-code#M106:_Fan_On. So change S1 to S0 in the M106 P0 line of your config.g file.



  • Thanks alot deckingman. Problem solved. I passed over that page , I'm sorry for this. So the thread can be closed as solved so others can learn.

    Thanks alot!


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.