Problem bed probing after firmware update with new Smart Effector



  • Hi
    I have just completed the installation of the new smart effector, it is probably the best upgrade to date, amazing!

    I have come across an issue however after upgrading the firmware and have no idea what is happening, why or how to troubleshoot.

    I have been using 1.18.1 with no issues and been able to run auto calibration with a bed.g file generated from here http://www.escher3d.com/pages/wizards/wizardbed.php

    Now the new Smart Effector is installed I tried to update the firmware as per the instructions to latest stable 1.19 version. I successfully completed the upgrade and reconnected to the Wifi.

    The issue then arises when I run the auto calibration, the process begins but it does one probe, then goes up approx 50mm slides sideways slowly, then does another probe but doesn't reach the bed, rises and does the slide again, then does another probe and so on.

    Have there been some changes in the behaviour of the Gcode that would cause this, or is there something else I have missed?

    I have now downgraded to 1.18.2 and the auto calibration does a 13 point probe perfectly - and with incredible accuracy.

    Does anyone know what I have done wrong?



  • You have to delete probe deploy and retract files from the sys folder - I made the same mistake



  • Ditto over here
    Just delete them and be amazed 🙂



  • Awesome - all working again, thank you


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.