How Do I Calibrate My Titan Extruder and Test Print?



  • My printer now has a Titan extruder with a Volcano hotend and a 0.2mm nozzle.

    I don't know how to configure the system files for the stepper or the slicer code for the print in Duet. I've done it for Marlin, but not Duet.

    Currently, my extruder settings and extruder plasters the bed with PLA, and didn't properly run the start code that I had been using for Cura.

    I need a complete calibration for printing really.



  • In config

    M350 X** Y** Z** E16 (1.8 stepper motor)
    M92 X** Y** Z** E419 ( Mine was changed to 405.69 to push 100mm of measured filament when commanded,

    If you have a bowden setup this is easy, remove tube from hotend feed out some filament. Cut off filament even with end of tube.
    command 100mm of filament, measure and adjust the 419 number until it matches.

    Direct feed will require you to remove hotend so I just go with 419 and change the multiplier.



  • I think with Cura you need to include M82 in the start g code.



  • @number40fan:

    I think with Cura you need to include M82 in the start g code.

    It probably defaults to absolute extrusion or, at least Cura always used to. However the default configuration for the Duet is to have M83 in config.g so the Duet expects extruder moves to be relative. So yes, putting M82 in the Cura start gcode file will tell the Duet that the extruder moves are absolute. The OP can either put M82 in the start gcode or in config.g if he is always going to use Cura. I believe that if neither M83 nor M82 are present, Duet will default to absolute (M82) when it first boots up but this may have changed.



  • This is the start code I used to have on my Marlin printer:
    Start Code
    M280 P0 S160
    M420 Z2 ; set fade leveling at 2mm for BLTouch (OK to send for Non BLTouch)
    G28 ; home all
    G29 ; bed probe
    M82 ; relative extrusion
    G92 E0 ;zero the extruded length
    G1 X0.0 Y50.0 Z10.0 F3600 ; perform wipe and prime
    G1 Z0.0 F1000
    G1 Z0.2 Y70.0 E9.0 F1000.0 ; prime
    G1 Y100.0 E12.5 F1000.0 ; prime
    G92 E0 ; zero extruder again
    M117 Printing…

    I tried changing M82 to M83 and it still didn't work. I then made this start code in a new version of Cura, but it also doesn't work, meaning it simply poos PLA on the board. It also doesn't begin drawing the brim for the test cube they way it normally does. It squirts a big glob in each of the four corners of the brim.

    M190 S65
    M104 S210
    M109 S210
    G21 ;metric values
    G90 ;absolute positioning
    M83 ;set extruder to relative mode
    M107 ;start with the fan off
    G28 X0 Y0 ;move X/Y to min endstops
    G28 Z0 ;move Z to min endstops
    G1 Z15.0 F9000 ;move the platform down 15mm
    G92 E0 ;zero the extruded length
    G1 F200 E3 ;extrude 3mm of feed stock
    G92 E0 ;zero the extruded length again
    G1 F9000
    ;Put printing message on LCD screen
    M117 Printing...

    I also don't have any config values changed since updating the firmware, such as what @JMJCOKE is mentioning. I'd imagine extrusion rate has something to do with it as well...



  • What I really need to do is go through this whole process from scratch, instead of trying to patch it.

    Does anyone have a process from step 1 through to completion?



  • https://duet3d.com/wiki/Duet_Wiki

    I guess you could delete everything on your SD card and start there.



  • Or, post your complete Config.g file and let someone take a look at it.


  • administrators

    Cura uses absolute extruder movement so you need M82 in your start gcode or config.

    The large overextension at the start of each line is indicative that this is the issue.



  • ; General preferences
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates…
    M83 ; ...but relative extruder moves
    M555 P2 ; Set firmware compatibility to look like Marlin
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X340 Y250 Z280 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 Z1 S0 ; Define active low and unused microswitches
    M558 P5 X0 Y0 Z1 H10 F200 T6000 ; Set Z probe type to modulated, the axes for which it is used and the probe + travel speeds
    G31 X-44 Y0 Z7.03 P50 ; Set Z probe trigger value, offset and trigger height

    ; Z-offset (Z0.9). Higher value LOWER nozzle height
    ; Lower value RAISE nozzle height

    M557 X10:340 Y10:240 S68 ; Define mesh grid

    M307 H3 A-1 C-1 D-1 ; disable heater 3, which makes it available for use to control the BLTouch

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards - X
    M569 P1 S0 ; Drive 1 goes backwards - Y
    M569 P2 S0 ; Drive 2 goes backwards - Z
    M569 P3 S1 ; Drive 3 goes forwards - Extruder

    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation 16
    M92 X160 Y160 Z1600 E615 ; Set steps per mm 16

    M566 X600 Y420 Z12 E120 ; Set maximum instantaneous speed changes (mm/min) - (JERK)

    M203 X6000 Y6000 Z500 E400 ; Set maximum speeds (mm/min)

    M201 X1000 Y1000 Z1000 E250 ; Set accelerations (mm/s^2)

    M204 P1000 T1000 ; Set Max acceleration for P=printing moves and T=travel moves
    M906 X1600 Y1600 Z900 E1000 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Heaters
    M143 S285 ; Set maximum heater temperature to 285C

    M305 P0 R4700 T100000 B3950 ; Set thermistor + ADC parameters for heater 0 - BED
    M305 P1 R4700 T100000 B3950 ; Set thermistor + ADC parameters for heater 1 - HOTEND

    M307 H0 P96.0, I3.285, D603.9 ;Bed
    M307 H1 A250 C999 D4.5 B0 S1 ;Hotend

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Network
    M550 PCLU ; Set machine name
    M552 P0.0.0.0 S1 ; Enable network and acquire dynamic address via DHCP

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Custom settings are not configured



  • @T3P3Tony:

    Cura uses absolute extruder movement so you need M82 in your start gcode or config.

    The large overextension at the start of each line is indicative that this is the issue.

    Noted. Although, putting the test print aside, simply extruding 100mm of filament shows it's being fired out at speed, and only 80/100mm at best. I need it to extrude 100/100mm approximately, and at the appropriate speed


  • administrators

    Ok so let's fix that first what's your extruder max speed set to in config.g? Also try sending G1 E10 F200 and then play with the F value to see what speeds are sensible. On the we interface the higher speeds are only appropriate for.loading/unloading filament and are much to fast for extruding.



  • @T3P3Tony:

    Ok so let's fix that first what's your extruder max speed set to in config.g? Also try sending G1 E10 F200 and then play with the F value to see what speeds are sensible. On the we interface the higher speeds are only appropriate for.loading/unloading filament and are much to fast for extruding.

    I thought maybe the extruding speed would be relative to the print…

    If the layers are a certain height, and the nozzle is a certain size, then it would guide the speed to suit. Unless the Duet is all about complete control. I've never had to set the extruding speed before. Print speed, yes, but not extruding.

    I'll punch those gcodes in and have a play with the settings. I guess the immediate issue I'm going to have, if I've understood the process correctly, is that it maybe printing 100% of the filament in an approximate time, possibly more or less than what's required to make a good print. I bought the Duet because I really wanted the fine control of the drivers, with 0.9 degree motors, etc. So I have to get this right to make good use of everything else.



  • During a print, the extruder speed is indeed relative to head movement. What Tony was referring was the fact that you said

    "putting the test print aside, simply extruding 100mm of filament shows it's being fired out at speed, and only 80/100mm at best."

    So when you do that - i.e. extrude filament via the web interface, it will come out at whatever speed you selected in the web interface. Generally, anything above 5 mm/sec should only be used for unloading filament.

    Edit. If you just use a search engine in put in "calibrating extruder", you'll find numerous examples and YouTube videos of how to do it. To get you somewhere in the right ball park, the Titan will need in the order of 400 steps/mm using 1.8 degree motors and 16 X micro stepping. If you use 0.9 degree motors, you'd need to double it to around 800.

    HTH



  • OK, I see.

    I've done an extruder calibration before. The problem I'm having is that it's not showing the results as expected, which is why I'm checking on a DuetWiFi specific process.

    For example, I just adjusted the extruder steps like so:

    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation 16
    M92 X160 Y160 Z1600 E420 ; Set steps per mm 16

    This extruded 80/100mm, so I changed it to this:

    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation 16
    M92 X160 Y160 Z1600 E380 ; Set steps per mm 16

    This extruded 82/100mm, so I changed it to this:

    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation 16
    M92 X160 Y160 Z1600 E200 ; Set steps per mm 16

    And it finally extruded 48/100mm.

    I can't get it closer than 80% feed.

    Can I steal someone's config.g who has a Titan? I need to compare my gcode I think.



  • I have 5 Titans (Diamond 5 colour hot end). With 1.8 degree motors, the calibrated steps per mm are

    M92 X80 Y80 Z3200 E393:397:403:400:401 ; Set steps per mm

    So between 393 and 401 on my machine. If you are running 0.9 degree steppers, then I'd expect your value to be double, so in the order of 800.

    Edit. I'm concerned about the way you are calibrating the extruder. Something is very wrong. You start with 420 steps which you say gives 80mm. Then you drop it to 380 steps. That should give you (80/420*380) 72mm yet you got 82 mm. So something isn't right. Are you doing this with the extruder connected to the hot end and the hot end heated or do you have the extruder disconnected form the hot end? If it's the former, do the latter. Also, check your extruder tension - something may be slipping. Do you have a good mesh between the gears? Are you simply trying to do it at too high a speed? Do it at a slow feed rate like around 5 on the web interface. Don't use the same piece of filament over and over again. Once it has been through the extruder, the hobbed bolt will have made grooves which will affect the diameter of the filament if you try and use that same section again.



  • OK, I just took a closer look considering some of your pointers.

    I found that the extruder filament cog spins halfway through the 100mm extrusion. I think the filament is backing up in the hotend and preventing the fed filament from being pushed in by the extruder.

    The nozzle is a .2mm, I think. What could be causing the congestion? It's been heated to 210c before extrusion and is brand new. Is there an indicator for the nozzle size somewhere? Or is this another issue?



  • It sounds very much like a partial blockage and/or you are simply extruding too fast.

    0.2mm is very small and rather specialised - designed for very small intricate parts that are to be printed slowly. Unless you really need very fine details, I'd suggest you go for a 0.4 or 0.5mm nozzle. Are you really sure it's 0.2mm? - that's unusual for a Volcano which is really intended to take 0.8mm upwards. Also, is it a Volcano nozzle and not a "normal" V6 one. I believe that they are not interchangeable and you must use Volcano nozzles with Volcano heat blocks. Wait…...........

    ..............I've just done a quick check on E3D's site and I can see that the smallest Volcano nozzle is 0.4mm and they go up to 1.2 mm, so your nozzle can't be a 0.2mm Volcano.

    So to calibrate your extruder steps per mm, disconnect the extruder from the hot end, extrude 100mm and alter the steps per mm until you get 100mm. As I said before, to get you in the right ball park, start with 400 steps/mm (at 16X micro stepping) if you are using 1.8 degree steppers (200 steps per rev) or 800 steps/mm if you are using 0,9 degree steppers.

    Once you have the steps per mm calibrated, then you can go on to investigate the cause of the extruder grinding away the filament, some possible reasons for that are detailed above. I would suggest that you do not alter the steps per mm again - all that is doing is trying to correct for a problem that lies elsewhere, rather than address the root cause of the problem.
    HTH



  • I meddled with the extruder steps for a while, and it calibrated fairly well a 440 steps/mm. I just used the 5mm extrude in the console, and counted 20 extrusions for a 99/100mm total.

    I'm not sure what the deal is with the speed of the extruder. I've never had this problem with the Tevo factory extruder or hotends. It's a Volcano yes, and came with the Tevo Titan Volcano kit. Changing the extruder speed on the console down to 1mm/second still didn't seem to slow the 100mm extrusion down. It just continues to power through, causing congestion.

    At least at this point I know the calibration is rightfully E440. It shouldn't congest on 100mm extrusion, like the earlier versions of this printer's setup. I have to fix it before I move onto slicer troubles. Cura gcode makes the Duet squeeze out an entire layer of filament in each corner of the test cube print, before moving to the next corner and doing the same thing.



  • Well the Cura gcode thing is likely because, as has been mentioned earlier, Cura uses absolute extrusion whilst the Duet is expecting it to be relative because there is an M83 command in your config.g file. So, as has also been mentioned, you need to put M82 in either the Cura start gcode or if you are always going to use Cura, put it in you config.g instead of M83.

    I really can't understand why using 1mm/sec on the DWC does not slow the extrusion speed down. It works for everyone else.

    As you have managed to extrude 100mm (by doing 20 x 5mm extrusions) with the hot end disconnected then it's a fair bet that the "congestion" is caused by a blocked or partially blocked nozzle or the temperature is too low to melt the filament don't you think? It's easy enough to check. Just remove the nozzle, enable cold extrude (can't remember the gcode for that - you'll have to look it up), then try extruding 100mm of filament. If that works, then the only thing you have taken out of the equation is the nozzle (and heater) so that's where the problem lies.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.