Please help with bed causing severe voltage drop



  • Attempting to convert an Anycubic Kossel Linear Plus to DuetWifi/Smart Effector/PanelDue/E3D hotend. Everything is working better than ever with this combo, except the existing heatbed. All 12v system, everything was working fine before conversion, but wanted more processing than their RAMPS clone could provide.

    Problem:
    When I turn on the heatbed, the voltage drops to about 10v, and the steppers start stuttering and missing steps. I don't have specs on the existing heatbed, but the cold resistance is 1.6 ohms, which if I'm calculating correctly means 7.5A at 12v. The original TriGorilla board could drive this fine and is only rated for 11A. When attached to the DuetWiFi and turned on, the power supply (cheap 250W/20A) starts rattling from the heavy load, and both the Duet and an external meter show a drop to 10v.

    In case it matters, this is a round 240mm diameter aluminum disk with the heating traces stuck to the bottom and wires soldered to them. A thermistor is taped to the bottom with kapton tape.

    First thought: bad connections. Reconfirmed and as far as I can tell all are tight. Using well-crimped crimp-on ends on both power into the Duet and on the bed power lines.

    Note that heating the bed (without printing) works fine (except for the voltage drop) and the bed heats up possibly a bit faster than before, but generally how I expect it to act temp-wise. Doesn't appear to have been damaged during the system rebuild.

    Moved to a MeanWell 350W 29A PS. Voltage still drops, but now there's enough power to run the steppers correctly.

    Moved the bed onto an external MOSFET board with a separate power line from the PS. Still seeing the severe 10v voltage drop. When the bed turns on, the white LEDs on the smart effector dim appreciably.

    Had the thought that the Duet might have a short internally on the bed circuit, but I don't see the drop if the bed is detached when turning on heater 0, and also do see it with the mosfet attached and presumably drawing all bed power directly from the PS and not through the Duet.

    Tried setting PWM for the bed to 0.5, but started a half-second strobing of the effector LEDs that was eye-watering. Duet is still set to bang-bang the bed, but so was the old controller, and did not see the drop there.

    Thanks for any solution or suggestion for further troubleshooting steps. Could replace the bed, but 1) not sure it's really the problem, so want to find the issue before moving on; 2) Everything worked correctly before the move to the Duet, and AFAIK there's no spec on the original controller that isn't bettered by the Duet. It should work!



  • If there was a meaningful short on the Duet, it would get very hot very quickly as it would have to dump 200+ watts of heat to be overloading your power supply.

    I think more likely is that your bed is pulling more than you think, as it is difficult for multimeters to measure low resistance. I've seen cheap meters with 1 ohm of resistance in their leads. If your bed was 0.6 ohms, that would be a 20 amp draw. The original board may have had a PWM limit programmed in, which would limit average current (though this is a poor solution).

    Also possible is that the wiring you're using is not rated for the current draw you're applying, or the screw terminals are not tight.



  • I agree about the measure. Try to first short your measuring wires to read their resistor, then substract this value to your bed reading.



  • There are two more options that come to my mind:

    Use the old power supply for duet and for the stepper and use the 2nd one for the bed only. Not efficient, but you have the parts anyway and as you already use an external Mosfet it is easy to do so, simply wire the mosfet to the 2nd power supply and have all grounds connected.

    The other option is a bit risky, the power supplies usually offer a small trimmer to adjust the output voltage of the power supply. You could increase the output voltage by one volt and see if this solves the problem with the effector leds. The downside of this approach is that with higher voltage you allow the bed to suck even more power out of the power supply, the bed heats up faster but it also increases the risk that the bed overheats and gets destroyed.


  • administrators

    My guess is that the wires connecting the Duet to the PSU are too thin and you are getting voltage drop in those wires, or that you have a bad connection at one end of one of those wires. Use your multimeter to measure the voltage between the output terminals of the PSU, and also between the two screws of the VIN terminal block. If the wire gauge is adequate and the connections are good, the difference should be very small e.g. 0.2V or less.



  • Thanks very much for all comments so far!

    Didn't think about lead resistance. Oscillates between 0.7 and 0.6 ohms, so assuming the worst, a 12A draw. I don't think it could be much worse than this–I was running straight Marlin 1.1.5 on the Trigorilla, so I don't think there was any PWM going on for the bed. Maybe their onboard MOSFET not efficient somehow?

    I'll try the dual-PS idea, need to get a second power cord though, so some delay before reporting back.

    Currently using as power leads some cables that came with the Anycubic, the printing on them claims they're 1.5mm. So about AWG 14.5? Maybe a little small for 12A. I'll get some thicker wires for the bed power. Existing wires did not get hot, btw.


  • administrators

    It's the PSU to VIN wires that need to be thick and the connections at each end of them that need to be good, to avoid a significant voltage drop between the PSU and the Duet when the bed heater is running at full power. Voltage drop in the wires between the Duet and the bed is less important - it reduces the bed heating power (which may be a problem if the bed heater is under-powered), but doesn't affect the Duet.



  • OK, checked this, and this doesn't appear to be the issue. Voltage measured at Vin is within 0.2-0.3v of the voltage at the PS.

    Things appear to be running OK with dual power supplies configured, but the bed supply (measured at the PS) is dropping to ~10.5v when the MOSFET turns the bed on. The other PS drops slightly when the hotend heater is on, but that's minimal. No sign of drop in the Duet when the bed turns on.

    I'm at a loss why this worked before but doesn't now.



  • When you look at the schematics of the effector you‘ll see that the LEDs on the effector are more or less directly connected to the power supply via the mosfet for turning on the cooler for the hotend.

    So the brightness of the LEDs will directly follow the output voltage of your power supply. This explains the flickering of the LEDs when you switched to PWM mode.

    To solve this you could try to connect an electrolytic capacitor to the H–fan+ H–fan– pins on either the effector side or on duet side. This should even out the flickering, but will most likely leave you with a dimming of the leds when the pwm kicks in. Ths could be solved by wiring a Zener–diode in parallel to the LEDs.

    But David should comment on that, my active days of building electronics are long gone.


  • administrators

    @Gone2Far:

    OK, checked this, and this doesn't appear to be the issue. Voltage measured at Vin is within 0.2-0.3v of the voltage at the PS.

    Things appear to be running OK with dual power supplies configured, but the bed supply (measured at the PS) is dropping to ~10.5v when the MOSFET turns the bed on. The other PS drops slightly when the hotend heater is on, but that's minimal. No sign of drop in the Duet when the bed turns on.

    I'm at a loss why this worked before but doesn't now.

    Which PSU are you using for the bed: the Meanwell 350W, or the other one?

    If it's the other one, then what power rating is it? If it has a marginal power rating, then it may be that with your RAMPS setup you were just within that rating, because RAMPS has a higher voltage drop in the bed circuit than the Duet, so the bed circuit would have drawn a little less power. Ot it could be that the power supply is just tired and starting to give up - that happens with some cheap PSUs, especially if you run them close to their power limits.



  • I was using the Meanwell. The other PS is a 12v 20A that came with the Anycubic. ~2 months of use so far on it.

    As an experiment, I reconnected the bed and the 20A PS to the TriGorilla board. Voltage with bed off 12.65v. Voltage with bed on, 10.93v, voltage to the bed 10.63v (both measured at the controller.)

    So it looks like the high bed drain was masked by the RAMPS voltage drop, and the almost-11v was enough to drive the steppers before.

    Looks like conversion to 24V is in my future. Will run dual PS for now. Is there a way to increase the bed PWM frequency without screwing anything else up?

    Thanks very much!


  • administrators

    The bed PWM frequency is deliberately low so as to be compatible with all types of SSR.

    Try measuring the Meanwell PSU voltage at its output terminals, with the bed off and with it on at full power. If it's dropping to 10.5V then there is something wrong with the PSU. If it isn't dropping much but the voltage at the Duet VIN terminals is still dropping that much, then you have a problem with the VIN power cab!e.

    If your mains voltage is 115V, check that if the PSU has an input voltage selector switch, it isn't set to 230V.



  • Ah, that last was it! I neglected to change the voltage input on the Meanwell to 115v. Everything working nicely now, running on just the Meanwell. Interesting that it almost worked correctly on what was essentially a 50% brownout. Also interesting (in a disappointing way) that even though the other PS was set correctly, it could not handle the loads it shipped with.

    Thanks!


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.