Duet Ethernet - AJAX errors and such



  • Let start with, I thought I damaged my board by accidentally giving it a hard yank while moving to storage for a couple weeks it and forgetting to unplug the Ethernet cable. That's still possible but I think I was just using a bad cable.

    Just before I moved the printer to storage, I had upgraded to 1.19 (and no 1.20b1) and I've been getting lots of connection errors. It's possible I've conflated the yanking on the board with the effects of the firmware upgrade.

    • Sometimes it will run for 10s of minutes with no disconnect.

    • Sometimes when it disconnects, refeshing reconnects.

    • Sometimes DWC reports an AJAX error

    • Sometimes it reports that it can't connect to firmware.

    • Sometimes I have to disable and reenable ethernet using the M552 command.

    • Pings always stay stable but vary from 1ms up to 100ms or so.

    • I have lowered microstepping to 16.

    • The problem happens more often when operations are happening but not exclusively.

    • This is very similar to the spike in AJAX errors I got on my Duet WiFi when I updated to 1.19beta that caused me to give up and go Ethernet. Is it possible there is something in my config (it's a Delta) that could cause this?

    • Is it possible that the WiFi network could contribute as the problem seems much higher when my TV (using built in app) is streaming Netflix? Yes, this seems dumb because the loss of connection to firmware should be entirely in the board.

    I'm going to revert to 1.18.x and see if that helps. I don't need any of the new features of 1.19 and up but I try to stay current.


  • administrators

    It sounds to me like a hardware problem. Have you tried a new Ethernet cable? Perhaps yanking the cable damaged the connections in the plug.

    The highest ping time I get to my Duet Ethernet is 2ms, and that is rare and only when I refresh the file list at the same time.

    Firmware 1.19 for the Duet Ethernet had only minor changes or the networking, unlike the Duet WiFi build.



  • Yes, I tried a new Ethernet cable but, even that, took a bit to get it to show the link light. I must have just slightly damaged the connector housing in the process.

    Thanks!



  • Leon - saw your order for a Duet Ethernet today, thanks for that. We do have one Ethernet module on hand if you feel like swapping the one on your board. If interested in in touch via the Filastruder contact page.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.