Initial tuning for corexy with 3 z independent z screws

  • Yeah it's tooling plate, so it is supposed to be super flat, but still have to level the actual gantry/bed

    G1 X99.4 Y138.5 Z0.35 E0 F6000
    G1 X99.4 Y138.5 Z0.3 E0 F1800

    Those are the first Z changes for the prime pillar, the first layer starts with 0.35 too.

  • I guess what you could try is starting a print then aborting it while it's doing the first layer. Make sure that any pause.g file doesn't have a Z lift in it. Then with your feeler gauges, measure the nozzle height which should be whatever you've set the first layer to be (0.35). If it is (within 0.05mm or so), then you can pretty much discount anything to do with bed level or flatness compensation.

    The other thing to check is your steps per mm for the Z axis. I see you have that set to 400 which would be correct for those God awful 4 start 8mm lead screws that people will insist on using - sorry but its a pet hate of mine. Anyway, assuming you have 1.8 degree motors, 1 revolution is 200 steps. If the lead of the screw is 8mm that means 25 full steps per mm and at 16X micro stepping that's 400 which is what you have it set to. But if the lead is different, then you'd need to change the steps per mm accordingly.

    By the way, you should avoid using a layer height that is an odd number. The reason is that with 25 full steps per mm, 0.1 mm will be 2.5 full steps - i.e half way between 2 and 3 full steps so you'd be relying on micro stepping for positional accuracy which is not so good. So 0.2mm layer height would be 5 full steps which is OK, 0.3mm is 7.5 full steps which is not good. 0.35 is even worse as it's 8.75 full steps. 0.4 is 10 full steps so that's OK.

    I'm not saying that is the cause of your first layer problems but it won't help.

  • I think that I am indeed using the awful lead screws that you mention πŸ˜›

    I let the babystepping there to be able to test other stuff, and I am getting stuff like this

    I tried to make my xy belts as tight as they can, and I don't think that kind of ringing is related to that but who knows.

  • OK so that's some sort of progress. It looks to me like the Z height is very inconsistent and now that we've established what you your lead screws are, it could well be that your acceleration and instantaneous speed settings are too high for that course lead and my best guess is that you are skipping steps. I see that you have acceleration set to 450mm/sec^2 which is way too high IMO. Try something like 10 or 20 (M201 Z20) and do the same for instantaneous speed change i.e set M566 Z10 or 20 (mm/sec). Set maximum speed for Z to around 300 (M203). While you are at it, the Y axis acceleration is way too low at 20 - set that to around 1,000 (I use 1000 and my moving mass in Y is 4Kg !).

    Edit, here is why those multi start screws are my pet hate

  • Ok, I did the Z change, but it didn't stick again. The Y is really faster and the Z seems more controlled.

    I am going to change belts and re-tighten and re-check the build to see if I messed up somewhere, and will report back with, probably, more questions on Friday πŸ™‚

  • @deckingman:

    Edit, here is why those multi start screws are my pet hate

    Also I read this and now want to find a way to adapt a 1:2 gear on my current screws. Or change them to a 1 start or threaded rod.

  • You can also try using a wider first layer which sometimes helps - up to 200% of the nozzle width.

  • So I changed the belts, added a 300mm PEI cover to the bed, and that seems to have helped on some of the shift issues

    The first layer problems still here tho. I am printing a big box for my duet now, and for the first layer to stick I had to print it with like 10 mm/s, on a Pei bed at 70 degrees. Still I get this:

    In this the skirt is raising up on the border because when the nozzle goes throug there, it forces it up.

    This is a photo of the first layer, as you can see the bottom part is very squished to the bed while the top part totally isn' t.

    I tought that with a MIC6 plate, independent screw correction and mesh maps, I would not have to worry about it getting a correct first layer ever again, but it seems that I may be better manually changing bed screws since I can't reliably believe this printer.

  • What I first would look at is that your piezo probe is working correctly and is consistent.
    I find it weird that you have to use the H parameter for G30 in bed.g.
    Try to do G31's on the different bed.g locations and repeat like 5 times, you should get values within 10 microns, if not you will need to tune the probe.
    If G31 is working as it should then do the same multiple G32's and see if the compensation values vary wildly or not.

  • From those pics it looks fairly clear that the bed isn't level so I agree with whosrdaddy that you ought to check that teh probe is functioning as it should. If it's inconsistent then that would explain things.

  • Got some good prints the last few days. I had to use the bed compensation AND mesh leveling. I guess somehow I got a 6mm aluminum plate bent 😐

  • After generating my own RRF config. g file I was having bed adhesion problems like you. What seemed to be the issue was that I messed up with the thermistor values. When the hotend was set to 235ΒΊc it was actually 215ΒΊc.

    Try this value:

    M305 P1 T100000 B4725 R4700 C7.06e-8 H0 L0
    BTW, I'm also using OEM TitanAero with the stock thermistor cartridge.

  • I have the same values, but not the H0 and L0. What those do?

    I got those values from the official E3D docs.

  • @coredump:

    …............................ but not the H0 and L0. What those do?

    See here.

    BTW, the duet g-code wiki is a great resource if ever you have similar questions.

  • administrators

    The H and L parameters are not generally needed for the Duet WiFi/Ethernet. They are sometimes needed on the older Duets.

  • @coredump:

    ….................... I guess somehow I got a 6mm aluminum plate bent 😐

    Not necessarily. It is possible that the X Y rails are not truly parallel (tram) with the bed or that they are not truly straight. Either way, mesh compensation would work though.

  • @deckingman:


    …............................ but not the H0 and L0. What those do?

    See here.

    BTW, the duet g-code wiki is a great resource if ever you have similar questions.

    Sorry, I read the wiki and I understood what the parameters do, was just asking why those values exactly πŸ™‚

  • Lol this is probably a dead one, but this sounds almost EXACTLY the same issue I had been having with my printer when I finally bought a Duet WiFi and tried to get my bed probe working. When It would home/level, and I did the paper trick, everything looked perfectly fine. But when I would start a print, the nozzle would be anywhere between 0.3 to 3mm above the bed and sometimes below... scratched a freshly installed aluminum plate that day...

    Anyway, I posted on here about it, and everyone suggested that it was because I didn't actually have the bed leveling action dictating the final Z height. As in, after it homed Z using the probe, it didn't actually 'save' the detected height. And so when it went to level the bed, it didn't have the proper height saved to begin with, and thus all the leveling showed my bed was 1-3mm below/above the expected Z0. Thus when it started a print, it'd float up in the air/dig into the bed...

    I forget what the actual code is, and I'm not near the printer atm to be able to look at my configs, but I know there was some GCODE I had to implement after homing and after probing, that dc42 had told me to add if I remember correctly. It basically forced the Z Position to set based on whatever the sensor detected. Since then I've had nothing but amazing first layers print after print. Only issues I've had is when the extruder borks up and I gotta clear the ptfe tube...


Looks like your connection to Duet3D was lost, please wait while we try to reconnect.