Not sure if slicer or other issue



  • Hi all, thanks for the help on the extrusion and the power supply. I found out it wasn't my power supply, but the switch that was connected to it. Somehow the switch connector itself on the switch (not the connects) became loose and started loosening up, causing the random power shut down and also smell before it was making sparks. Luckily caught it in time and switch it, so far so good. My question is that I believe I am almost 100% certain that it seems to be as some people said, an overextrusion that slowly becomes underextrusion over time because too much being fed and gradually it can't go through. However, the problem is and I"m not sure of if this is my settings or slicer issue. Basically I have tried 85% to 95% change on my Cura flow % settings, but it seems like the change isn't being used and the extruder still feeds at same rate, causing my nozzle to keep jamming after like 3 minutes into the print and me having to clean it. As mentioned, using Cura, and with relative extrusion checked. I'm wondering if I should just buy S3D (SImplify 3d) and use that instead. Thanks.



  • Have you calibrated you steps on the extruder (at approx the speed you will be extruding at say 5mm/s). Also check the temperature your printing at, the faster you go the hotter you need to be, with a Titan I've had issues where it will start to skip for over extrusion and too cold a hot end, both lead to the filament stripping and clicking and then the signs of under extrusion. I must confess I never go the titan to work well, it also squealed and the screws would come loose and the e3d forum for support was not a touch on this forum. I swapped to the Bondtech and it's been flawless, should have bought that in the first place.

    Also if you want to try another slicer before buying S3D try the Slic3r Prusa edition, its free and works very well with reprap printers.


  • administrators

    I use Cura successfully with a Titan &Duet so it is possible! I agree with dadiy let's isolate the issue by checking extruder calibration.

    It sounds like you have removed the most obvious issue that can happen with Cura, especially older versions, of having absolute mode gcode with firmware set for relative mode. Extrusion flow % can be tweaked for final tuning but the printer should work without having to set that to.something other than 100% so test with it in 100% to start with.

    You should be able to get the titan calibrated to <1% error by extruding 100mm and adjusting the extruder steps/mm until the difference between actual and commanded movement is <1mm



  • Oh yeah I should have mentioned, the titan has been calibrated, doing 10mm extrusion gives me 9.93 mm according to my calipers. Hmm DADIY you might be right, I'm so used to printing only around 50-60mm/s on my other machines, and now I'm trying to do 80-90mm/s but sitll using the same temperature. That would also explain why my brims and first layers would work fine extruding (cause first layer is at 205 C for Zyltech PLA) but start going wonkers after that (which is then set to 196 C by then) maybe I should set both first layer AND afterwards to all 210C and try that out?



  • Well I'm at a loss, here, I'm strongly thinking it's the titan clone extruder, I upped my temp all the way to 230, the brim prints fine, and it was doing okay, but showing some underextrusion, so I upped it to 97% flow from 96% and extruder starts clicking and because apparently the nozzle can't push it out fast enough, and then starts jamming despite the huge temp change from 196 to 230 C. I'm at a loss here and getting super frustrated, the brim seems to print fine though, I'm thinking of ordering the authentic Titan with the 0.9 motor and trying that out. THis is using ZYltech PLA, at 80mm/s. Though I'm also confused why it takes over 1 hour when Cura says 24 minutes…



  • THis is using ZYltech PLA, at 80mm/s.

    And what happens if you print at 50-60mm/s like you were doing before?

    Though I'm also confused why it takes over 1 hour when Cura says 24 minutes…

    Cura can actually produce some pretty accurate time estimates as long as the accel and jerk values that cura uses match the values that are being used by the Duet.



  • Ah okay how do I get Duet to go faster? as the reason I built the HEVO is for faster print speeds, but if it's slower 😕

    About the issue, it was a I fell for it at least for now, even though it was at 94% or such it was still overextruding, but the small gaps made it look like underextrusion, so when I went to 97% it jammed it, once I lowered it to 91-92 it was seemingly almost much better, still have to play around with it. Though at this rate I'm still tempted to get either the authentic Titan or Bondtech, since I've heard they have much more consistency.



  • https://youtu.be/H8pe_xal2FQ

    There's probably more to it. I've a titan clone on my corexy feeding a genuine volcano and I've checked to see how much it can push with a 0.4mm nozzle. 9.1mm3/s which is a linear nozzle speed of around 160mm/s.

    I'd make sure you've enough motor current, enough idler tension, and that the filament flows easily when pushed by hand through. If it doesn't then either your hotend is blocked or partially blocked, or your heater isn't actually as hot as you think verify the temp with a thermocouple or something else you can trust.

    As for speed push the jerk/acceleration for extruder often the limiting axis in combined moves (I. E. Printing moves) titan and clones should be set for max speed 3600, acceleration at least 1000 but I've tried 9000 and jerk 1000. Then run your speed factor up while printing. You shouldn't run out of melting power until you reach 5-6mm3/s with v6/0.4mm or 9mm3/s with volcano/0.4mm more with bigger nozzles. Calculate the volumetric extrusion either by measuring the volumr of filament fed in over time, or the volume of a layer extruded over time.



  • Update on the situation, here are my drives settings:

    ; Drives
    M569 P0 S0 ; Drive 0 goes forwards
    M569 P1 S0 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80.84 Y80.84 Z400 E424 ; Set steps per mm
    M566 X900 Y900 Z12 E120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X18000 Y18000 Z180 E1200 ; Set maximum speeds (mm/min)
    M201 X3600 Y3600 Z250 E250 ; Set accelerations (mm/s^2)
    M906 X1500 Y1500 Z1200 E1200 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    I did what you said and set max speed to 3600, and I think it's something with retraction, the "underextrusion" all happen on the same layers, and not some are so bad that it doesn't come out and causes missing layers on my benchy. Really at a loss right now, it's so frustrating. my Current retraction settings are 3.5 mm distance and 350mm/s (yes 350 as someone told me to) retraction speed, Nozzle isn't clogged because I can push filament through fine.



  • Another update, I think it's my part cooling fan blowing onto the nozzle tip that's the problem, but I feel like it might be my PID thermistor settings. I'm ussing the authentic E3d V6 nozzle, and I feel like maybe my settings aren't correct:

    Here's the values in my Duet Wifi : ;
    Heaters
    M143 S280 ; Set maximum heater temperature to 280C
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.