Question about fan control..



  • I have the following in config.g and when tuning my hot end I realized the hot end fan was not coming on.

    [c]; Tools
    M563 P0 D0 H1 ; Define tool 0[/c]

    So I added a line to the fan section that worked

    [c]M106 P1 T60 H1 [/c]

    I think M563 is essentially missing the hot end fan for Fnnn.

    Can I just add F1 to the M563 and remove the M106?

    [c]; Tools
    M563 P0 D0 H1 F1 ; Define tool 0[/c]

    Thanks.

    vbtalent,


  • administrators

    Assuming you have Duet WiFi or Duet Ethernet, normally you should connect the print fan to Fan0 and the hot end heatsink fan to Fan1. Fan1 defaults to being in thermostatic mode controlled by the temperatures of heaters 1 and 2. So if you connect them in this way, you don't need any M106 commands in config.g.

    When you send M303 to tune the hot end, it will automatically turn on any fans that are configured thermostatically to respond to the hot end temperature.



  • Thanks for the insight as always..

    DuetWifi is what I'm using.



  • Is that contradictory to what's in the WIKI?

    Thermostatically controlled fans

    As mentioned above, many hot ends require a fan to keep the heatsink cool, so that the filament remains solid until it passes through the heat break into the melt zone. This fan should be on any time the hot end is hot enough to melt plastic, but can safely be off when the hot end is cool even if the rest of the machine is on. The Duet WiFi supports this mode of operation. Plug your fan into one of the PWM connectors, say FAN1, and configure it as a thermostatic fan for the appopriate heater by putting the appropriate M106 G-code in config.g. For example:

    M106 P1 T45 H1

    This sets fan 1 to run any time the temperature of heater 1 is above 45 Celsius. See [1] for details. We recommend you use the FAN1 connector for a thermostatically-controlled hot end fan, because on the Duet WiFi it defaults to being on at power up, to provide maximum safety if you restart your Duet when the hot end is hot.

    A thermostatically controlled hot end fan will be turned on automatically when you auto tune any heater that it monitors.

    Thanks,


  • administrators

    Which bit do you think is contradictory?



  • The part about adding or removing the M106 command…

    If using the Fan1/Fan0 is it needed in the config.g for them to be operational?

    Without adding the M106 in the config.g file I can not get the part cooling fan working however the extruder fan does work without the M106.



  • Fans are optional so you need to add them to config.g if you want to use one. Having said that, the wiki extract you posted says this:

    "We recommend you use the FAN1 connector for a thermostatically-controlled hot end fan, because on the Duet WiFi it defaults to being on at power up, to provide maximum safety if you restart your Duet when the hot end is hot."

    Which is why your extruder fan works without putting a M106 P1 command in config.g. If you want to use a part cooling fan and if you connect it to the Fan0 connector, then you need to put an M106 P0 command in config.g.


  • administrators

    The part cooling fan should work (i.e. respond to M106 commands generated by your slicer), at full speed at least, without any support in config.g if you have connected it to Fan 0. What might not work is turning it on at less than full speed, because you may have to reduce the PWM frequency or increase the blip time using a M106 command in config.g.



  • For me the part fan on Fan0 does not come on unless I put in the M106 in the config.g however the extruder Fan1 is working as described.

    In Slic3r there is a "Filament Setting" for "Cooling" which generates Gcode similar to the following

    [c]…
    M106 S219.3
    M106 S140.25
    ...[/c]

    if I use the following in my config.g file

    [c]M106 P0 S1 I0 F500 H1 T45[/c]

    I assume the Gcode lines from Slic3r will be interpreted and the Fan0 speed will be controlled as it prints and override the default settings in the config.g file?

    Thanks for the input guys.


  • administrators

    The S1 in your M106 command means turn on the fan at full speed. The H1 means control it thermostatically with the hot end temperature, which you probably don't want for the part fan, because it's normally best to print the first layer without the part fan running.

    The M106 command in config.g should not be needed. Without it, the fan will be off until a M106 command generated by the slicer turns it on after the first layer, which is almost certainly the behaviour you need.



  • Whilst I think that the Wiki could be a little clearer in what needs to go in config.g and what doesn't, I can confirm that deleting M106 P0 from config.g has no effect on the print fan.

    What may be confusing the OP however, is that in the web interface, the (print) fan is labelled "FAN1" not "FAN0" as might be expected.


  • administrators

    @deckingman:

    What may be confusing the OP however, is that in the web interface, the (print) fan is labelled "FAN1" not "FAN0" as might be expected.

    Good point! I'll suggest to chrishamm that he changes it.



  • @dc42:

    @deckingman:

    What may be confusing the OP however, is that in the web interface, the (print) fan is labelled "FAN1" not "FAN0" as might be expected.

    Good point! I'll suggest to chrishamm that he changes it.

    While you are on, how about getting my pet hate fixed? That is extruder drives being labelled 1 to 5 instead of 0 to 4 🙂

    i.e. assigning drives 0 to 4 to tools 0 to 4 but to check extrusion heat tool 2 but use drive 3. Grrrrrrr 🙂


  • administrators

    @deckingman:

    @dc42:

    @deckingman:

    What may be confusing the OP however, is that in the web interface, the (print) fan is labelled "FAN1" not "FAN0" as might be expected.

    Good point! I'll suggest to chrishamm that he changes it.

    While you are on, how about getting my pet hate fixed? That is extruder drives being labelled 1 to 5 instead of 0 to 4 🙂

    i.e. assigning drives 0 to 4 to tools 0 to 4 but to check extrusion heat tool 2 but use drive 3. Grrrrrrr 🙂

    Where are the extruder drives labelled 1 to 5?



  • @dc42:

    Where are the extruder drives labelled 1 to 5?

    DWC - Machine Control page - under "Extruder control" and just above "Miscellaneous" (which also shows "Fan1") 🙂



  • Also in print status under "Extrusion factors" they are labelled as Extruder 1, Extruder 2 etc. For the majority of people who only use a single extruder, they will only see one extruder (or drive depending on which page you are on) so it won't matter. It's only crazy people like me who have mixing hot ends that have the issue.

    Cheers



  • OK, great!

    Thanks for the direction… Slicer controls fan in G-Code... M106 not required in config.g.

    Sorry about the additional work, lol!

    VB,


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.