Duet WIFI Random Skipping Issue



  • OK I've had this issue on 2 of my printers (installed the duet on both printers to test it's not a fault with the machines)

    About 33% of the time this is what happens when I power up my machine. https://photos.app.goo.gl/JSx6ikmvSesdLJMU2

    As you can hear, it is skipping like crazy. This happens on both X & Y.

    If I reset the machine several times, it happily prints for several days.

    Any ideas, are the pin headers on the board faulty?



  • Sounds just like my z axis driver, it has no torque at all. Putting the z axis motor on any other driver its smooth and quite.
    Hope you get it resolved.


  • administrators

    Which firmware version are you using? Have you tried version 1.20RC1 ?



  • Still running 1.19, is there anything specific in 1.20RC1 that could address the issue?


  • administrators

    You should be running at least version 1.19.2 which addresses bugs in 1.19, one of which might possibly account for the strange behaviour. If you are using our MAX31856 thermocouple daughter board, there is another relevant fix in 1.20. In any case, with 1.20 close to release I won't be doing any investigations into possible bugs in earlier series firmware.



  • Thanks, i'll update later today and report back if I still get this issue



  • Totalitarian,have you found anything?

    My new Duet has been like it since it's been hooked up. Intermittent working, occasionally it drives correctly although I find it doesn't last and will change to this weird crunching after some time.

    • I've changed the loom

    • I've changed the NEMA17 motor it is hooked up to by testing it against my 2 year old (working) Ormerod 2's X-axis (with Duet 0.65 running firmware 1.19)

    • as well I plugged it into the Y-axis on this Ormerod 2 - same symptoms.

    Today I was demonstrating to a friend and he pointed out to me that to him, it looked like it might be heat related, as it works from a "cold" state (not been switched on recently) but doesn't work after it's been on a while.

    We then did further tests by pointing a big household fan at the board when switching it on from cold.Many (unscientific) repeats seem to show that it works a lot longer when a fan is pointing at it, as well as failing after a couple of minutes when the fan is removed.

    For information, I was running Firmware 1.19.2, and just in case I upgraded to Firmware Version: 1.20RC4 (2017-12-20) as indicated above, with no change to the behaviour.

    config.g

    ; Configuration file for Duet WiFi (firmware version 1.17 to 1.19)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Wed Dec 20 2017 22:03:57 GMT+0000 (GMT Standard Time)
    
    ; General preferences
    M111 S0                            ; Debugging off
    G21                                ; Work in millimetres
    G90                                ; Send absolute coordinates...
    M83                                ; ...but relative extruder moves
    M555 P2                            ; Set firmware compatibility to look like Marlin
    M208 X0 Y0 Z0 S1                   ; Set axis minima
    M208 X240 Y240 Z200 S0             ; Set axis maxima
    
    ; Endstops
    M574 X0 Z0 S0                      ; Set active low endstops
    M574 Y1 S1                         ; Set active high endstops
    M558 P1 X1 Y0 Z1 H5 F120 T6000     ; Set Z probe type to unmodulated, the axes for which it is used and the dive height + speeds
    G31 P600 X0 Y0 Z2.8                ; Set Z probe trigger value, offset and trigger height
    M557 X15:215 Y15:195 S20           ; Define mesh grid
    
    ; Drives
    M569 P0 S0                         ; Drive 0 goes backwards
    M569 P1 S1                         ; Drive 1 goes forwards
    M569 P2 S1                         ; Drive 2 goes forwards
    M569 P3 S1                         ; Drive 3 goes forwards
    M569 P4 S1                         ; Drive 4 goes forwards
    M350 X16 Y16 Z16 E16:16 I0         ; Configure microstepping without interpolation
    M92 X87.489 Y87.489 Z4000 E420:420 ; Set steps per mm
    M566 X300 Y900 Z12 E120:120        ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000 Y6000 Z180 E1200:1200   ; Set maximum speeds (mm/min)
    M201 X500 Y20 Z250 E250:250        ; Set accelerations (mm/s^2)
    M906 X800 Y1000 Z800 E800:800 I30  ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30                            ; Set idle timeout
    
    ; Heaters
    M305 P0 T10000 B3988 C0 R4700      ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120                       ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 C0 R4700     ; Set thermistor + ADC parameters for heater 1
    M143 H1 S260                       ; Set temperature limit for heater 1 to 260C
    M305 P2 T100000 B4138 C0 R4700     ; Set thermistor + ADC parameters for heater 2
    M143 H2 S260                       ; Set temperature limit for heater 2 to 260C
    
    ; Tools
    M563 P0 D0 H1                      ; Define tool 0
    G10 P0 X0 Y0 Z0                    ; Set tool 0 axis offsets
    G10 P0 R0 S0                       ; Set initial tool 0 active and standby temperatures to 0C
    M563 P1 D1 H2                      ; Define tool 1
    G10 P1 X10 Y0 Z0                   ; Set tool 1 axis offsets
    G10 P1 R0 S0                       ; Set initial tool 1 active and standby temperatures to 0C
    
    ; Network
    M550 PMy RepRapPro Ormerod 2       ; Set machine name
    M552 S1                            ; Enable network
    ;*** Access point is configured manually via M587 by the user
    M586 P0 S1                         ; Enable HTTP
    M586 P1 S1                         ; Enable FTP
    M586 P2 S0                         ; Disable Telnet
    
    ; Fans
    M106 P0 S0 I0 F500 H-1             ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1:2 T45        ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1:2 T45        ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on
    
    ; Custom settings are not configured
    
    

    So, is this a known issue? Is there supposed to be a fan over some part of the board that I'm not aware of? (it is mounted in the open, so there is no airflow issue) or is this something I should be contacting Duet3D about?


  • administrators

    I've just replied to your similar post on the RepRapForum. If you suspect that a particular motor output his at fault, try substituting the E1 motor output instead, and use the M584 command to assign the E1 driver (driver 4) to the axis concerned. The M584 command must come before some other commands including M906 and M350.



  • cheeseandham doing as dc42 mentioned fixed the issue for me. It must be a faulty driver. dc42 how do we go about getting it replaced under warranty?


  • administrators

    Email your supplier. If you bought it from duet3d.com then the address is info at duet3d dot com.



  • Right, now Christmas is out of the way!

    I used the M584 command to assign the E1 driver (driver 4) to the X axis as instructed above.
    Everything works fine and I commissioned and could print a Marvin.

    Moving the loom back to the X axis, and unfortunately it does the same thing as before (works for 0-4 minutes then crunch & fail)

    I wouldn't mind so much if I hadn't bought the DuetWifi specifically for dual extrusion 🙂

    Therefore I'll report this to my supplier.



  • Sorted out / solved.

    I'll just say Think3DPrint3D have great customer service. 😄


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.