New firmware 1.20 Release Candidate 2 - please try it!


  • administrators

    I have released this in the usual Edge folders at https://github.com/dc42/RepRapFirmware/tree/dev/Release. If you are an experienced Duet user, I would appreciate it if you would test this release and report your experiences (good or bad) in this thread. Unless any serious issues are reported that I can't fix in time, I intend to release firmware 1.20 final next week.

    Chrishamm has also released Duet Web Control 1.20RC1 so I have included it in the Edge folders too.

    For a list of the changes, see https://github.com/dc42/RepRapFirmware/blob/dev/WHATS_NEW.md.

    RRF 1.20 is the last release I plan do for the Duet 06/085, apart from any 1.20.x bug fix releases that may be needed. Firmware for the Generation 2 Duets will soon be migrated to a Real Time Operating System (RTOS) and the SAM3X-based Duets don't have enough RAM for that.



  • Printed non stop with RC1 now, will try RC2 tomorrow.
    Only had one issue with a hard reset (don't have the log unfortunately) during printing but I suspect that was because I was sending GCode commands during the print.



  • Christmas has come early. My extruders are labelled 0 to 4 instead of 1 to 5!!!! Yes!

    Oh, and thanks DC and Chrishamm. 🙂

    Edit. And the print fan is labelled as Fan 0 rather than Fan1.



  • I'm not sure what I'm doing wrong, but every time I update I break the wifi and have to go through a different procedure to get it reconnected.

    Currently I can't reset the wifi module or anything through Pronterface. I think I need to upload directly to sd card then?

    Is there a specific wifiserver version I need for RC2? I had 1.20a1 so updated to b10 for this thinking that's what I need.



  • Back online. I replaced the wifiserver file with one from a backup, M997 S1 then was able to get it online.



  • having trouble with Wifi disconnects in RC2. I updated from an earlier beta where everything was fine. Cant seem to stay connected for more than 5 mins now. I just added a duex5 and rewired everything so there is a chance I tweaked something in the process but im pretty sure I had no issues after the rewire until RC2…. Anyone else? Is the last 19 beta living somewhere to roll back to?

    anything I can do to help identify a bug in either the version or my own work? Im not super familiar with the debugging process but im pretty good at following directions.

    Also the new web interface killed my dark theme. I had to roll that back to 19.3



  • Starting with Beta11, with the M584 changes, with the U axis hidden if I run G29 the printer starts probing, but after the first row the U drive, which is my second Z motor starts moving up rather than down.



  • Not sure where to report DWC issues, so posting it here. Dark theme is broken in the latest 1.20-RC1 - it is visible immediately upon switching (and applying) the Dark theme. Some backgrounds remain white.


  • administrators

    @SuperJETT:

    I'm not sure what I'm doing wrong, but every time I update I break the wifi and have to go through a different procedure to get it reconnected.

    Currently I can't reset the wifi module or anything through Pronterface. I think I need to upload directly to sd card then?

    Is there a specific wifiserver version I need for RC2? I had 1.20a1 so updated to b10 for this thinking that's what I need.

    DuetWiFiserver 1.20beta10 is recommended for RC2. As explained in the upgrade notes, it often needs to be installed twice over earlier versions. Something to do with the bootloader and reserved flash areas having changed in the later version SDK I think.


  • administrators

    @Jason:

    having trouble with Wifi disconnects in RC2. I updated from an earlier beta where everything was fine. Cant seem to stay connected for more than 5 mins now. I just added a duex5 and rewired everything so there is a chance I tweaked something in the process but im pretty sure I had no issues after the rewire until RC2…. Anyone else? Is the last 19 beta living somewhere to roll back to?

    anything I can do to help identify a bug in either the version or my own work? Im not super familiar with the debugging process but im pretty good at following directions.

    Also the new web interface killed my dark theme. I had to roll that back to 19.3

    Which version of DuetWiFiServer are you using?


  • administrators

    To those using the dark theme: It is now fixed in DWC 1.20-RC2, available here.



  • How do i wire / configure multiple bed heaters? Are the wiki docs updated to reflect the feature?
    I'd like to revive my idea of a zoned heatbed with 4 heaters/thermistors for a larger printer tho.



  • @chrishamm:

    To those using the dark theme: It is now fixed in DWC 1.20-RC2, available here.

    Thanks.


  • administrators

    Please be aware that multiple bed heaters are not yet supported on DWC but in principle it is fairly easy to configure them. Assuming you want to map heaters 3-5 to heated beds leaving heater 0 as the first bed heater, you could send

    M140 P1 H3
    M140 P2 H4
    M140 P3 H5

    to the firmware to set everything up. Just make sure you don't put excessive load on the heater channels - in fact you may want to consider connecting an SSR to each of them before you continue.



  • Thanks @chrishamm. I always forget the GCodes used are important whether a heater is a bed, hotend or chamber …

    I explicitly use SSRs for my silicone heaters since I only use 230V/AC ones, so I won't do it any different in the future or with multiple heaters 😉

    So, in practice, I'd set all four heaters to my target temperature (e.g. 80°C) and the Duet takes care that each zone reaches 80°C and stays at it. I know the zones will affect each other, but in the end, the Duet will figure out which zone to heat, right?



  • Installed on kossel XL, 9-hour lithophane print completed successfully.



  • I'm about to start a print but can already confirm that M28/M29 is working as expected again, thanks! 🙂


  • administrators

    @DjDemonD:

    Installed on kossel XL, 9-hour lithophane print completed successfully.

    @darookee:

    I'm about to start a print but can already confirm that M28/M29 is working as expected again, thanks! 🙂

    Thanks for the confirmation, both of you.


  • administrators

    @Immutef:

    So, in practice, I'd set all four heaters to my target temperature (e.g. 80°C) and the Duet takes care that each zone reaches 80°C and stays at it. I know the zones will affect each other, but in the end, the Duet will figure out which zone to heat, right?

    Yes, that is right.


  • administrators

    @Immutef:

    So, in practice, I'd set all four heaters to my target temperature (e.g. 80°C) and the Duet takes care that each zone reaches 80°C and stays at it. I know the zones will affect each other, but in the end, the Duet will figure out which zone to heat, right?

    That's correct. Currently you will need to send M140 P0 S80, M140 P1 S80, M140 P2 S80 and M140 P3 S80. Then M116 to wait for them all to reach temperature. M140 with no P parameter defaults to P0.

    I am considering making a couple of changes:

    1. Use M140 H0:2:3:4 to configure multiple bed heaters, instead of M140 P0 H0, M140 P1 H3 etc.

    2. Make M140 Sxxx (also M190) with no P parameter set the temperature of all bed heaters. So the bed temperature commands generated by slicers would apply to all bed heaters by default.

    These changes would also apply to the M141 command to configure and control chamber heaters.

    Thoughts?


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.