Not Extruding? Wanhao i3 - And Grinding Problem.



  • So I replaced the Melzi board on my Wanhao i3 with a Duet Wifi.

    I then loaded on the latest firmware and used config files generated by this; https://configurator.reprapfirmware.org/ for the Wanhao i3.

    It homes correctly, the temperature range looks correct, but when it comes time to print.. well it goes through all the motions, darting back and forth across the print area but never actually attempts to extrude anything. The extruder stepper looks like it never moves.

    I've tried a few things, I went through the documentation and tried following the steps for manually setting up the configs, but the generated ones don't look wrong.

    I tried this guy's configs; https://github.com/darookee/wanhaoi3-duetwifi - but same issue, with the added bonus that this makes the y axis judder violently to the point it just sounds like its constantly hitting something.

    I've looked through these forums, and did find something to do with not setting the tool, but T0 is at the end of all the config.g files I've tried.

    I'm completely lost. It's getting a little frustrating at this point. Any ideas?


  • administrators

    Have you tested the extruder? Select the correct tool, heat it to operating temperature, and use the Extrude and Retract buttons on the Machine Control page of the web interface.



  • Do you get any error messages? Can you extrude via the web interface? What I mean by that is on the Machine Control page select the tool to make it active, heat it to around 180 deg C, then under "Extruder Control " set the feed amount to around 20mm, set the feed rate to 5 (the faster speeds are only good for loading and unloading filament) then press the button labelled "Extrude". It will be "greyed out" and won't let you do it until the temperature gets close. What happens when you do that?

    Edit. Was typing at the same time as DC.



  • Using the web interface, selecting tool 0. Manually giving it the command to heat up and then extrude works. The macro to then do a test print fails on no selected tool, even if you manually select one. And actual prints don't produce any errors and continue as if it were working.


  • administrators

    Please post the first 50 or so lines (not counting comment lines) of the GCode file you are trying to print.



  • Just going to preface this with I have been having problems… I did try the manual extrude, but only with the reprap configurator files. I hadn't tired with the github user's files.

    It didn't work this time... the cable on the stepper motor had come lose. However the violent axis motion issue still exists.

    edit:
    I'm glad that part of the issue is solved, I can hardly believe that's all it was, that's rather embarrassing. But the grinding noise it is making is probably not normal. Could you help me with that bit of the issue?

    Here's the gcode;

    ; external perimeters extrusion width = 0.40mm
    ; perimeters extrusion width = 0.48mm
    ; infill extrusion width = 0.48mm
    ; solid infill extrusion width = 0.48mm
    ; top infill extrusion width = 0.48mm

    M107
    M190 S55 ; set bed temperature
    M104 S215 ; set temperature
    G28 ; home all axes
    G1 Z5 F5000 ; lift nozzle

    M109 S215 ; wait for temperature to be reached
    G21 ; set units to millimeters
    G90 ; use absolute coordinates
    M82 ; use absolute distances for extrusion
    G92 E0
    G1 Z0.400 F7800.000
    G1 E-2.00000 F2400.00000
    G92 E0
    G1 X85.302 Y91.751 F7800.000
    G1 E2.00000 F2400.00000
    G1 X87.058 Y90.252 E2.27422 F1800.000
    G1 X89.218 Y89.436 E2.54845
    G1 X90.475 Y89.317 E2.69842
    G1 X109.525 Y89.317 E4.96089
    G1 X111.800 Y89.714 E5.23512
    G1 X113.805 Y90.858 E5.50934 F1800.000
    G1 X115.305 Y92.614 E5.78357
    G1 X116.120 Y94.774 E6.05779
    G1 X116.239 Y96.031 E6.20776
    G1 X116.239 Y103.969 E7.15046
    G1 X115.842 Y106.243 E7.42468
    G1 X114.698 Y108.249 E7.69891
    G1 X112.942 Y109.748 E7.97313
    G1 X110.782 Y110.564 E8.24736
    G1 X109.525 Y110.683 E8.39732
    G1 X90.475 Y110.683 E10.65980
    G1 X88.200 Y110.286 E10.93402
    G1 X86.195 Y109.142 E11.20825
    G1 X84.695 Y107.386 E11.48247
    G1 X83.880 Y105.226 E11.75670
    G1 X83.761 Y103.969 E11.90667
    G1 X83.761 Y96.031 E12.84936
    G1 X84.158 Y93.757 E13.12359
    G1 X85.272 Y91.803 E13.39069
    G1 E11.39069 F2400.00000
    G92 E0
    G1 X107.697 Y102.140 F78



  • Video of it trying to print, violent motions; https://streamable.com/htk35


  • administrators

    The grinding noise suggests a mechanical problem, or the Y speed or acceleration set too high. Check your M201 and M203 commands in config.g.

    Why not revert to the config.g file you used originally?



  • I feel like its more likely to be the second, unpowered it's motion is very smooth, and giving it manual commands via the web interface it doesn't as much hit a blip.

    And I switched back to the original gcode once I realised it was my mistake on the power cable. I think I must have taken it off to unjam the extruder at some point.

    It works smoothly for a little while, then a couple of minutes into the print it starts the grinding.

    I am going to try a different model tomorrow to see if its just the model, or to see if it consistently trips up at that point in the print.



  • I have the same printer, please post your config.g and I'll take a look.



  • ; Configuration file for Duet WiFi (firmware version 1.17 to 1.19)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Fri Dec 15 2017 16:55:26 GMT+0000 (GMT Standard Time)

    ; General preferences
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates…
    M83 ; ...but relative extruder moves
    M555 P2 ; Set firmware compatibility to look like Marlin
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X200 Y200 Z180 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 Z1 S0 ; Set active low endstops
    M558 P0 X0 Y0 Z0 H5 F120 T6000 ; Set Z probe type to switch, the axes for which it is used and the dive height + speeds
    G31 P500 X0 Y0 Z2.5 ; Set Z probe trigger value, offset and trigger height
    M557 X25:175 Y25:175 S20 ; Define mesh grid

    ; Drives
    M569 P0 S0 ; Drive 0 goes backwards
    M569 P1 S0 ; Drive 1 goes backwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X128 Y128 Z128 E16 I0 ; Configure microstepping without interpolation
    M92 X640 Y640 Z3200 E100 ; Set steps per mm
    M566 X900 Y900 Z12 E120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X12000 Y12000 Z1200 E3000 ; Set maximum speeds (mm/min)
    M201 X1000 Y1000 Z100 E5000 ; Set accelerations (mm/s^2)
    M906 X855 Y855 Z855 E855 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Heaters
    M305 P0 T100000 B3988 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4725 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Network
    M550 Pwanhao-di3 ; Set machine name
    M552 S1 ; Enable network
    ; Access point is configured manually via M587 by the user
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Custom settings are not configured

    ; Miscellaneous
    T0 ; Select first tool



  • I'm not sure what's happening with it, it didn't used to do this. Now it slips every now and again, or does the grinding/juddering action as seen in the video.


  • administrators

    It's possible that the E0 stepper driver is intermittent. Have you tried using the E1 motor output instead?



  • This is what my section of the config.g file looks like, nothing is immediately screaming out to me as wrong, but maybe give it a try.

    But your motor currents are a bit high, assuming your motors are similar, particularly the Z axis motors are extremely high, I initially based my configuration off of the config on GitHub but have since then changed quite a bit of it, I had a big improvement on Z stepper motor noise once I lowered the values. Check your stepper motor model numbers to be sure.

    M350 X16 Y16 Z16 E16 I1 ; set 16x microstepping with interpolation
    M92 X80 Y80 Z400 U400 E96 ; set axis steps/mm
    M566 X480 Y480 Z12 U12 E120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X12000 Y12000 Z1200 U1200 E3000 ; Set maximum speeds (mm/min)
    M201 X800 Y800 Z100 U100 E5000 ; Set accelerations (mm/s^2)
    M906 X700 Y700 Z351 E918 I30
    M84 S30 ; Set idle timeout



  • @dc42 - I don't think anything is actually wrong with the extruder now. I think that was just all on me, I guess I should update the title. It's a bit of a misnomer at this point. I think my bed leveling was off and I simply jammed the assembly, locking the motor in place when I first had this problem, I took it off to clear the jam and so some reason didn't reattach the connector.

    @MarMed - I'll try that when I get home from work. Thanks.



  • I've not quite got it to print yet, I hit the stop after about 20 seconds, but with your settings MarMed I didn't notice any violent lurching like before. So within any luck… That's that sorted.

    Did notice something now that grinding is gone, there is another grinding from the extruder stepper. The stepper can't seem overcome the pressure holding the fillament in place from the feeding mechanism without having an external force assist it from above. So... I probably have that a little too tight.... So the extruder issue was mechanical after all. (my extruder mechanism is new to me, I bought a Flexion kit along side the Duet. Probably should have taken one thing at a time.)


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.