Incorrect/unwanted DWC status updates



  • I've been using my Duet Wifi for about 9 months. For at least the last 6 months, sometimes the web interface gets "confused" and shows the wrong information. For example, in this screenshot I send an [c]M572 D0 S0.2[/c] command, but the box that pops up shows the response to a previous command (in this case an [c]M207[/c]):

    When in this state, I also get similar popups when operating the UI. Recently I was trying to move the head down in 0.1mm increments, but each time I pressed Z-0.1, that large popup status (reporting the results of an [c]M207[/c] or similar, plus a lot of blank space) would appear. If I pressed Z-0.1 several times quickly, multiple popups appear, blocking the Z-0.1 button.

    Finally, when DWC gets in this state, I get old data for new commands. For example:

    The Z lift did change to 0.24 in reality/functionally, but I'm getting the old Z lift (and many empty lines) in the confirmation.

    I'm seeing the same behavior in Chrome and Firefox, so it doesn't seem to be a browser or browser cache problem. Currently running:
    Firmware Version: 1.20RC1 (2017-12-08)
    WiFi Server Version: 1.20b10
    Web Interface Version: 1.19.3

    But I've had this problem for at least 6 months, I think ever since I started using DWC. I haven't reported it before because I figured everyone must see it so it will get fixed soon, but apparently not.

    Is anyone else seeing any of these symptoms? What subforum are we supposed to use to report DWC issues?



  • I have experienced this too. Are you connected to DWC with more than one device? That is a known cause of at least some of the notification weirdness, but I can't say if it is exactly yours.



  • I see this occurring as well sometimes, on 1.19.2/1.19.



  • @KeeganB:

    Are you connected to DWC with more than one device?

    Yes I am connected from multiple devices… So sticking to one might be a good work-around, but being able to connect from multiple devices is supposed to be a benefit of a web interface, isn't it? I hope this is being worked on.

    Also (as shown in my last email) I haven't yet updated to the latest DWC - maybe it's already been addressed.



  • I get this too. Was trying to baby step my first layer and get getting numerous popups. I do connect using several devices



  • If you connect with a second device, or if you pull the printer status with curl, be sure to go to this url to resolve this problem: http://192.168.0.192/rr_disconnect
    I had the same problem, I was pulling the status with curl to display it in my statusbar, and adding a call to http://192.168.0.192/rr_disconnect after getting the json data resolved it.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.