Can't connect to wifi after firmware update



  • Today I've updated from 1.18.beta3 to 1.20.1rc2, and am having issues connecting to my wifi again.

    I did follow the instructions at https://www.duet3d.com/wiki/Upgrading_to_DuetWiFiFirmware_1.19
    But I am not sure if I need to use ' chars for lowercase characters as per https://duet3d.com/wiki/G-code#M587:_Add_WiFi_host_network_to_remembered_list.2C_or_list_remembered_networks (I've tried with and without)

    If I boot printer and execute my macro to add the wifi network then run the following:

    [[language]]
    M587
    
    Remembered networks: Mato24 IP=0.0.0.0 GW=0.0.0.0 NM=0.0.0.0
    
    M552 S1
    
    WiFi reported error: Failed while trying to connect to Mato24 Wifi module is idle
    
    M115
    
    FIRMWARE_NAME: RepRapFirmware for Duet WiFi FIRMWARE_VERSION: 1.20.1RC2 ELECTRONICS: Duet WiFi 1.0 FIRMWARE_DATE: 2018-01-01
    
    M589
    
    Failed to retreive own SSID data
    
    

    From my router:

    Is there any way to report the wifiserver version?

    Any other suggestions?


  • administrators

    The WiFi server version is reported on the Settings Page of DWC and also in the M122 report.

    You don't need to use the ' characters if you put the M587 command in a macro with the SSID and password in the correct case.



  • @dc42 I can't access DWC though as I can't connect to my wifi 😉



  • ran M588 S*

    then my add network macro and it's working now..



  • well I got one time connection.. now I can't again



  • Hey there @Zesty Brian! It's Jonathan from over on your discord server. I, too, ran into this annoyance while performing similar updates to the firmware if my duet wifi board. What ended up working for be was to pull the SD card from the duet, copy over the firmware 2 firmware files as instructed on the page linked below, and then follow the recovery direction for fallback scenario #3 found in this page:

    https://www.duet3d.com/wiki/Updating_main_firmware

    Oddly, despite multiple attempts at adjusting the SetNetwork macro which uses the shory script described in the @updating to firmware 1.19 from below that which explains to disable the M552 S1 line of your current [SDcard]:\sys\config.g (simply modify the line to read ";M552 S1" by adding the leading semicolon) file before the dual upgrading of the firmware packages by issuing the M997 S0:1 from Paneldue once the files are in place and you have written the macro containing the M587 command with your appropriate details for SSID and password. Once all the prerequisite steps are completed and you go ahead with issuing the M997 S0:1 command, the last step is to run the macro file which will add your SSID to the known network list, then finally you MUST manually issue an "M552 S1" which will illuminate the LED next to the wireless component on the duet wifi board followed by a message displaying the IP address it ended up catching from the server. After all that is completed, you mustn't forget to navigate to the DWC server at that very IP address, go to SETTINGS->SYSTEM EDITOR ->CONFIG.G and edit the semicolon out from ahead of the M552 S1 line which in an earlier step we commented out.

    Really hope this helps. Interestingly, I tried any 5 times to modify the syntax of the macro made called SetNetwork to no avail – kept getting error messages in console after issuing the macro. The only way I succeeded was to literally perform the entire Fallback procedure #3 in that linked site above from start to finish exactly as listed. Then suddenly the configuration settled in and didn't give me any error messages. YMMV.



  • Today I've had a little more luck, but I get disconnects all the time in DWC and am seeing errors on the paneldue console:

    WiFi reported error: incomplete write

    Now I can get a connection to the wifi but it usually drops before I can load DWC fully.

    Neither my printer or router have moved… have spent the better part of 2 days trying to get this working now.. any suggestions @dc42 ?


  • administrators

    Some suggestions:

    1. Which DuetWiFiServer.bin are you using: 1.20 or 1.20+1 ? Try the other one.

    2. Another user reported yesterday that he solved his connection issues by using a static IP address in the M587 command.

    3. Connect a PC via USB, send M111 S1 P14 to enable WiFi debugging, and report here what debugging messages are shown when the disconnection occur.



  • @dc42

    #2 alone didn't do it, but reverting back to 1.20 of DuetWiFiServer.bin seems to have resolved it

    Thanks.



  • Hello. I'm new owner of duet wifi and also was experiencing problems with connecting. My wifiserver version 1.20 (also I had problems with preinstalled 1.19). In the beginning it connected but I've had numerous connection losts and AJAX webcontrol errors. So I've tried updating it to 1.20 version. It worked some time but after that it stopped connecting at all. Changing channels (btw in my flat it's totally useless because ALL 2.4ghz channels are overloaded, so I mainly use 5ghz wifi for my devices), wifi modes, I've tried everything - even using dedicated asus rt-n66u router solely for duet, but it wasn't any help.
    And when I was totally frustrated I've tried to connect to my neighbour's open (no password) DIR-320 router (d-link I presume).
    And it connected with no problems! Webcontrol was loading just instant, no AJAX errors at all.
    So today I want to try creating AP with no password on my routers and see how it goes with duet. (Also want to try static IP address).

    upd:

    1. static address - nope, it didn't help. It connected and got IP but I couldn't open webcontrol, it starts loading but very slow.
    2. Created AP with no password - connected with no problems.

  • administrators

    Interesting, I wasn't aware that enabling/disabling WPA2 could make a difference. Have you tried DuetWiFiserver 1.20+1 yet? It's at https://github.com/dc42/RepRapFirmware/blob/dev/EdgeRelease/DuetWiFiServer.bin (follow the link, then press Download).



  • So although I thought reverting to 1.20 duetwifiserver resolved the issue I am still getting DWC disconnects, just far less often now.



  • I have had a lot of the same issues using the v1.20+1 I used to get the odd issue with v1.20 but no where near as much as v1.20+1 I will revert back to v1.20 for now



  • @dc42:

    Interesting, I wasn't aware that enabling/disabling WPA2 could make a difference. Have you tried DuetWiFiserver 1.20+1 yet? It's at https://github.com/dc42/RepRapFirmware/blob/dev/EdgeRelease/DuetWiFiServer.bin (follow the link, then press Download).

    Sorry no help. I'm still using with AP without password (set my AP to use MAC address filters because of security). Sometimes I experience rare disconnects.
    AP with WPA2 password just don't work in my case. Firmware now - 1.21RC0 and 1.20+1 wifi.



  • Just reporting back that after updating my network gear to Ubiquiti Unifi kit everything is working properly again.


  • administrators

    Brian, what make/model of router were you using before when you had the disconnections?



  • David just for info My Wifi wont connect at all to my Netgeear D6400 router but works to the cheap TP-Link travel router think it is a TL-720N or whatever I am due to change provider next week so will see what there Router is like I will report Back later.

    Doug



  • I'm getting the same error now, since replacing my power supply. When I turn the Duet on, it either reports no wifi networks, or that it "failed while trying to connect" to the one it previously used without issue.

    So back to troubleshooting!

    17:04:00.737 : serial: M552 S1
    17:04:00.742 : WiFi: mode : sta(5c:cf:7f:76:73:38)
    17:04:00.743 : WiFi: add if0
    17:04:02.931 : WiFi: scandone
    17:04:02.939 : WiFi: ../src/SocketServer.cpp(353): found network BLANK1
    17:04:02.945 : WiFi: ../src/SocketServer.cpp(353): found network BLANK2
    17:04:02.954 : WiFi: ../src/SocketServer.cpp(353): found network BLANK3
    17:04:02.961 : WiFi: ../src/SocketServer.cpp(353): found network BLANK4
    17:04:02.969 : WiFi: ../src/SocketServer.cpp(353): found network ETC
    17:04:03.015 : WiFi: sleep enable,type: 2
    17:04:03.578 : N13 M10521
    17:04:05.206 : WiFi: scandone
    17:04:05.208 : WiFi: state: 0 -> 2 (b0)
    17:04:06.209 : WiFi: state: 2 -> 0 (2)
    17:04:06.210 : WiFi: reconnect
    17:04:06.645 : N14 M105
    18
    17:04:08.401 : WiFi: scandone
    17:04:08.403 : WiFi: state: 0 -> 2 (b0)
    17:04:09.402 : WiFi: state: 2 -> 0 (2)
    17:04:09.403 : WiFi: reconnect
    17:04:09.707 : N15 M105*19
    17:04:11.593 : WiFi: scandone
    17:04:11.596 : WiFi: state: 0 -> 2 (b0)
    17:04:12.595 : WiFi: state: 2 -> 0 (2)
    17:04:12.596 : WiFi: reconnect
    17:04:12.598 : ESP reported status change
    17:04:12.598 : WiFi reported error: Failed while trying to connect to BLANK3
    17:04:12.598 : WiFi module is idle
    17:04:12.598 : WiFi: scandone
    17:04:12.598 : WiFi: del if0
    17:04:12.599 : WiFi: usl
    17:04:12.601 : WiFi: mode : null



  • Not too sure if it's relevant, but I'm getting reset buffer blocks via the COM port now. Not sure if that was happening previously.

    Firmware version 2.02beta1(RT0S) - date 2018-08-12b5
    Duet Wifi 1.02 or later

    Using M588 S"*" to forgot the existing network, allowed me to use M587 S"network" P"password" to connect (M552 S1) to a new network. I'll check now if I can still connect to the old one.

    Final edit; problem solved by deleting the network and reconnecting. No idea why.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.