Titan aero steps pr mm



  • After i upgraded to latest firmware, my extrution is way off .

    Nomatter what i set the step pr mm to, it dosnt change a thing ?

    Config.g :

    ; Configuration file for Duet WiFi (firmware version 1.17 to 1.19)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Oct 28 2017 00:02:03 GMT+0200 (Mitteleuropäische Sommerzeit)

    ; General preferences
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates…
    M83 ; ...but relative extruder moves
    M555 P2 ; Set firmware compatibility to look like Marlin
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X400 Y400 Z400 S0 ; Set axis maxima
    M561 ; Cancel any existing bed compensation
    G29 S1 ; load hight map

    ; Endstops
    G91 ; relative mode
    G1 Z4 F200 ; raise head 4mm to ensure it is above the Z probe trigger height
    G90 ; back to absolute mode
    ;G1 X200 Y200 F2000 ; put head over the centre of the bed, or wherever you want to probe
    G30 ; lower head, stop when probe triggered and set Z to trigger height

    M574 X1 Y1 Z1 S1 ; Define active high microswitches
    M558 P1 X0 Y0 Z0 H5 F120 T12000 ; Set Z probe type to switch, the axes for which it is used and the probe + travel speeds
    G31 P500 X0 Y0 Z1.567 ; Set Z probe trigger value, offset and trigger height
    M557 X50:350 Y50:350 S50 ; Define mesh grid

    ; Drives
    M569 P0 S0 ; Drive 0 goes backwards
    M569 P1 S0 ; Drive 1 goes backwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forkwards
    M92 X80 Y80 Z400 E851; Set steps per mm
    M350 E32 I1 ; Configure microstepping with interpolation
    M350 X32 Y32 Z32 I1 ; Configure microstepping with interpolation
    M566 X1200 Y1200 Z20 E300 ; Set maximum instantaneous speed changes (mm/min)
    M203 X30000 Y30000 Z800 E3000 ; Set maximum speeds (mm/min)
    M201 X500 Y500 Z130 E2500 ; Set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Heaters
    M143 S265 ; Set maximum heater temperature to 265C
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1

    ; Tools
    G10 P0 S[extruder0_temperature] R[extruder0_temperature]

    My tool definitions are (Note I'm using Fan 1, you probably don't need/want that):
    M563 P0 D0 H1 ;F1 ; Define tool 0
    G10 P0 S0 R0 X0 Y0 ; Set tool 0 operating and standby temperatures
    M307 H1 A326.1 C168.0 D6.1 B0 ; PID settings for H1
    M563 P1 D1 H1 ;F1 ; Define tool 1
    G10 P1 S0 R0 X0 Y0 ; Set tool 1 operating and standby temperatures
    ;M92 E90.13:92.67 ; Set extruder steps per mm

    ; Network
    M550 PCR 10 TITAN ; Set machine name
    M552 S1 ; Enable network
    M587 S"SSID" P"PASSWORT" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Fans
    M106 P0 S1 I0 F500 H1 T50; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P1 S0 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P2 S255 ;MCU fan thermostatic

    ; Custom settings
    ;M912 P0 S-13 ; calibrate MCU Temp

    ; Miscellaneous
    M501 ; with PID Tune data
    T0 ; Select first tool



  • Hello, M350 needs to be set before M92.



  • @Martin_S:

    Hello, M350 needs to be set before M92.

    not really, if you use M92 before M350, the firmware assumes 16x microstepping for M92.



  • @whosrdaddy:

    @Martin_S:

    Hello, M350 needs to be set before M92.

    not really, if you use M92 before M350, the firmware assumes 16x microstepping for M92.

    Uhhm, yes, but he is using x32 miscrostepping.



  • from the documentation:

    When M350 is processed, the steps/mm will be adjusted automatically to allow for any changes in microstepping. Therefore you can either: a) Set Steps/mm correctly for the default 1/16 microstepping, then set the microstepping to the desired amount using M350:

    M92 X80 Y80 Z400 ; set axis steps/mm
    M92 E420:430 ; set extruder 0 and 1 steps/mm
    M350 X128 Y128 Z128 E128:128 ; set microstepping



  • @Camalot977: I don't know if it matters but interpolation only works with 16x microstepping.
    from the documentation:

    M350: Set microstepping mode
    Usage
    M350 Xnn Ynn Znn Enn Inn
    Parameters
    Not all parameters need to be used, but at least one should be used. As with other commands, RepRapFirmware reports the current settings if no parameters are used.
    Xnn Set stepping mode for the X axis
    Ynn Set stepping mode for the Y axis
    Znn Set stepping mode for the Z axis
    Enn Set stepping mode for Extruder 0 (use Enn:nn:nn etc. for multiple extruders)
    Inn Enable (nn=1) or disable (nn=0) microstep interpolation mode for the specified drivers, if they support it. The Duet WiFi and Duet Ethernet support interpolation (to x256 microstepping) only when configured for x16 microstepping.



  • You are right. I got confused, sorry.
    I'm going to bed now 😛



  • i tried swapping M92 and M350 as sugested. Still doesnt change a thing ?

    the fun part is that it worked fine before ??



  • Drives
    M569 P0 S0 ; Drive 0 goes backwards
    M569 P1 S0 ; Drive 1 goes backwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forkwards
    M350 E32 I1 ; Configure microstepping with interpolation
    M350 X32 Y32 Z32 I1 ; Configure microstepping with interpolation
    M92 E907 ; step pr mm extruder
    M92 X80 Y80 Z400; Set steps per mm
    M566 X1200 Y1200 Z20 E300 ; Set maximum instantaneous speed changes (mm/min)
    M203 X30000 Y30000 Z800 E3000 ; Set maximum speeds (mm/min)
    M201 X500 Y500 Z130 E2500 ; Set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout



  • @Martin_S:

    @whosrdaddy:

    @Martin_S:

    Hello, M350 needs to be set before M92.

    not really, if you use M92 before M350, the firmware assumes 16x microstepping for M92.

    Uhhm, yes, but he is using x32 miscrostepping.

    But if the M350 is after the M92 then the Steps/mm is adjusted automatically and without you needing to do it manually and this is exactly how he should have it arranged unless of course he is using 40 tooth pulleys which I doubt.



  • What is actual problem you have with the extruder? Changing firmware shouldn't have any effect. If you have a 1.8 degree motor, the steps per mm at 16x on a titan should be around 400. For a 0.9 degree motor they will be double that so around 800. If you use 32X micro stepping those figures will all be double that again. If you set steps per mm first, this will default to 16x so if you change micro stepping after, then Duet will re-calculate for you.

    What you have above is set micro stepping to 32x in you M305, then set the steps per mm using that 32x to 907 which is close for a 1.8 degree stepper but for a 0.9 degree stepper, it is only half of what you need.

    BTW, don't try and print with what you have above because you've also changed the steps per mm for X and Y (probably Z as well). For a 20 tooth pulley and 1.8 degree stepper the steps per mm will be 80 at 16x micro stepping so setting the micro stepping to 32 then setting the steps per mm to 80 will only give you half the movement.
    HTH



  • actually the correct value for a Titan is 837 steps for a 0.9 degree motor on x16 😉



  • my problem is that it dosnt extrude enough filament . only about half.
    It's a 9 degree stepper and i have had it running fine.

    measuring 100 mm filament and mark it and tell it to extrude 100 mm. it only extrudes 60 mm with this setup ?

    M92 X80 Y80 Z400 E837 ; Set steps per mm
    M350 E16 I1 ; Configure microstepping with interpolation
    M350 X16 Y16 Z16 I1 ; Configure microstepping with interpolation
    M566 X1200 Y1200 Z24 E300 ; Set maximum instantaneous speed changes (mm/min)
    M203 X30000 Y30000 Z600 E3000 ; Set maximum speeds (mm/min)
    M201 X500 Y500 Z100 E5000 ; Set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout



  • That config looks fine to me. After calibrating, I run a tad over 400 steps per mm @ 16x on all 5 of my Titans with 1.8 degree motors, so 837 would be about right for 0,9 degree motors. If it was a firmware problem then lots of us would be experiencing issues so I'd say that it's purely coincidental that your problems started after the firmware upgrade. Suggest you look for a partial blockage or some restriction in the hot end that is causing the extruder to skip steps or grind the filament.



  • Are you using the E3D pancake motor as extruder drive? In that case I would use more current for the extruder, I use 1200mA (24V) and get good results, with lower current I the extruder occasionally skipped steps…



  • And it has worked fine for me too until i updated firmware ???? it makes no sense i know . But its a fact. I even tried re uploading the firmware with no change 😕
    So somewhere in my files there is a little gnome teasing me 🐵

    Pancake? dunno . its the motor delivered with the titan ( e3d ) 26 mm thick . And i run on 12V on my system



  • no config is fine, Check M122 to see if you have skipped steps after extrusion.
    I would try to extrude without the heater block connected (in case of clogged nozzle).



  • Facepalm 🐵
    Thank you all for your input
    And thank you whosrdaddy for the solution. i tried extruding without the heatbloc connectet.
    And filament extrudes as it should. so after a cleanup it should work fine .

    Thanks again



  • Ive had a problem with my titan aero , Ive not been able to get to extrude more than about 80mm out of 100mm whatever setting I used .
    I didn`t think about it being a stepper motor under current problem , so decided to give it a try and for the first time with a setting of 1400ma got it to over extrude.

    I think the 800ma default is a little too low for most steppers , but I guess they are working on safety first ?.



  • No firmware update has affected my titan aero.

    I would like to ask you how old is your extruder? I'm asking you this as there was an issue with the titan aero bearings. I had my aero working great until I moved it onto my new coreXY and and the extrusions were inconsistent. It took me a while before i eventually figured out that the bearings were causing this problem due to a friction increase as a result of not only missing steps but also the extruder was getting jammed.

    With new bearings I can still use the pancake (slim nema motor that comes with aero) but I still had to increase the current to 1000 (M906 E1000 I50)

    I am currently using x16 microstepping and works great

    M350 E16 I1 ; Configure microstepping with interpolation
    M92 E950 ; Set steps per mm


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.