BlTotouch and Duet



  • Hi,

    More issues… while solves the problems i am having with Mini Ir Probe, i have decided to install BlTouch....but dont works.

    Someone sees some error...

    I am followed this guide, located in facebook group for TLM Duet users:

    RESULTS

    A - When start printer, BlTouch blinks and deploy/retract
    B- But…. When execute a macro from deploy or retract, the same error message

    [[language]]
    M98 P0:/macros/BlTouchDeploy.g
    Error: Invalid servo index 3 in M280 command
    
    

    The contents of macro "BlTouchDeploy.g" is:

    [[language]]
    M280 P3 S10 I1
    
    

    One posibility… is that PIN8, its no H3...

    Some ideas?
    Help for someone working with BlTouch in Duet.

    P.D.: Trace in rear BlTouch is cuted, and i have tested there isn't continuity


  • administrators

    That error message suggests that you don't have the M307 H3 A-1 C-1 D-1 command in config.g. Try sending M307 with no parameters. If that line is present and working, the response should be "Heater 3 is disabled".



  • hi,

    this have in config.g, i have copy from guide….

    [[language]]
    ; BL-Touch
    M307 H3 A-1 C-1 D-1 ; reserve pin 21 for M42 or servo use
    M558 P5 X0 Y0 Z1 H5 F100 T2000
    G31 P25 X0 Y0 Z1.083; Set Z probe trigger value, offset and trigger height
    ;INCREASE VALUE WILL LOWER NOZZLE CLOSER TO THE BED, DECREASE THIS VALUE
    WILL RAISE THE NOZZLE FROM THE BED
    
    

  • administrators

    …and what response do you get if you send M307 with no parameters?

    You may have a M307 H3 command in config-override.g too. If so, delete it.



  • Eeee…

    No response, double check...

    update...

    Now, when send by console Retract and Deploy. Nothing happens
    And BlToucn after start, rest lighted



  • I follwed this guide to get my bltouch working: https://betrue3d.dk/bltouch-on-duet-wifi-duetreprapfirmware/
    The only thing I needed to change was adding the I1 to the end of the deploy/retract commands.



  • i have followed this guide too.. and nothing, don't works…

    I do not know if the behavior is normal.
    When I turn on the printer, the BlTouch, makes a test, the tip comes out and picks up, two or three times. When this test ends, a red light remains on.
    Is it normal for this red light to stay on?
    It sounds to me that this indicated an error. Do not?



  • No, it is correct if it stays red after the initial self test. Mine does that too and works fine.
    If deployed the led is off, and when I tip it / it gets contact to the plate when probing the led turn red again.
    (I have the bltouch smart)



  • Hi,

    thanks to all, and sorry for disturb….

    Mistake mine, how no.....

    Whats the mistake...

    i was conecting (BlTouch- Orane pin - Ctrl) to (Duet -Expansion socket - PIN 7) and.... NO, BIG NO its in PIN 8

    This is correct: (BlTouch- Orane pin - Ctrl) to (Duet -Expansion socket - PIN 😎

    Thanks to all, and sorry



  • Another question…

    When i have instaled Mini IR sensor, the field (Z-Probe) of web interface, chage when Mini IR was triggered...

    With BlTouch, this field, have to change? or show any valor?


  • administrators

    I think the bltouch produces just a short pulse, so you probably won't see the reading change in the web interface. To test the Z probe, with the probe a long way above the bed, send G30. Then hold an obstruction below the bltouch to trigger it. If triggering the bltouch doesn't stop the Z movement, turn off power to the printer or use emergency stop before it reaches the bed.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.