Problems updating firmware - now board unconcious!



  • I've been using my (1 month old) Duet WiFi on a self designed & built Delta Printer. Until yesterday, everything was going OK setting up & tuning. I decided to update the firmware to address the jerkyness problem moving the head in circles (the Internet told me to do it!).

    I used the web interface for the printer, clicked the update firmware button to load 1.15e from here: https://github.com/dc42/RepRapFirmware/tree/dev/Release/Duet-WiFi
    It started transferring OK, then the web interface disconnected with an AJAX Error. After that, the web interface just showed a 404 Page Not Found message, though the PC could still connect to the IP address. PanelDUE just sat there saying Connecting - and it would not connect via USB. It just showed as 'Unknown Device' though previously it was working with Pronterface.

    OK, something's been corrupted - reinstall the firmware!

    Followed the instructions here: https://duet3d.com/wiki/Updating_main_firmware Procedure #3
    Download SAM-BA, Erase, Reset, Select at91sam4e8-ek, open DuetWiFiFirmware and upload. Everything fine so far.
    Execute the firmware (Boot from Flash) - then the USB Disconnects from the PC and after 5 mins, reconnects as 'Duet Printer Control Electronics (Comm 12)'
    "Great" I think!
    Unfortunately, though Pronterface sees the comm port but it cannot connect to it. There is no WiFi connection and PanelDUE sits saying 'Connecting' for a few mins then says 'Starting Up' (for an hour so far).

    Every few seconds, the blue light on the ESP#### WiFi board flashes and the USB disconnects from the PC (making the USB Disconnect chime). Device Manager refreshes at the same moment - but still shows 'Duet Printer Control Electronics (Comm 12)'

    I've tried re-flashing the firmware several times as well as updating the USB Drivers (From https://github.com/dc42/RepRapFirmware/tree/dev/Driver)).
    I've tried re-starting the PC as well as two other laptops - all behave the same.
    I've tried several different USB Leads - all the same.

    I don't like having to ask for help - but it's got me stumped!

    Have any of you got any ideas? I really don't want to have to dismantle the thing to send the board back!

    Si

    P.S. I should add, I love the board and the whole ecosystem! Those involved deserve a lot of credit!


  • administrators

    It could be a problem with the SD card. PanelDue shows "Starting up" when the Duet has acknowledged it but has not finished processing config.g. So put the SD card in a PC and check it for corruption. If necessary, reformat it and put a fresh copy of the /sys files on it, or try a new SD card.



  • Thanks David - I'll try that now!

    Si



  • Sadly - that didn't help!
    No obvious corruption. Did a low level format and restored the original files from Github - behaves the same
    Tried brand new 8Gb Card with original then my edited files - still nothing.
    Any other options?

    Si


  • administrators

    I can think of the following possibilities:

    1. Something in your config.g is triggering an undiscovered firmware bug. But if you have restored config.g from github, we can rule that out.

    2. A power supply problem. If you are using USB power only, bear in mind that a typical PC USB port cannot handle a Duet + 7" screen, and some USB ports may struggle to handle a Duet + 5" screen.

    3. A fault has developed on your Duet WiFi. If you have ruled out (1) and (2), ask your supplier for a replacement under warranty. You will probably be asked to send your Duet WiFi to me for investigation.



  • And the answer is….2 - well, kind of
    It turns out that the firmware was running OK. Every time the ESP tries to connect (Blue LED Flashes), the power dips and the board reboots.
    I've tried powering the board via a powered USB Hub, with PanelDUE disconnected - and Pronterface then connects.
    But......
    When you send M552 S1 to connect to the network, the same thing happens and it re-boots. Later I'll put a scope on the Vcc line to see.
    Same happens powering the board from 24v.
    I think therefore it is a power issue - the USB / On board regulator cannot supply enough juice for the ESP.

    Si


  • administrators

    It sounds like the ESP on your Duet WiFi needs to be replaced. Contact your supplier for a replacement board.



  • That's a shame. Will do.

    Thanks for your speedy help.

    Si


  • administrators

    One more thing to check: disconnect anything you have that might be drawing excessive power from the 3.3v rail, such as the Z probe and any endstop switches you have that use the centre pin of the endstop connector. It could be chat the 3.3V regulator is overheating.



  • I put a scope on it last night. The 3.3v rail stays within a few mV - no spikes or drop-outs that I could see.

    There's nothing getting obviously hot:

    The hottest point top right, is the SD Socket
    The alignment of the visual & thermal on this is a bit out - but you get the idea.

    These were taken after the board had been powered (from 24v) for half an hour in a pretty cold workshop (16C)

    Si



  • I've disconnected the Z probe. None of my end-stops use the centre pin - but I disconnected them as well. No change.

    The only thing that makes a difference is to comment out this line in Config.g
    ;M552 S1 ; Start WiFi

    Then it's as normal, but without the Wifi (Obviously).

    I think it's reasonable to conclude that the ESP is dodgy!

    Si


  • administrators

    Looks like the processor is warm and so is the 3.3V regulator. That is normal. What surprises me is that the crystal and the SD socket appear to be warmer than either.



  • I'd guess that's IR reflections from the room.



  • My guess is the SD socket is 'hot' because of the residual heat from me holding the SD Card. It's perfectly possible I touched the Xtal at the same time! Mind you, they are only 2C warmer than ambient - so not exactly hot.

    I'd like to thank David for his help and Roland from T3P3 for sending a new board (which works perfectly) so quickly. It arrived at mid-day today. I'll return the dodgy one to David by return.

    Exemplary service all round!

    Si


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.