Extruder keeps stuttering… out of ideas



  • Hi,

    Has anybody any idea how i can avoid a stuttering extruder?
    first attempt with a direct extruder with flex3drive, stuttering…
    now i have a bowdendrive with a bulldog xl (a 5:1 geared extruder) which would normaly eat my filament,... stuttering

    I first tried a V5 from e3d-online, after that a V6, now i have a Volcano, tried all diameters, always the same easily pushed by hand stuttering with the extruder.
    I tried all temperatures from 180 till 250. stuttering...
    i tried all different settings for my extruder ranging from 0.5 till 1.1 A => stuttering

    i tried three different steppermotors with the flex3drive => stuttering

    tried PLA and ABS (both two different colors) => stuttering

    Anybody has any idea what i forgot to try.

    If i push the filament by hand it flows with ease.

    I have here a very nice paperweight which has printing dimensions of 1meter by a diameter of 60cm. It has a changed smarteffector, it has a hanging extruder driver, really a very nice machine, if it just could print a little bit....

    greetings,

    Pieter



  • Not sure what you mean by shuddering? Is it a wiring issue? Did you test the poles (continuity) of the stepper motor to make sure they are right?



  • The stepper blocks, and then it starts stuttering. It starts moving, blocks, tries again, blocks again, etc
    . And every time it shudders it activates the smarteffector.

    example of stuttering stepper https://www.youtube.com/watch?v=KWVXZO_TMkw
    (not mine just an example i found on the internet which is exactly what mine is doing)

    The wiring is checked already 20 times if not more by now. Any idea how i can rule wiring mistakes out?
    As far as i know the polarity doesn't matter because you can switch it in the config file.
    It does work, in that way that it can feed and retract the filament in the bowden tube, until it reaches the extruder. But when there is a problem in the heating head and the filament blocks, the extruder should start grinding away the filament. it should be strong enough but instead from the moment it needs to exert some force it starts blocking and stuttering.



  • It looks like there isn't enough torque to drive the filament.


  • administrators

    What model of stepper motor are you using for the extruder drive?



  • Its just a generic nema 17 stepper motor with no extra info available.

    The only info you can find is the info on their site and it is very minimal:

    ideal current 0.6A maximum current 1A
    gear box ratio 5.18:1
    colorcode for wires:

    A+:Red
    A-:Brown
    B+:Yellow
    B-:Blue

    and that's it: i contacted them to ask the type of steppermotor used, we'll see what they answer


  • administrators

    The gear ratio looks OK but the rated current is a it low. Is it Nema 17 size?

    If you suspect a faulty stepper driver, you can connect the extruder motor to the E1 motor output instead of E0, and use D1 in your M563 command instead of D0.



  • It is indeed a nema 17.
    I thought the rated current was low indeed, but i found this rates on their website, so i expect them to be right. Other people are using this rates without problem.

    i tried the other extruder-driver already, didn't solve the problem 😞



  • I changed the extruder, a Nema 17 (42BYGHW811) with a direct drive gear shaft for pushing the filament.
    changed to a 1,75mm Volcano instead of a 3mm Volcano. Give it 1.0A in the config file.
    The heater is a 40W and the filament is black PLA. I tried temps between 190 and 210. Lower then 190 it's not hot enough to melt the filament fast enough
    Stuttering at every speed.

    When i try to push the filament it looks like it blocks somewhere in the heating head. (connection between heatbreaker and nozzle?) I have to overcome a certain force and then it flows perfectly. When i stop pushing it blocks again.

    Anybody has a suggestion for a better nozzle/heater-system on a delta?



  • If you disconnect the bowden tube at the smart effector and just left it push filament into the air do you have any problems? If you dont then perhaps you have an issue in the hot end assembly, things I would check in no particular order -

    • Temperature, I'd try 220c for PLA - I've found this is my go to temperature for the filaments I buy (cheap stuff 🙂 and the speed I print)

    • Retraction, too much and you might be causing a bulge to form in the filament. Causing a jam

    • Nozzle, Is it fitted per the e3d instructions, otherwise you might have a gap causing a bulge to form.

    • Nozzle, any chance of a partial blockage, have you go something like a syringe you can use to ream out the nozzle when its hot.

    • Did you use the thermal compound when assembling the hot end?

    • If you disconnect the bowden tube from the effector and manually push the filament, increasing the temp 5c between tries is the temperature making it any easier.



  • As DADIY notes; a restriction/bulge in the hotend can cause uneven flow with pressure. I had exactly this sort of issue unless I turned speed ridiculously low on my first printer.. compounded by very low first layer speeds that fooled me into thinking flow 'must be ok' for too long as prints only turned blobby on upper layers. In my case it was the PTFE tube in my hotend that had a crimp in the nozzle end, looked like it was cut to length with wirecutters during manufacture, YMMV. Pushing it round and making the end flat with a craft knife solved the problem. As per your description I could feed filament effortlessly up to a certain point, but over that the whole thing would lock up. Bit like stirring custard mix or one of those other (antifixatropic? I think the word is) substances that lock solid over a certain pressure.



  • It has to be something like that. It goes effortlessly until approximately the start of the heatbreak. So probably there is some kind of minimal obstruction there. but enough to block the filament. I will disassemble the extruder head again for the 300th time and check for some obstructions in the flow channel or tube or connection of both.

    thanks both for the advice.

    i post the follow up



  • Found one of the problems: E3d delivered me three 1,75mm nozzles where i ordered 3mm nozzles. The fact that i didn't use any 1,75 mm nozzles before i didn't notice the difference, i thought it was normal to have a bigger melting room with a bigger diameter. Because i ordered now 1,75mm nozzles, i noticed they were the same as some of my previous nozzles.

    But because the supposed 3mm nozzles didn't work, i started modifying my heatsinks, I changed a direct drive to a bowden by adding a threaded clip on top of the direct drive heatsink. This didn't work out (ridge on the inside) so now i have two damaged heatsinks, and no working extruder. Also i just discovered that xl Bulldog extruders are delivered with too wide tubing. They deliver 6/4 mm for the 3mm filament and 5/3 mm for the 1,75mm filament, which makes the filament, specially for the 1,75mm filament blocking on the entrance of the heatsink.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.