Probe Help



  • I have a bltouch

    m307 H7 have it set to heater 7 in config
    internal +5 jumper set
    if i do a m307 h7 says heater disabled i don.'t have a config-override file yet so its not that
    if i do a m307 h3 it looks like its enabled but i am not on that heater 3 i am on heater 7
    checked wiring over and over look good

    I can issues all the commands deploy retract test mode and release form error all work

    but with heater 7 disabled it will not stop when probe hit but it's set in the config

    Any suggestions

    Thanks gary



  • Can you post the rest of your config.g?



  • I can will do tomorrow i have it working went back to heater 3

    I do find that with the bltouch it's doesn't seem totally reliable mostly the first run sometimes the probe needs to be
    triggered a couple times before it will probe correctly seems like it's not being read by the software or not sending
    the signal, i did do 3 g30's and got readings from 1.173 1.179 1.184 as for the probe height i don't have a resistor but my bltouch
    has the trace that i cut so i assume you don't need the resistor just doesn't seem as reliable as when i was using smoothieware
    or i'm doing something wrong also set the probe speed way down.

    Gary


  • administrators

    Several users have commented that their bltouch doesn't give very consistent readings. The following features in firmware 1.21 may help:

    • the multi-touch facility (A and S parameters in the M558 command)
    • disabling heaters during probing (B parameter in the M558 command)

    If your bltouch gives less consistent readings than it did before, perhaps you are probing at too high a speed, or the pin no longer slides smoothly in the sleeve.



  • does A work with g30 s1 i set it to 2 and only hit once
    I set b to 1 P to 9 haven't figured out S yet

    I ran g30 9 times and i got back
    1 - 1.204
    2 - 1.214
    3 - 1.209
    4 - 1.199
    5 - 1.189
    6 - 1.189
    7 - 1.199
    8 - 1.199
    9 - 1.189
    looks like it settled down a bit after 3 or 4 hits
    should i set the A to 4 or 5?
    would this be considered close enough or should i look for a different probe?.
    Thanks gary


  • administrators

    G30 by itself sets the current Z height when the probe triggers. To test reproducibility, use G30 S-1.



  • That is what i was using sorry i put G30 S1 in my last post

    Gary


  • administrators

    Looks like either the bltouch or your mechanics takes a few attempts to settle. Based on those figures, using A5 with S about 0.005 might help, but it would be better to fix the underlying problem.



  • Found another problem i moved the axis x0 y-100 z10 and i was going to do a G30 S-1 there
    Now i homed from that position and the x and y towers homed and hit the end stops but the z tower stopped about 30 or 40 mm short and then
    I got the error message G0/G1: insufficient axes homed
    it homes ok as long as i am in the bed center but not from outside.

    Also if i enter x0 y-122 z10 it seems to only go to y-85 that's what the web control shows
    this is my m666 have it set to 100 should make at least 100 i assume or does that need to be a high number
    M665 R122 L288 B100 H315 ; Set delta radius, diagonal rod length, printable radius and homed height
    Gary


  • administrators

    See the FAQ in the wiki for that problem.



  • Got that figured out thanks

    But now have a major problem I'm stuck on

    I have been doing a manual config of the center and the a b c tower corners
    my heights are so far off i am getting lost checked the stops and there the same height and the frame is level square
    I just had smoothieware on the same machine and calibrated good. and haven't touched anything to make it way off,

    My center is at Z0 good but the a b c corners are way off i am getting at build plate x A = 15.30 y B = 15.20 z C = 14.70
    So the corners need to be about 15mm less so if the corners are brought down then the center will be about 15mm off
    and at zero will crash the plate.. I'm sure its something simple in the settings i'm missing.

    any suggestions

    Thanks gary


  • administrators

    Why are you doing a manual calibration when the firmware has a much faster least squares auto calibration algorithm built in? See https://duet3d.dozuki.com/Wiki/Calibrating_a_delta_printer. You can use it without a Z probe if you use P0 in your M558 command.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.