Duet WIFI with Micron Cobra extruder temperature setting



  • I have been try different settings with the reprap configurator and the lowest I get the temperature is somewhere around 396c. Here is all the information I have.
    Temperature sensor: Type-K Thermocouple
    NTC thermistor
    The thermistor type is: 100K ohm EPCOS B57560G104F NTC THERMISTOR
    Polarity for the NTC is not important. Connect it to the Temperature input on the
    Ramps/Sanguilolu/Smoothieboard/Etc.
    For Marlin firmware, the thermistor number is type 1.
    EPCOS 100K Thermistor (B57560G104F)
    Supplier Part Number
    Farnell 3878697
    Obsolete - not recommended for new designs (NRND). Substitute: B57560G1104

    datasheet
    // EPCOS 100K Thermistor #3(B57560G104F)
    // Made with createTemperatureLookup.py (http://svn.reprap.org/trunk/reprap/firmware/Arduino/utilities/createTemperatureLookup.py)
    // ./createTemperatureLookup.py --r0=100000 --t0=25 --r1=0 --r2=4700 --beta=4036 --max-adc=1023
    // r0: 100000
    // t0: 25
    // r1: 0
    // r2: 4700
    // beta: 4036
    // max adc: 1023
    #define NUMTEMPS 20
    // {ADC, temp }, // temp
    uint16_t temptable[NUMTEMPS][2] PROGMEM = {
    {1, 864}, // 864.165363324 C
    {54, 258}, // 258.53991594 C
    {107, 211}, // 211.310066205 C
    {160, 185}, // 185.861725716 C
    {213, 168}, // 168.31793816 C
    {266, 154}, // 154.754297589 C
    {319, 143}, // 143.52544406 C
    {372, 133}, // 133.784751118 C
    {425, 125}, // 125.033500921 C
    {478, 116}, // 116.945124847 C
    {531, 109}, // 109.283980973 C
    {584, 101}, // 101.861768746 C
    {637, 94}, // 94.5095302806 C
    {690, 87}, // 87.0542728805 C
    {743, 79}, // 79.2915563492 C
    {796, 70}, // 70.9409729952 C
    {849, 61}, // 61.5523326183 C
    {902, 50}, // 50.25271896 C
    {955, 34}, // 34.7815846664 C
    {1008, 2} // 2.86606331838 C
    };
    https://cdn.shopify.com/s/files/1/0388/6813/files/INSTALLATION_GUIDE_FOR_MICRON_3DP_EXTRUDERS-REV--4_c75de786-b674-4987-9203-ce1c53da23af.pdf?3870582523988255141


  • administrators

    Can you post the configuration you are using with RRF please. If it's 360+C when it should be room temp that might be that you have it as a 10K thermistor in RRF...



  • Hi,

    In case you are using the original Cobra Extruder thermistor, which is:
    EPCOS 100K thermistor (B57540G0104F000)

    this is the command you should write in the config file:
    M305 P1 T100000 B4066 R4700;
    This command sets Heater 1 (First extruder) (P1) thermistor resistance in 25[deg] (T100000), Beta value (B4066), Thermistor series resistance (R4700)

    In case you (or anyone) have additional questions in regards to Micron E.M.E Cobra extruder, feel free to ask for my support.
    I have plenty of experience for using the Cobra extruder with the Duet.

    HTH



  • HTH

    M305 P1 T100000 B4066 R4700;

    I think I tried this but when I get home I will try it again.
    I tested it with a normal thermistor and got it to work right away.
    I will let you know how it goes thank you.

    Thank you,
    SaltyPetz



  • Hi SaltyPetz,

    1. HTH its abbreviation for "Hope This Helps" 🙂

    2. In case the command I noted did not fixed your problem, Upload your config.g file, as T3P3Tony said. this would assist us to assist you.

    3. In case you have Multimeter, check the resistance of the thermistor at room temp (also make note of the room temperture if you can). report here your findings.



  • I tried using a copy of the other person using a tevo black widow and it still doesn't work. Mine is the same setup except the extruders everything else is the same.

    ; Configuration file for Duet WiFi (firmware version 1.20 or newer)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Mar 03 2018 14:29:05 GMT-0500 (Eastern Standard Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 P"Black Widow" ; Set machine name
    M552 S1 ; Enable network
    M587 S"NETWORKNAMEHERE" P"NETWORKPASSWORDHERE" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards X
    M569 P1 S0 ; Drive 1 goes backwards Y
    M569 P2 S0 ; Drive 2 goes backwards Z
    M569 P3 S1 ; Drive 3 goes forwards E

    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80 Y80 Z1600 E427 ; Set steps per mm for 16x microstepping
    M566 X900 Y900 Z12 E10 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000 Y6000 Z500 E1200 ; Set maximum speeds (mm/min)
    M201 X500 Y150 Z300 E200 ; Set accelerations (mm/s^2)
    M906 X1050 Y1050 Z1300 E1050 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X335 Y260 Z250 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 S0 ; Set active low endstops
    M574 Z1 S2 ; Set endstops controlled by probe
    M557 X0:335 Y45:260 S20 ; Define mesh grid

    ; Heaters
    M301 H0 S1.00 P32.6 I1.360 D79.4 T0.4 W180 B30 ; Use PID on bed heater (may require further tuning)
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S80 ; Set temperature limit for heater 0 to 80C
    M305 P1 T100000 B4725 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S240 ; Set temperature limit for heater 1 to 220C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T100 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S0 I0 F500 H-1 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned off

    ; Tools
    M563 P0 D0 H1 F2 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured

    M307 H3 A-1 C-1 D-1 ;
    M558 P5 X0 Y0 Z1 H9 F200 T6000
    G31 X-48.8 Y-18.2 Z2.3 P25

    ; Miscellaneous
    M501
    T0 ; Select first tool



  • Here it is with your setting now it's at 2000.

    ; Configuration file for Duet WiFi (firmware version 1.20 or newer)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Mar 03 2018 14:29:05 GMT-0500 (Eastern Standard Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 P"Black Widow" ; Set machine name
    M552 S1 ; Enable network
    M587 S"NETWORKNAMEHERE" P"NETWORKPASSWORDHERE" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards X
    M569 P1 S0 ; Drive 1 goes backwards Y
    M569 P2 S0 ; Drive 2 goes backwards Z
    M569 P3 S1 ; Drive 3 goes forwards E

    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80 Y80 Z1600 E427 ; Set steps per mm for 16x microstepping
    M566 X900 Y900 Z12 E10 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000 Y6000 Z500 E1200 ; Set maximum speeds (mm/min)
    M201 X500 Y150 Z300 E200 ; Set accelerations (mm/s^2)
    M906 X1050 Y1050 Z1300 E1050 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X335 Y260 Z250 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 S0 ; Set active low endstops
    M574 Z1 S2 ; Set endstops controlled by probe
    M557 X0:335 Y45:260 S20 ; Define mesh grid

    ; Heaters
    M301 H0 S1.00 P32.6 I1.360 D79.4 T0.4 W180 B30 ; Use PID on bed heater (may require further tuning)
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S80 ; Set temperature limit for heater 0 to 80C
    M305 P1 T100000 B4066 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S240 ; Set temperature limit for heater 1 to 220C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T100 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S0 I0 F500 H-1 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned off

    ; Tools
    M563 P0 D0 H1 F2 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured

    M307 H3 A-1 C-1 D-1 ;
    M558 P5 X0 Y0 Z1 H9 F200 T6000
    G31 X-48.8 Y-18.2 Z2.3 P25

    ; Miscellaneous
    M501
    T0 ; Select first tool



  • @saltypetz said in Duet WIFI with Micron Cobra extruder temperature setting:

    M92 X80 Y80 Z1600 E427 ; Set steps per mm for 16x microstepping
    M566 X900 Y900 Z12 E10 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000 Y6000 Z500 E1200 ; Set maximum speeds (mm/min)
    M201 X500 Y150 Z300 E200 ; Set accelerations (mm/s^2)
    M906 X1050 Y1050 Z1300 E1050 I30 ; Set motor currents (mA) and motor idle factor in per cent

    Change to this:

    M92 X80 Y80 Z1600 E1600 ; Set steps per mm for 16x microstepping
    M566 X900 Y900 Z12 E120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000 Y6000 Z500 E1200 ; Set maximum speeds (mm/min)
    M201 X500 Y150 Z300 E600 ; Set accelerations (mm/s^2)
    M906 X1050 Y1050 Z1300 E800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    

    In regards to the heater problem - if the heater in DWC shows 2000° it means that the temp sensor is disconnected.
    Please upload a picture of your temperature sensor. I suspect this may be a Thermocouple and not a thermistor, and in that case, that's definitely not going to work that way, and you will need either to purchase a thermocouple daughterboard for the Duet or to purchase a thermistor (cheaper and simple solution).

    If the temperature sensor has a braided shield that's definitely a thermocouple and not a thermistor.

    Also, I am not familiar with your specific printer settings, but it looks to me that the accelerations for X and Y axis are low.
    I would recommend adding to your config file the command:
    M204 Pnnnn Tnnnn; Set acceleration for printing moves (Pnn), Set acceleration for printing moves (Tnn)
    That would allow you to change the accelerations in mid print (so you can tune it), while never exceeding the maximum accelerations which were configured using the M201 command.



  • I put a regular temperature sensor and it works perfect.
    This one is a k-type with a metal shield. Also I tried 3 different one it's a daul plus they set a extra. Here is a picture of it. I don't remember the settings but I got it down to 390c.
    I do have a thermocouple daughterboard. I am very new to this duet wifi board. It hard for me now but I'm sure it will get easier in time.
    (https://photos.app.goo.gl/FfKThQruDtJThEFD2)

    Thank you for the help.



  • That's indeed Type-K thermocouple.
    In that case, you will need to connect the thermocouple leads to the Thermocouple daughter board.
    Polarity does matter if you connect it with reversed polarity the temperature will drop instead of rising during heating.
    There are 2 types of thermocouple daughterboards for the Duet:

    1. M31855K
    2. MAX31856MUD (Newer version)

    You can identify which version you have using the following picture:
    0_1523648038794_DuetThermocupleDaughterboards.jpg

    In case you have M31855K, use this command, and connect the thermocouple to channel 1
    M305 P1 X100 T"K"; Set temperature sensor parameters, Heater number (Pn), Heater ADC channel (Xnnn)
    for channel 2 you can use this command:
    M305 P1 X101 T"K"; Set temperature sensor parameters, Heater number (Pn), Heater ADC channel (Xnnn)

    In case you have MAX31856MUD, use this command, and connect the thermocouple to channel 1
    M305 P1 X150 T"K"; Set temperature sensor parameters, Heater number (Pn), Heater ADC channel (Xnnn)
    for channel 2 you can use this command:
    M305 P1 X151 T"K"; Set temperature sensor parameters, Heater number (Pn), Heater ADC channel (Xnnn)

    Due to the fact that thermocouples are prone to electromagnetic interference, it is highly recommended the keep the thermocouple wiring away from stepper motors wiring, and from heaters wiring, because these wires carry varying current which creates electromagnetic fields around them.

    Micron E.M.E provides thermocouples which are ungrounded and have a thick braided jacket, and that helps to eliminate electromagnetic interferences.

    You can read more about connecting thermocouples in the Duet Wiki:
    Connecting_thermocouples



  • @guyaros said in Duet WIFI with Micron Cobra extruder temperature setting:

    M305 P1 X150 T"K";

    This worked. I'm sure i will need a lot more help this is all new to me.
    I am a newbie with this setup so I'm sure I will have a lot questions.
    M305 P1 X150 T"K"; Set temperature sensor parameters, Heater number (Pn), Heater ADC channel (Xnnn)

    Thank you for the help



  • I'm glad I could help.
    You are welcome to ask further questions.



  • Next problem. The board can't handle the power the heaters needed so I have one more power supply. I using the tevo black widow mosfet and the other power supply and the wire gets reat hot to the heater. But when I hooked up the heat to the Duet WIFI the wires also got real hot. Could if be something in the config file.

    Here is the config info.

    ; Heaters
    M301 H0 S1.00 P24.54 I4.3 D34.97 T0.4 W180 B30 ; Use PID on bed heater (may require further tuning)

    M305 P0 T100000 B4036 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S80 ; Set temperature limit for heater 0 to 80C
    M305 P1 X150 T"K"; ; Set thermistor + ADC parameters for heater 1
    M143 H1 S300 ; Set temperature limit for heater 1 to 300C

    Thank you for the help.



  • Forgot to say this I can see the temperature going up for the WIFI page.


  • administrators

    Which heater wires are getting hot: the bed heater wires, or the extruder heater wires?

    What is the power rating of the heater concerned, and what thickness wires are you using?

    If you are using 24V power, are you sure that the heater is a 24V heater not a 12V heater?



  • The extruder wires are getting real hot but I turned it off. The extruder is on a 12V 25A power supply.



  • This is from the Micron support page.

    https://cdn.shopify.com/s/files/1/0388/6813/files/INSTALLATION_GUIDE_FOR_MICRON_3DP_EXTRUDERS-REV--4_c75de786-b674-4987-9203-ce1c53da23af.pdf?3870582523988255141

    Electrical:
    Step motor connections
    Connect the motor wires according to the attached motor spec.
    If you are working with 24V Power supply, reduce the driver (pololu or similar) to about 50% current. This
    can be done by: disconnect PS, rotate the current pot fully counterclockwise and then about 1/8 of a turn
    clockwise, connect the PS and check if the extruder stepper motor able to extrude the filament without
    losing steps (don't forget to turn on the heater).
    Another approach to reduce the current is in the firmware configuration, this can be done only if you have
    a controller and drivers that support this.
    NTC thermistor
    The thermistor type is: 100K ohm EPCOS B57560G104F NTC THERMISTOR
    Polarity for the NTC is not important. Connect it to the Temperature input on the
    Ramps/Sanguilolu/Smoothieboard/Etc.
    For Marlin firmware, the thermistor number is type 1.
    Heaters
    Micron 3DP extruder's heaters are rated for 12V and about 60W (120W for the dual extruder). Make sure
    your board fuse can handle that.
    It is possible to operate the heaters using 24V PS. In this case, reduce the power to 60 % by changing the
    heaters parameters in the firmware. In case of using Marlin firmware, you should look for #define
    PID_MAX 255 in configuration.h file and change it to #define PID_MAX 155
    Polarity for the heater is not important; just connect it to the heater exit

    Thank you for the help



  • Cobra extruder is available with 2 voltage configuration: 12[V] or 24[V].
    the difference between the configurations is the Fan voltage rating and Heater resistance.
    Also, there are several heaters options: 50[W] / 64[W] /100[W].
    Duet extruder heaters can output 9[A], so for 12[V] the power output is 108[W], so no problem at all.
    Please measure the resistance of the heater you have, using Digital Multi Meter, and report here.

    I have never experienced a situation where the heaters wiring of the Cobra got hot. Please take a picture of your wiring. This is very odd.



  • After you'll fix the "hot wires" problem you should run Heater Auto PID tuning
    Please read here before tuning:
    https://duet3d.dozuki.com/Wiki/Tuning_the_heater_temperature_control

    To run PID tuning in your case, use this command:
    M303 H1 P1.0 S230

    After the PID tuning is completed, write the command
    M307 H1
    and write down or print screen the tuning results.

    then, edit your config.g file, and add this line:
    M307 H1 Annnn.n Cnnn.n Dnn.n S1.0;
    Replace nnn.n with the results from the PID tuning.



  • So you want me to unhook the heater and put the meter on the heater wires. Is that what you want me to do?
    If that is what you are asking me to do it is 600 - 700 on 2000k on the meter.
    Can these extruders run off the board or should I put them on a different power supply. I don't want to burn up the board. I had them hooked up to the board and the shut down from low power. Right now I have them on a different power source with the tevo black widow mosfet. But the wires get hot hooked to the board or the mosfet.

    Thank you


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.