Homing vs Print bed layout when printing



  • Here is my specific issue at hand.
    Running the Duet wifi my homing works well reporting back from the web console X300 Y300 Z0. Printer set up is a cartesian, bed dimension is 300x300.

    Z endstop is at lower front left of bed, Y endstop is at bottom rear of printer, X endstop is on left of maching and travels with Z motion.

    What is required so that models print the same as placed in the slicing app. I've never seen this problem before.
    1_1523560187354_Example1.jpg 0_1523560187354_example2.jpg
    Any help will be appreciated.



  • What slicer are you using and how is the bed defined there?
    What does your endstop and axis config commands look like?



  • Looks like your Axis moves backwards to the way your slicer thinks it moves.

    When standing in front of your printer,
    When you move X positive the head should move to the right.
    When you move Y positive the head should move away from you.

    Right now probably everything you print is mirrored to what you really need. Letters and threads would come out backwards.



  • @phaedrux I'm using simplify 3d and the bed is set up for 300x 300y 300z same settings as with a mini rambo and on other versions or ramps with marlin.



  • @timcurtis67 In the web control, Z moves up with a Positive value from the head movement controls, X and Y want a - value to move away from home.



  • If your X endstop is on the left side of the bed then X positive should move it away from home towards the center of the bed.



  • Same goes for Y. If the Y endstop is closest to you standing in from of the printer then Y positive will move it away from the home towards the center of the bed.

    If you invert the axis's you will have to reset up all of you endstops as well. They will seek home in the wrong direction.



  • @timcurtis67 Y endstop is at rear of printer, when y homes the bed is towards the rear of the printer.



  • @timcurtis67 If i invert my motors on Y the bed moves forward looking for home however the endstops for y home are at the rear of the printer Unless I mis understand invert...



  • I just confirmed that when a model is placed in the slicer for example front center 2 inches from front.
    When printed it is at rear center 2 inches from rear only rotated 180 but not mirrored.0_1523564463104_Untitled-1.jpg



  • Can you post the contents of your config.g so we can see how you have the axis and endstops configured?



  • Have you seen this guide for commissioning a cartesian?

    https://duet3d.dozuki.com/Wiki/ConfiguringRepRapFirmwareCartesianPrinter

    I think if you follow it, you'll get to where you want.



  • @phaedrux
    ; Configuration file for Duet WiFi (firmware version 1.17 to 1.19)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Apr 07 2018 02:01:06 GMT-0400 (Eastern Standard Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 PPrinter ; Set machine name
    M552 S1 ; Enable network
    ;*** Access point is configured manually via M587
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives Mapped like this
    ;0 = X
    ;1 = Y
    ;2 = Z
    ;3 = E0
    ;4 = E1 etc

    ; Drives

    M569 P0 S1 ; Drive 0 goes forwards **** X Axis****
    M569 P1 S0 ; Drive 1 goes forwards **** Y Axis****
    M569 P2 S1 ; Drive 2 goes forwards **** Z Axis****
    M569 P3 S0 ; Drive 3 goes Reversed Extruder*
    M350 X32 Y32 Z32 E32 I1 ; Configure microstepping with interpolation

    M92 X155 Y155 Z800 E195
    M566 X900 Y900 Z400 E120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000 Y6000 Z1500 E1200 ; Set maximum speeds (mm/min)
    M201 X500 Y500 Z500 E250 ; Set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X300 Y300 Z300 S0 ; Set axis maxima

    ; Endstops
    M574 X2 Y2 S1 ; Set active high endstops DEFAULTS
    M558 P5 X0 Y0 Z1 H5 F120 T6000 ; Set Z Probe to type Switch or Digital output where Z probe connector is used. Used for z only.;
    G31 P50 X22 Y26 Z8.2; Set Z probe trigger value, offset and trigger height -X goes to far to the left

    ; Heaters
    M301 H0 S1.00 P10 I0.1 D200 T0.4 W180 B30 ; Use PID on bed heater (may require further tuning)
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; BLTOUCH
    M307 H3 A-1 C-1 D-1 ;

    ; Custom settings are not configured

    ; Other Stuff
    M106 P0 S0.0 ; Disable part cooling fan at startup
    M572 D0 S0.05; Set linear advance for direct drive
    M500
    M501



  • I think you have your X axis endstop set as high end instead of low end.
    M574 X1 Y2 S1 is I think what you want based on where your 0,0,0 origin is for the nozzle.

    I think it's only working half way right now because you have the motors direction flipped so that it's moving how you expect it. You'd have to make adjustments to your homing files as well I think.

    But I could be out to lunch.



  • Yes the fact that your parts are flipped instead of mirrored means both X & Y are working backwards. You will have to re-configure your endstops as well.

    Or move your origin to the center of the bed and don't worry with the location of the parts being different. Working from the center of the bed.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.