# Y axis moves, when only X is commanded

  • I am new to the world of 3dPrinting but have some CNC experience, in other words a Newbie, to the Duet.

    The printer is a custom built CoreXY. I have discovered that the Y axis moves when only the X is commanded to move. If send G91 G1 X100 Y100, both X & Y respond as they should. The DWC indicates the position , X100, Y100. If at that point I send G1 X10,the X axis moves 10mm, the Y axis moves + 0.5mm or (.0195-.020in, sorry all my dial indicators are Imperial). The DWC indicates X110 Y100. Sending a G1 X-10, X moves - 10 and the Y moves -.5mm and the dial indicator on the Y) is back to 0. The DWC indicates X100 Y100. It does not acknowledge that the Y axis as moved. This appears to be accumulative. I tested moving X 10 times +10mm moves and watched the Y move each time. The DWC indicated X200, Y100. I then Sent G1 Y0 , it was 50mm short of the home switch.
    I do not have a hotend or extruder mounted at this time or bedheater wired up. I wanted to see this moving to be able to see what and where for the extruder.

    I have run the tests at https://duet3d.dozuki.com/Wiki/ConfiguringRepRapFirmwareCoreXYPrinter and passed them.
    All of the homing tests work homeall.g, homex, homey and homez. I do have to run them in the order of Z, then Y then X.

    here is a partial of my config.g file.
    ; Configuration file for Duet WiFi (firmware version 1.20 or newer)
    ; executed by the firmware on start-up
    ; generated by RepRapFirmware Configuration Tool on Tue Apr 10 2018 12:36:02 GMT-0700 (Pacific Daylight Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves
    M555 P2 ; Set firmware compatibility to look like MARLIN
    M667 S1 ; Select CoreXY mode

    ; Network
    M550 P3DPRINT ; Set machine name
    ;M552 S1 ; Enable network
    M552 S1 P192.168.1.99 ;SET IP ADDRESS
    M553 P255.255.255.0 ;SET SUBNET MASK
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X325 Y415 Z600 S0 ; Set axis maxima

    ; Drives
    M569 P0 S1 ; Drive 0 goes FORWARDS
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    ;M569 P3 S1 ; Drive 3 goes forwards
    M350 X64 Y64 Z128 E16 I1 ; Configure microstepping with interpolation
    ;M92 X80 Y80 Z175 E420 ; Set steps per mm
    M92 Y320 Y320 Z1400 ;mod to test 64 micro stepping
    M566 X600 Y600 Z100 E120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000 Y6000 Z4000 E1200 ; Set maximum speeds (mm/min) CHANGED FROM 6000 TO 600 Z NO CHG
    M201 X500 Y500 Z250 E250 ; Set accelerations (mm/s^2)
    M906 X1500 Y1500 Z1500 E800 I40 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Endstops
    M574 Z1 S0 ; Set active low endstops
    M574 X1 Y1 Z2 S0

  • It sounds like you just need to get the motor directions right. On a CoreXY, for pure X both motors turn the same direction, for pure Y they turn in opposite directions (or it might be the other way round). There is a bit in the Wiki about setting them up. I'll see if I can find it.............

    Edit. Found it. Take a gander here ......https://duet3d.dozuki.com/Wiki/ConfiguringRepRapFirmwareCoreXYPrinter

  • administrators

    My guess is that one of the belt sections whose length varies with XY position isn't exactly parallel to the corresponding axis.

  • @deckingman Thanks for the Reply. I did those tests, and the results were as stated in the wiki.

  • administrators

    I had the exact same issue just last night after swapping a couple of my motors.

    Turns out the reason was a crap connection on one of the leads to one of my motors. I should have known this by the sounds it was making but since it was new motors I overlooked that. The way I diagnosed the issue was to unplug one motor (duet off obviously) and then command it to move with a single motor. One of the motors worked and was quiet, one of the motors did not and was loud. I narrowed it down to further by removing the pins from the molex connectors and holding the pairs together to see if it made the motor harder to turn by hand or not. One pair did not, so replaced both of those connectors (while also testing the bare wire just to be sure) and viola' working printer.

    Assuming that you have the motor directions and everything setup properly as you suspect that you do; this could be a culprit.

  • @dc42 Thanks for your reply. I just tried swapping the test and If I move the Y first, the X moves, just like the Y did. So that means you are right. Now I am not sure how to proceed.

    When I was putting it together I used a 12" caliper and a extension rod that I filed to 6" to use to extend the only way I had of accurately measuring the distances. I measured distances between the X at the ends of the rails and the same on the Y. I believe that I am at .001" or less end to end. The belt that changes length on the outsides in the Y axis look very straight and measure the same width and the ends just before they change direction. (as accurately as I can). Used

  • @msquared Thanks, I will check that out. Both motors sound good and when measuring the distance and repeating positions, it seems good.

  • administrators

    @fxxtoo Mine did not sound good, at all...in retrospect.

    maybe some pictures of your belts / routing would help

  • @msquared I will try tonight to take some pics and post them..Thanks

  • @msquared Here is some pictures, I hope they help get to the bottom of this...
    All comments are welcome...





  • maybe the photos are misleading but it seems that the belts coming from the motors are not aligned with the Y axis rails.

  • administrators

    There is a good diagram that shows which belts must be parallel here http://forums.reprap.org/read.php?397,818906,818924#msg-818924.

  • @dc42 Thanks. I modeled this printer after the last one the Digital Dentist built. I laid a straight edge on the belt and the motor side is out about .6 millimeter. I haven't checked the other side yet. I hope that will fix this. I love the Duet and the 7" Panel. I am glad that I went with this system.

  • @whosrdaddy Thanks, It is off a bit on the motor side.

  • I had to set this aside because of work, but am back at this. I found a post where a guy was having the same issues as I was. https://forum.duet3d.com/topic/3688/corexy-setup-problems-with-movement
    I tried what he did and changed the steps per mm on one axis and my problem went away. That was after taking every thing a part and redoing it. The rails on the bearings are parallel within .001" end to end. The X is 90 degrees to the Y, the belts are even and the movements are correct. So I changed M92 X320 Y320 , trying different setting and with M92 X320 Y319, the movement of the axis are correct, no more Y movement when moving just the X and vice versa. So barring a difference in a pulley, could the board have a timing issue like the guy in the link posted as DC42 stated? Help I am just trying to get this printer up and running


Looks like your connection to Duet3D was lost, please wait while we try to reconnect.