Bltouch goes down fast



  • I have a problem, when I do homing in Z or a G29 my bed goes up and it hits the probe correctly, but when I lower my bltouch bed it hits the bed again when it goes down, there is some way so that the pin does not go down so fast and Do not hit my hot bed 2 times?

    ; Drives
    M569 P0 S0 ; Drive 0 goes forwards
    M569 P1 S0 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes backwards
    M569 P3 S0 ; Drive 3 goes backwards
    M584 X0 Y1 Z2:3 E4 ; Apply custom drive mapping
    M350 X16 Y16 Z16 E16 I1 ; XYZ and E0 microstepping
    M92 X100 Y100 Z400 E420 ; Set steps per mm
    M566 X900 Y900 Z12 E120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000 Y6000 Z160 E1200 ; Set maximum speeds (mm/min)
    M201 X500 Y20 Z250 E250 ; Set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X300 Y260 Z450 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y2 S0 ; X home to min. Y and Z home to max. Normally Closed limit switches.
    M574 Z2 S2 ; Define Z to use Probe. Home to Min

    ; Z-Probe
    M558 P5 H5 F600 T4000 X0 Y0 Z2 ; Set Z probe type/mode 5. H=Dive Height. F=Speed the bed moves
    G31 P25 X-24 Y35 Z1.52 ; Z probe trigger value, offset in relation to nozzle. And trigger height adjustment
    M557 X15:280 Y15:245 S30 ; Define mesh grid
    M375



  • M558 P5 H5 F600 T4000 X0 Y0 Z2 ; Set Z probe type/mode 5. H=Dive Height. F=Speed the bed moves

    F600 is probably your culprit. That is very fast probing speed. I would stay around F100 to F200 max.



  • You can also use P9 instead of P5 in the same command if you are using the latest firmware revision (1.21 and later).

    https://duet3d.dozuki.com/Wiki/Connecting_a_Z_probe



  • @shadowx said in Bltouch goes down fast:

    M558 P5 H5 F600

    I just tried to get down to F100 and F200 but it keeps hitting on the bed when it goes down, I'll have to adjust the speed of raising and lowering the bed on M203 X6000 Y6000 Z160 E1200; Set maximum speeds (mm / min) ???



  • @ivang said in Bltouch goes down fast:

    @shadowx said in Bltouch goes down fast:

    M558 P5 H5 F600

    I just tried to get down to F100 and F200 but it keeps hitting on the bed when it goes down, I'll have to adjust the speed of raising and lowering the bed on M203 X6000 Y6000 Z160 E1200; Set maximum speeds (mm / min) ???

    The maximum speed in M203 is just that - the maximum speed that axes are allowed to travel. So although you had been using F600 in M558, this should have been limited to 160 by the M203 command (unless the firmware does something weird during homing moves). Therefore, probing at F600 or F200 will be done at 160, only F100 will be slower. It sounds like the issue is something other than probing speed but I don't know anything about the BL touch so can't advise further.


  • administrators

    If the problem is that the pin is dropping too fast after the probe triggers, either increase the travel speed (T parameter in M558), or change to P9 in the M558 command (which needs firmware 1.21 to work).



  • @dc42 said in Bltouch goes down fast:

    If the problem is that the pin is dropping too fast after the probe triggers, either increase the travel speed (T parameter in M558), or change to P9 in the M558 command (which needs firmware 1.21 to work).

    Thank you try it, I have another problem that I just saw, when the XY axes move the 3 axes Z also turn very very slowly, because can this be ??


  • administrators

    @ivang said in Bltouch goes down fast:

    @dc42 said in Bltouch goes down fast:

    If the problem is that the pin is dropping too fast after the probe triggers, either increase the travel speed (T parameter in M558), or change to P9 in the M558 command (which needs firmware 1.21 to work).

    Thank you try it, I have another problem that I just saw, when the XY axes move the 3 axes Z also turn very very slowly, because can this be ??

    That's normal if you have bed compensation enabled.



  • @dc42 said in Bltouch goes down fast:

    @ivang said in Bltouch goes down fast:

    @dc42 said in Bltouch goes down fast:

    If the problem is that the pin is dropping too fast after the probe triggers, either increase the travel speed (T parameter in M558), or change to P9 in the M558 command (which needs firmware 1.21 to work).

    Thank you try it, I have another problem that I just saw, when the XY axes move the 3 axes Z also turn very very slowly, because can this be ??

    That's normal if you have bed compensation enabled.

    I just want to use Bltouch to create the mesh at the time of printing, the strange thing is that if I move with the X axis 100mm the z axes also start moving, as I can disable so that the Z axes do not move when I move them. X and Y axes


  • administrators

    @ivang, perhaps you are loading a mesh using G29 S1? If you clear bed compensation by sending G29 S2 then the Z axis should not move when you move X or Y.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.