Configuration Z-Probe



  • Hi,

    I post this here, because I guess it will be a configuration problem. Something that will have been overlooked.

    I own a Tevo Little Monster, which comes from "factory" with a BlTouch sensor, like Zprobe. During the transformation to Duet, I change it to a Mini Ir (Escher), and I have to say at this point, thanks to the forum and David I made the two sensors work.

    Background

    About a month ago, the sensor that had installed, Mini IR, started to work wrongly, producing a Headcrash. I commented my problems to Escher, and soon they sent me a new sensor, meanwhile, mount the original BlTouch, which is the one I have mounted at the moment

    Issue

    The problem is that, at the moment, after some changes in the Firmware, neither of the two Zprobe works for me .... The two present a similar problem, it seems that they are going, but when I try to calibrate the printer they do not work, I have tried several things, and here I pose the problem in case someone can help me.
    I summarize what happens to me with each of the Zprobes:

    MINI IR SENSOR:

    To install it I follow the instructions on the Escher website, which I followed the other time when the sensor was working.
    When I turn on the printer the sensor "blinks" as it should.
    If I bring an object closer to it, the values ​​in DWI vary according to the plan ... if the object is at a distance of about 10 mm, mark on 475 (approx), and if I hit it completely it marks 1000.
    The PROBLEM, that, if I give it to calibrate, the printer, a delta, even if I put an object under the sensor, and detect it .... DO NOT STOP, result, if I do not turn off the printer, HEADCRASH.

    BlTouch

    Something similar, the installation is somewhat more laborious, as well as the configuration, I follow Betrue's guide, the one I followed the other time, when I got it to work.
    When I turn on the printer, the sensor does the Initial Test, it goes up, down, up, down.
    The macros that I have created to display it, pick it up, reset it and test it, they work ... I have them copied in the SYS and MACRO folder, and the names are checked ...
    But again, the PROBLEM, that when I give it to CALIBRATE, and I put an object that activates the BlTouch, this does not stop the movement of the printer.
    I have to say, that the sensor does not deploy automatically, if it is deployed well, but if not, it remains collected, and it seems to me that it was deployed before, HEADCRASH.

    As you can see the problem is similar, it seems that the sensors work, but when I try to CALIBRATE the printer, they do not do it correctly. This makes me think that something I am missing in your configuration.

    Any ideas? What can I try?

    Thanks in advance



  • Post your homeall.g and config.g



  • homeall.g -->(in my case) homedelta.g

    ; homedelta.g
    ; called to home all towers on a delta printer
    ;
    ; generated by RepRapFirmware Configuration Tool on Sun Jan 21 2018 07:57:47 GMT+0100 (Hora estándar romance)

    G91 ; relative positioning
    G1 S1 X530 Y530 Z530 F1200 ; move all towers to the high end stopping at the endstops (first pass)
    G1 X-5 Y-5 Z-5 F1200 S2 ; go down a few mm
    G1 S1 X10 Y10 Z10 F360 ; move all towers up once more (second pass)
    G1 Z-5 F4800 ; move down a few mm so that the nozzle can be centred
    G90 ; absolute positioning
    G1 X0 Y0 F4800 ; move X+Y to the centre
    G29 S1 ; Usar el heighmap generado por la compensacion automatica



  • config.g

    ; Configuration file for Duet WiFi (firmware version 1.20 or newer)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Sun Jan 21 2018 07:57:47 GMT+0100 (Hora estándar romance)

    ; General preferences
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves
    M555 P2 ; Set firmware compatibility to look like Marlin
    ; Automatic saving after power loss is not enabled

    ;*** The homed height is deliberately set too high in the following - you will adjust it during calibration.
    M665 R157 L397.1073 B175 H518.3 ;M665 R160 L360.25 B160 H518.34 Set delta radius, diagonal rod length, printable radius and homed height
    M666 X0 Y0 Z0 ; Put your endstop adjustments here, or let auto calibration find them
    M208 Z0 S1 ; Set minimum Z

    ; Endstops
    M574 X2 Y2 Z2 S1 ; Set active high endstops
    M557 R130 S20 ; Define mesh grid

    ;Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S0 ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolatio
    M92 X80 Y80 Z80 E2613 ; Set steps per mm
    M566 X600 Y600 Z600 E40 ; Set maximum instantaneous speed changes (mm/min)
    M203 X12000 Y12000 Z12000 E3000 ; Set maximum speeds (mm/min)
    M201 X1000 Y1000 Z1000 E120 ; Set accelerations (mm/s^2)
    M906 X1800 Y1800 Z1800 E999 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Heaters
    M143 S298 ; Set maximum heater temperature to 285C
    M301 H0 S1.00 P10 I0.1 D200 T0.4 W180 B30 ; Use PID on bed heater (may require further tuning)
    M305 P0 T100000 B4607 C8.950070e-8 R4700 ; Set thermistor + ADC parameters for heater 0
    M305 P1 T100000 B4138 C0 R4700;M305 P1 T100000 B4725 C7.06e-8 R4700 xx Set thermistor + ADC parameters for heat
    M305 P2 T100000 B4138 C0 R4700;M305 P2 T100000 B4725 C7.06e-8 R4700 xx Set thermistor + ADC parameters for heater 1

    ; Tools
    M563 P0 D0 H2 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Network
    M550 Duet3D ; Set machine name
    M587 S"DIR869L2" P"A1B2C3D4" I192.168.1.50; Configure access point. M587 S"NOMBRE RED" P"PASSWORD" I"ip"
    M586 P0 S1 ; Enable HTTP
    M586 P1 S1 ; Enable FTP
    M586 P2 S1 ; Enable Telnet
    M552 S1

    ; Fans
    M106 P2 S1 I0 F500 H2 T70 ; Por tempertura
    M106 P1 H-1 ; Ventilador controlado por gcode
    M106 P0 H-1 ; Ventilador controlado por gcode

    ; Escher Ir Differential sensor
    M558 P1 H10 F120 T6000 ; Set Z probe type to smart, dive height, and the probe + travel speeds
    G31 P500 X0 Y0 Z1.250 ; <------------------------------------------Set Z probe trigger value, offset and trigger height

    ; Miscellaneous
    M501 ; Load saved parameters from non-volatile memory


  • administrators

    Do you have the homed height (H parameter in M665) set too high? If so then the travel move to the first probe point may crash into the bed before the probing move starts. You can increase the dive height (H parameter in M558) temporarily to avoid this, until you have established a more accurate value for the homed height.



  • The M parameter in M665, there isn't the height of the printer volume?

    If is this height, the M value its Ok, the printer its tall. I have obtain this value with DWC, homing the printer, and after moving down the head until reach the bed....

    More on this... This value its unchanged since months... When the printer work well



  • I can find the gcode... but i haved a idea...

    CHECK IF Z-PROBE WORKS

    How?

    Moving with relative position head, and check endstops....

    This can be used?

    Macro for check Z-Probe

    1 G91
    2 G1 X-50 Y-50 Z-50 F100 S1

    i am not sure, how the printer its a Delta if the 2 line is: G1 Z-50 F1OO S1, only moves one Stepper...

    And if this is correct, Zprobe DON'T stops the movement, in DWC can be read in Z-PROBE field, as IR PROBE has detected and obstacle.... but the movement DON'T STOPS...

    In a Delta, the flag S1, in the Gcode (G1), Stops the movement if endstops is triggered??? Not sure..

    EDIT

    I have find in: [http://reprap.org/wiki/G-code/es#G0_.26_G1:_Move]

    1Some firmwares allow for the RepRap to enable or disable the "sensing" of endstops during a move. Please check with whatever firmware you are using to see if they support the S variable in this way, as damage may occur if you assume incorrectly. In Duet-dc42 firmware, using the S1 or S2 parameter on a delta printer causes the XYZ parameters to refer to the individual tower motor positions instead of the head position, and to enable endstop detection as well if the parameter is S1

    There is some flag in Duet... for Sensing endstops with G1 movements???



  • I want to say I had to add something to my homeall.g in order for the z probe to work. Before I added it the z probe would show its working but during homing it wouldn’t actually stop z movement.

    I don’t have a delta but I’m just guessing you need to add it also. When i get off work I can look at my homeall.g to see what I added.


  • administrators

    @peirof said in Configuration Z-Probe:

    I can find the gcode... but i haved a idea...

    CHECK IF Z-PROBE WORKS

    How?

    See https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe.



  • @stealthy_tt Thanks



  • @dc42

    Think... that this can't use it....

    i'd like check if Z-Probe stops the movements, with calibrate...no stops... but i wat check if, with normal movements, G1, the zprobe stops the head movement. I have cheked, that Z-Probe(Mini Ir) is reconiced by Duet, when i close some object to Mini IR, in DWC, can see how the field Zprobe raises until 46x... but.... when i calibrate the printer... and trigger Zprobe, dont stops the movement....

    For this .... i want check, with G1 flag, in Zprobe is well reconiced...

    Its supposed, with cartesian printer type, if gcode, G1 Z-200 S1, move the head 200 mm downwards, if Zprobe its triggered, the movement must stop. No? but with a Delta printer, this flag S1 don't work.... There is similar flag for a Delta?


  • administrators

    You are confusing an endstop switch with a Z probe. G1 S1 commands are for use with endstop switches, not with a Z probe.



  • @dc42

    And iirc s2 is for z probe right? I’m not home to check my config for it but that’s what I believe i set for mine.


  • administrators

    To use a Z probe for Z homing, use a G30 command, not a G1 S2 command. See the first item in https://duet3d.dozuki.com/Wiki/FAQ.



  • @dc42

    You are correct but I’m sure you already knew that haha. I have a g30 command in homeall.g



  • Hi,

    after some test... i have cheked when i send G30 S-1, and put an obstacle in ZProbe.... *** STOPS THE HEAD MOVEMENT***... this discards a fault to Zprobe, and bad conection....

    IF:

    • When printer power on, ZProbe blinks correct.
    • When by console send G30 S-1, printer head stops with a obstacle
    • When try calibrate, Zprobe DON'T stops printer head movement...

    Why?

    A- Something is wrong in bed.g?
    B- Something is wrong in config.g?
    C- Le falla "lajuntadelatrocola"

    What can i do?

    Latest test are made with Mini IR

    Copy bed.g i am using

    *; bed.g
    ; called to perform automatic delta calibration via G32

    M561 ; clear any bed transform, otherwise homing may be at the wrong height
    G28 ; home the printer

    ; bed.g file for RepRapFirmware, generated by Escher3D calculator
    ; 16 points, 6 factors, probing radius: 140, probe offset (0, 0)
    ; bed.g file for RepRapFirmware, generated by Escher3D calculator
    ; 16 points, 6 factors, probing radius: 125, probe offset (0, 0)

    G30 P0 X-67,5 Y117 Z-9999 H0
    G30 P1 X67,5 Y117 Z-9999 H0
    G30 P2 X135 Y0 Z-9999 H0
    G30 P3 X67,5 Y-117 Z-9999 H0
    G30 P4 X-67,5 Y-117 Z-9999 H0
    G30 P5 X-135 Y0 Z-9999 H0
    G30 P6 X0 Y-90 Z-9999 H0
    G30 P7 X-77,95 Y-45 Z-9999 H0
    G30 P8 X-77,95 Y45 Z-9999 H0
    G30 P9 X0 Y90 Z-9999 H0
    G30 P10 X77,95 Y45 Z-9999 H0
    G30 P11 X77,75 Y-45 Z-9999 H0
    G30 P12 X0 Y45 Z-9999 H0
    G30 P13 X22,5 Y0 Z-9999 H0
    G30 P14 X-22,5 Y0 Z-9999 H0
    G30 P15 X0 Y0 Z-9999 S6*



  • @peirof said in Configuration Z-Probe:

    Hi,

    after some test... i have cheked when i send G30 S-1, and put an obstacle in ZProbe.... *** STOPS THE HEAD MOVEMENT***... this discards a fault to Zprobe, and bad conection....

    IF:

    • When printer power on, ZProbe blinks correct.
    • When by console send G30 S-1, printer head stops with a obstacle
    • When try calibrate, Zprobe DON'T stops printer head movement...

    Why?

    A- Something is wrong in bed.g?
    B- Something is wrong in config.g?
    C- Le falla "lajuntadelatrocola"

    What can i do?

    Latest test are made with Mini IR

    Copy bed.g i am using

    *; bed.g
    ; called to perform automatic delta calibration via G32

    M561 ; clear any bed transform, otherwise homing may be at the wrong height
    G28 ; home the printer

    ; bed.g file for RepRapFirmware, generated by Escher3D calculator
    ; 16 points, 6 factors, probing radius: 140, probe offset (0, 0)
    ; bed.g file for RepRapFirmware, generated by Escher3D calculator
    ; 16 points, 6 factors, probing radius: 125, probe offset (0, 0)

    G30 P0 X-67,5 Y117 Z-9999 H0
    G30 P1 X67,5 Y117 Z-9999 H0
    G30 P2 X135 Y0 Z-9999 H0
    G30 P3 X67,5 Y-117 Z-9999 H0
    G30 P4 X-67,5 Y-117 Z-9999 H0
    G30 P5 X-135 Y0 Z-9999 H0
    G30 P6 X0 Y-90 Z-9999 H0
    G30 P7 X-77,95 Y-45 Z-9999 H0
    G30 P8 X-77,95 Y45 Z-9999 H0
    G30 P9 X0 Y90 Z-9999 H0
    G30 P10 X77,95 Y45 Z-9999 H0
    G30 P11 X77,75 Y-45 Z-9999 H0
    G30 P12 X0 Y45 Z-9999 H0
    G30 P13 X22,5 Y0 Z-9999 H0
    G30 P14 X-22,5 Y0 Z-9999 H0
    G30 P15 X0 Y0 Z-9999 S6*

    Did you also place the code for z probe in homedelta?



  • @peirof why is there a * on the s6 param on the last line ?



  • Hi,

    In homedelta.g... it's mecessary place code? Homing a Delta, there is with endstops, No?...

    Delta dont use Zprobe for Homing. No?



  • @peirof No delta doesn't use the Z Probe for homing.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.