Seems to be doing something : ))



  • @3mm can you post your bed.g file and the M665 and M666 lines from your config.g and also what is the length of your hand rods (as marked on the stickers on them)



  • @Dougal1957

    Hi, thanks.

    Delta config:
    Originally AnyPubic kossel linear plus, but virtually everything has been replaced, except steppers, belt, top-of-tower end-stop-sw's & 2020 profiles.

    DUET3D-EtherNet
    Smart-Effector + authentic E3D V6 HotEnd
    Metal corners,
    360W switching power-supply
    SRD-100, 100Vdc @100A SSR for hot bed switching.
    RepRapFirmware - Duet 2-E v1.21

    I scotch taped the labels so they can't fall-off:
    6 rods, grouped by pairs:

    288.13
    288.12

    288.12
    288.12

    288.11
    288.11

    config.g:
    M665 R139.7 L288.12 B111.76 H215.9 ; Set delta radius, diagonal rod length, printable radius & homed height
    M666 X0 Y0 Z0 ; Put your endstop adjustments here, or let auto calibration find them

    Thanks

    3mm

    ![0_1526171708494_delta_DUET-E & PanelDUE.jpg](Uploading 100%)



  • @3mm can you post your bed.g as well please I think I know what may be happening but without that file I can't confirm



  • @dougal1957

    Hi,

    Perhaps I should also mention that when I run "Mesh Grid Compensation" web-control 'preset', that while it does generate a bed map, the graphic display depicts only the axis and grid overlay with no measurements??

    bed.g (text information removed):

    M561 ; clear any bed transform

    ; Probe the bed at 6 peripheral and 3 halfway points, and perform 3-factor auto compensation.

    G30 P0 X0 Y109.9 H0 Z-99999
    G30 P1 X95.18 Y54.95 H0 Z-99999
    G30 P2 X95.18 Y-54.95 H0 Z-99999
    G30 P3 X0 Y-109.9 H0 Z-99999
    G30 P4 X-95.18 Y-54.95 H0 Z-99999
    G30 P5 X-95.18 Y54.95 H0 Z-99999
    G30 P6 X0 Y54.9 H0 Z-99999
    G30 P7 X47.54 Y-27.45 H0 Z-99999
    G30 P8 X-47.54 Y-27.45 H0 Z-99999
    G30 P9 X0 Y0 H0 Z-99999 S3

    thanks in advance

    3mm



  • yep change the S3 on the last G30 line to be either S6 or S8 and that should improve things no end


  • administrators

    @3mm said in Seems to be doing something : )):

    Perhaps I should also mention that when I run "Mesh Grid Compensation" web-control 'preset', that while it does generate a bed map, the graphic display depicts only the axis and grid overlay with no measurements??

    Hover the mouse cursor over the grid points to see the measurements.



  • @dc42

    0_1526458464062_Mesh Grid Display.jpg

    Hovering over the grid does nothing.

    3mm



  • @dougal1957

    The numbers changed! Was .109/.107 and now is consistently reading things like:
    "Calibrated 8 factors using 17 points, deviation before 0.039 after 0.031"

    I presume that these are better numbers than before.

    There seems to have been some type of mismatch somewhere, I think it was between the config.g file and the config.json file, as I was seeing via the console, an error msg, when ever I did a calibration, being a G32 'bad command' error. I reran the RepRap wizard and the error msg disapeared. So what does the config.json file do that the config.g file doesn't? Which one is read by the firmware?

    Thanks for your help.

    3mm


  • administrators

    @3mm said in Seems to be doing something : )):

    Hovering over the grid does nothing.

    3mm

    In that image it isn't displaying a height map at all. Did that auto calibration fail?



  • @dc42 said in Seems to be doing something : )):

    @3mm said in Seems to be doing something : )):

    Hovering over the grid does nothing.

    3mm

    In that image it isn't displaying a height map at all. Did that auto calibration fail?

    @dc42

    No, that's what I've been saying. I've not seen anything on that grid in all of the runs that I've done. Its seems like its working ok?? and I'm not seeing any error messages anywhere. Both 'AutoCalibration' and 'Mesh Grid Compensation' macros run the entire process. It creates a height-map .csv file, but nothing is displayed? And hovering over it does nothing, and before I mentioned this matter...well...I tried zooming in, and out, rotating, panning. The grid is empty.

    Here's the content of the most recent HeightMap.csv file that I generated today.

    HeightMap.csv:
    RepRapFirmware height map file v2, mean error -0.001, deviation 0.044
    xmin,xmax,ymin,ymax,radius,xspacing,yspacing,xnum,ynum
    -100.00,100.10,-100.00,100.10,111.80,20.00,20.00,11,11
    0, 0, 0, -0.057, -0.049, 0.052, 0.040, 0.104, 0, 0, 0
    0, 0, 0.017, -0.001, -0.008, 0.027, 0.007, 0.023, 0.027, 0, 0
    0, 0.053, -0.019, -0.011, 0.020, 0.063, 0.026, 0.067, 0.075, 0.098, 0
    0.085, 0.064, 0.037, 0.018, 0.013, 0.017, 0.019, 0.003, -0.096, -0.100, 0.012
    0.051, 0.040, 0.012, -0.002, 0.002, -0.001, -0.010, 0.001, -0.013, 0.003, -0.006
    0.066, 0.040, 0.017, -0.010, -0.034, -0.050, -0.049, -0.061, -0.058, -0.071, -0.073
    0.014, 0.003, 0.003, -0.001, -0.034, 0.015, -0.048, -0.060, -0.043, -0.050, -0.068
    -0.013, 0.010, 0.008, 0.041, 0.014, -0.063, -0.074, -0.071, -0.060, 0.025, -0.046
    0, 0.041, 0.048, 0.050, -0.026, -0.047, 0.031, 0.032, 0.039, 0.051, 0
    0, 0, -0.036, 0.020, -0.055, -0.060, 0.004, 0.004, -0.009, 0, 0
    0, 0, 0, -0.032, 0.023, -0.037, -0.044, -0.023, 0, 0, 0


    On an unrelated subject...I find it peculiar that the web 'G-Console' displays different messages than does the PanelDUE, in fact, there is an obvious disparity between the two readouts, eg, the web 'G-Console' and the PanelDUE 'Console'. It would be convenient to watch the PanelDUE 'Console' display for messages while the web-interface remains in Machine-Control or another mode.

    Thanks...3mm


  • administrators

    What browser are you using? Also, please confirm what firmware and DWC versions you are using.



  • @dc42

    Hi...

    Web-Browser: Mozilla - FireFox 'Quantum' v57.0 (64-bit)

    PanelDUE: v1.20(15b1)
    DUET-E HW v1.02
    Smart-Effector v?

    RepRap FW for Duet 2 WiFi/Ethernet
    HW Electronics: Duet Ethernet 1.02 or later
    FW Ver: 1.21 (2018-03-21)
    Web Interface Ver: 1.15a

    thanks...3mm
    ps...screen grab of 'Machine-Control' page:

    0_1526593696001_Web Interface V1.15a.jpg


  • administrators

    You are running a very old version of DWC. Please upgrade it to 1.21.



  • @dc42

    I'm confused, I thought I had the latest Firmware...which of these two firmwares are you refering?

    FW Ver: 1.21 (2018-03-21)
    Web Interface Ver: 1.15a

    The web-interface, presume is an internal module of the DUET-E firmware v1.21, do I need to manually update that firmware? eg, 1.15a?

    thanks...3mm



  • @dc42

    Also, which specific (DUET-E v1.02 HW, SAM4E8E) firmware do you recommend? I'd appreciate the URL location, so as not to make any mistakes.

    thanks...3mm



  • This is the link to the file you need to Download then drag the .zip file (do not unzip it) to the Upload button on the settings page of the web interface

    DWC V 1.21



  • @dougal1957 & @dc42

    Thanks guys, that fixed the graph anomally!!

    What about the latest FW releases? I notice some releases at URL:
    https://github.com/dc42/RepRapFirmware/tags
    depict a 'verified' tag, while other's don't? What's the difference, are the un-'verified' beta or not-necessarially-stable test releases?

    Thanks in advance

    3mm


  • administrators

    @3mm said in Seems to be doing something : )):

    I notice some releases at URL:
    https://github.com/dc42/RepRapFirmware/tags
    depict a 'verified' tag, while other's don't? What's the difference, are the un-'verified' beta or not-necessarially-stable test releases?

    That is correct.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.