possible web control firmware glitch (1.21)

  • During a print, if I access the webUI by opening a tab and going to that address, if there isn't already a tab for this open, the duet loads the page, stops the print, homes the hotend, and attempts to continue printing, crashing into the print already on the bed. The only way I have found around this is by:
    -keep a tab open while printing
    -do not access the webUI until the print completes
    -use firefox. I'm accessing this on safari (I know, I know. I just like it.)

  • I access my printer during prints all the time using Chrome. Never had a crash as a result of it. Maybe it is a Safari thing?

  • It might be. I just tried accessing it on my iphone to check the status of a print in the next room. It loaded the UI, stopped the print, and the printer had to be power cycled to start again.

  • I use Safari and Chrome both on a regular basis, no issues with prints in progress. I've also done some development of an alternate "multi-printer" web interface, and during this development, fetched HTTP responses from the printer with 'curl' (command line). Also no issues.

    Your symptom is VERY strange...

    You can turn on logging, post the results here, and see if David sees anything.

    Or... you might try just a full re-load of all the firmware and web stuff, just to get rid of the problem. Maybe.

  • It's done this every firmware version, each reload, but you gave me an idea. I loaded up the current RC firmware. So far, so good. I still have to power cycle the printer if it sits unused for a while to regain access to the webUI, but so far, it looks like the new firmware might have solved it.

    It's still too soon to say, but it looks good so far.

Log in to reply