Strange Ringing artifacts on coreXY



  • Hi there!
    I will try to describe the problem as short as possible for you:
    I have a really strange problem and have almost no idea any more how to solve it... Maybe you can help me?
    On my coreXY (Hypercube Evolution) I have strange ringing on x and y. The distance is ~2 mm symmetric on all sides (x, y, 45° (so only 1 motor is rotating) and in vase mode (to eliminate the infill as cause))

    Here some example pictures of prints:
    3_1526382038281_20180515_125756 (Large).jpg 2_1526382038281_20180506_230208 (Large).jpg 1_1526382038281_20180502_120745 (Large).jpg 0_1526382038280_20180501_235232 (Large).jpg

    I now mounted a gauge and verified an oscillating vibration always on the axis that isn't supposed to do so (red is always the movement that was performed and the gauge measured the movement on the other axis):
    X-axis movement:
    0_1526382306433_20180515_124913 (Large).jpg
    http://www.visser.at/x-movement.mp4

    Y-axis movement:
    0_1526382395221_20180515_125047 (Large).jpg
    http://www.visser.at/y-movement.mp4

    I now tested almost anything except of changing the Duet Board. The problem was always the same and didn't change at all.
    Things I tested so far:

    • Changed the belts:
      -> Steel reinforced
      -> Kevlar reinforced
      -> glass fiber reinforced
      -> GT2 Belt with only 5 mm width (to prevent the belt of "rippling" against the frame of the Idler)
      -> changed the tension of the belts (if they are very loose, the ringing increases a little bit)

    • Changed all pulleys and Idler 3 times

    • Changed the PSU and installed a second PSU only for the heated bed (2x Meanwell HRP-600-24 PSU)

    • Switched off all fans

    • Changed from PID-Tuning to Bang-Bang

    • Changed the extruder from a Nimble to a Bowden-Extruder I had lying around

    • tested different stepper motors (mounted the ones I still have from my Anet A8) changed the stepping and the current

    • printed in vase mode "cubes" (200 x 5 x 10 mm) and placed them in a distance of 5 cm all over the bed to test if the ringing increases somewhere. (also x, y and 45° rotated so only one motor spins) (It only increased a little bit as the x-axis was right in the middle of the y-rods. But I think this is just because the y-rods are mounted to the frame at the both ends and so the resonance increases in the middle of the rods as this is the biggest distance to the mounting)

    I think I also forgot some tests I did as well 😄

    This is my config.g file:
    0_1526383311581_config.g

    It seems as if the motors are driven in a sine wave and that causes the movement?

    Would be really happy, if you would have any further idea...?

    Greetings from germany

    kuhni



  • Are you using toothed pulleys where they are need?



  • yes. toothed on the belt side, flat on the "flat side" 🙂



  • @kuhnikuehnast

    I also own a Hypercube Evolution and i never had this problem.

    Biggest difference to mine is that i'm using microstepping.
    Maybe you can give it a try.

    You should also check if your pulleys on the motors are wobbling a little bit.

    Regards,
    Martin



  • We (Jan, makerdise managing director) also did some analyzes with Denis, however there seems to be no mechanical influence as we already did test the most common/known cases.

    Especially we don't believe that the pulleys do influence the behaviour as they were changed, optimized by hand etc. without any visible changes in the pattern. Denis did measure on multiple points, the rods seems to be stable enough to handle the belt length. In conclusion, the stuttering can be caused by soft- or hardware issues related to the activation of the related drivers.



  • @mloidl - we already did try quarter steps, anyway thanks a lot for your input...



  • @makerdise

    Just saw it, was confused because of the 80Steps/mm. So you're using 1,8°/step motors. Thats different to mine.



  • Yes, 1.8°, I think from OMC @kuhnikuehnast please post a link...







  • 0_1526389989466_2ad6aa29-8448-49e8-80a1-5cef0dfbc985-image.png

    So seems that I could go for a 350 mm/s speed until the torque starts to drop with the stepper motors I own... The videos linked in the first post are performed at a speed of 6000 mm/min (100 mm/s)





  • Hi,

    try:

    M201 X1000 Y1000 Z250 E600
    M203 X12000 Y12000 Z1800 E3600
    M204 P1500 T2500

    and try to print a test cube @ 30mm/s max. 40mm/s, show some pictures.

    Greetings



  • Started printing. But The M204 seems to be very fast for my Z-axis? As I own a Nimble (30:1 ratio) i left the M201 at 120 as recommended by zesty.



  • U mean M203? there is no Z parameter for M204... The Z parameter is from your config u posted before 🙂 I would set it to Z680 or 720 depends on your Z axis setup, weight of the heatbed ect... Using pressure advance u schould set your jerk min. to 600 so mayby try to turn off pressure advance too.



  • With M204 you set the travel acceleration. Isn't this also then used for the z-axis?
    I also tried prints with Pressure advanced off before...
    This is the "cube" I printed in vase mode at 40 mm/s:

    0_1526394426565_eb178a7a-0c6d-4b83-9507-3c4911207209-image.png

    Results are almost the same:
    0_1526394622484_20180515_162534 (Large).jpg :



  • Do you have quality 3M belts or china? How about your hotend mount is it stable or wobbly.



  • @neoxio said in Strange Ringing artifacts on coreXY:

    Do you have quality 3M belts or china? How about your hotend mount is it stable or wobbly.

    Check his OP - seems he's tried them.


  • Moderator

    I had very similar ridges on my corexy and the solution for me was to replace the toothed idlers with smooth bearings and do a belt flip so the smooth side rode on the bearings. It seemed that the diameter of the idler was too small or the profile of tooth and belt mismatched enough that it wasn't meshing smoothly.

    Also, I recall a thread from not long ago where using very low steps per mm was causing motor movement to be less smooth.

    Just some thoughts

    alt text

    Here's an example of what I had.



  • Could be an extrusion problem.
    Add some pictures of the complete printer so we can have a better idea...



  • @whosrdaddy

    I second the vote for extrusion problem. Try changing the extruder motor current up or down 20% and see if the pattern changes.

    I've seen this in direct extruders with no gear reduction and relatively large filament drive gears.

    What kind of extruder is on the machine?



  • @whosrdaddy @mrehorstdmd @kuhnikuehnast did test a bowden setup as an alternative, while currently running a zesty nimble (which sounds like a hot candidate having a non concentric part or imprecise worm drive etc.)... This was also one of my first ideas (inconsistent extrusion). However, the pattern remains nearly the same on both setups. The distance between the "waves" is very consistent so this could only be caused by a part moving around in circles with a non-concentric bore or wrong clamping (in theory).

    Damn.

    @mrehorstdmd - are you the guy with the belt driven z-axis printer, do I remember right? If so, respect.



  • as @makerdise already told: at first, I was "hoping" to have an extrusion problem... But as I tried 2 different types of extruders and also with 2 different stepper motors, the problem persisted. And if you watch the video, you can also se the "sine wave like" spinning on the axis. These videos were made by just "printing" a g-code like:

    G21
    G91
    M564 S0 H0
    G0 X300 F6000
    G0 X-300 F6000
    G0 X300 F6000
    G0 X-300 F6000
    ...

    So all the possible interfering factors were eliminated.



  • Does it get worst when u print @ 0.1mm layer hight? (does the "ringing" changes, increase?)


  • administrators

    @kuhnikuehnast, @makerdise It looks like you have carried out a detailed investigation so far. To try and isolate the problem to a subsytem (electronics/mechanical) can you try changing:

    1. Movement axis interpolation this line in config.g "M350 X16 Y16 Z16 E16 I1 " change so that X and Y are not using interpolation:
      M350 Z16 E16 I1
      M350 X16 Y16 I0

    2. As a seperate test, try different microstepping for movement axis:
      "M350 X64 Y64 Z16 E16 I1 "
      You may need to reduce the print speed. Also make sure you follow the documentation about how the microstepping and steps/mm interact. https://duet3d.dozuki.com/Wiki/Gcode#Section_M350_Set_microstepping_mode


Log in to reply