Cannot connect to DuetWifi



  • Hello Duet Community,

    I have got issues connecting to the DuetWifi when I get to Step 7 of "Getting Connected" (https://duet3d.dozuki.com/Guide/1.)+Getting+Connected+to+your+Duet/7). I am using a Mac and tried both the terminal and pronterface. In both cases I get the message: M587: Bad or missing parameter.

    Primarily, I also got this message when supplying the M115: Executing config.g...Error: Bad command: FOR TESTING ONLY! USE https://configurator.reprapfirmware.org/ to generate configuration files for your printer!

    I would therefore greatly appreciate your help with the former connection issue and any clues on how to go about the latter message.

    Kind regards,
    János


  • administrators

    So the message "FOR TESTING ONLY! USE https://configurator.reprapfirmware.org/ to generate configuration files for your printer!" is exactly that. The configuration file shipped on the board is for testing use only. There are so many different printers and configurations that the duet can support that you need to give it an appropriate config for your printer.

    On the other hand you should still be able to connect to it over wifi (so you can easily upload the config files generated by the configurator).

    If you are getting "M587: Bad or missing parameter." check you are sending the correct information:
    https://duet3d.dozuki.com/Wiki/Gcode#Section_M587_Add_WiFi_host_network_to_remembered_list_or_list_remembered_networks
    I do not know how MAC terminal works but pronterface is known to be problematic as it converts everything to capitals. On windows we use YAT as it behaves properly, maybe someone with a mac can jump in and confirm what terminal program works properly for them.



  • @T3P3Tony
    Thanks for the quick reply and the information on the configuration bit.

    Unfortunately, I still cannot connect to the wifi. I have switched to windows now and I am using YAT. When I supplied the M552 command it shows: "Wifi module is idle" and "ok" is returned after supplying the ssid and password, but the subsequent command M552 S1 returns: "ok<LF>Wifi reported error: no known networks found <LF>Wifi module is idle<LF>".

    I have also created a macros with the ssid information and tried to call it with the M98 function, but the file could not be found.

    I really don't know what the problem is. @T3P3Tony do you have any suggestions? Thank you very much



  • 2 things to watch out for when connecting to Wifi;

    • The duet can connect to 2.4Ghz networks only
    • The SSID is case sensitive, make sure to use the correct casing when using M587

  • administrators

    @janosp, as @whosrdaddy has pointed out the Duet only connects to 2.4GHz networks so that might be an issue. One thing you could try to check that the wifi module is working is to set the wifi module up to act as a hotspot and connect to that wifi network as a test:
    https://duet3d.dozuki.com/Wiki/Gcode#Section_M589_Configure_access_point_parameters


Log in to reply