vibration on all motors when homing



  • I just received a Duet Wifi board and have it configured for the most part. I have a Prusa P3 Steel variant. When I have the motors and endstops connected, I get a vibration on the motor before homing. Then the home procedure happens. Both X and Y home and are able to move afterwards. When I do this with the Z motors (using Za and Zb), I get a vibration but no homing. Using this command, G1 S2 Z10 F100, the Z access moves. Taking off the Z steppers and homing X and Y, I get no vibrations. What could be the issue? It seems specifically related to the z steppers being on the board.

    Also, I thought these drivers are supposed to be quiet. When Idle, I can hear them making a noise similar to the noise I had when using DRV8825.

    One question I'l pop into here is what G command would I put in the homeall file to get the x and y axis to move to a specific location?



  • The problem you are seeing suggests that your Z motors are skipping steps (=vibrating noise).
    Try to increase the current on the Z axis, you can go up to 80% of the motor current rating (or higher but that might overheat the motors).
    What type of motors are you using and what for leadscrew are you using?

    to reply to your second question:

    G90; absolute positioning
    G1 X100Y100; move to X=100 Y=100
    


  • The motors should not be skipping steps. The were working correctly on my previous board. The were running at a total of 1.6 amps on the last board (smoothie clone). So each motor was getting .8 amps. Here, I had it set the same and upped the correct to 2 amps. No change. Remember, this is happening when homing XYZ. XY will run, but Z will not unless you specify the command as I explained.



  • Be aware that the Duet runs the motors in series, not in parallel, so they run at the current you set but at half the voltage.
    If you have high inductance motors, this might be a problem.
    You can run the Z axis from 2 different drivers (for example E1 if you are using only one extruder).
    This gives you the added bonus of 2 motor leveling, that is if you have a Z-probe.

    please read following articles:
    https://duet3d.dozuki.com/Wiki/Choosing_and_connecting_stepper_motors
    https://duet3d.dozuki.com/Wiki/Bed_levelling_using_multiple_independent_Z_motors



  • Sounds like your motor current settings are to high, I am running my P3 Steel at 800ma on all motors, using 2 drivers for the the Z axis



  • The motor currents are the exact same setup as in the smoothieboard clone I had. They are not too high. I've tried 800mA to. 1600mA with no change in behavior. The motors are rated for 2000mA.



  • So I went through my settings and found the issue. The micro step calculation for z was off on the motor. I"m doing 128 micro steps, and it should have been 32000 vs 64000 that I had set. I corrected that, and all move correctly now. I have another problem that I will have to figure out or start a new thread.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.