Z axis not stopping at Endstop



  • My z axis keeps going through the min endstop and going into the bed.
    Here is my Homez
    ; homez.g
    ; called to home the Z axis
    ;
    G91 ; relative mode
    G1 S1 Z-250 F300 ; move Z towards the switch until it triggers
    G1 Z5 F100 S2 ; move Z back 5mm
    G1 S1 Z-10 F100 ; move Z slowly towards the switch until it triggers
    G90 ; back to absolute mode
    Here is my homeall
    ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool on Thu Mar 29 2018 21:22:13 GMT-0400 (Eastern Daylight Time)
    G91 ; relative positioning
    G1 Z5 F6000 S2 ; lift Z relative to current position
    G1 S1 X-843.2 Y767 F1800 ; move quickly to X or Y endstop and stop there (first pass)
    G1 S1 X-843.2 ; home X axis
    G1 S1 Y767 ; home Y axis
    G1 X5 Y-5 F6000 ; go back a few mm
    G1 S1 X-843.2 F360 ; move slowly to X axis endstop once more (second pass)
    G1 S1 Y767 ; then move slowly to Y axis endstop
    G90 ; absolute positioning
    G91 ; relative mode
    G1 S1 Z-250 F300 ; move Z towards the switch until it triggers
    G1 Z5 F100 S2 ; move Z back 5mm
    G1 S1 Z-10 F100 ; move Z slowly towards the switch until it triggers
    G90 ; back to absolute mode
    ;G1 X15 Y15 F6000 ; go to first bed probe point and home Z
    ;G30 ; home Z by probing the bed
    ;G1 Z5 F100 S1 ; uncomment this line to lift the nozzle after homing



  • what type of end stop is it ?? a switch, piezo probe \ bltouch ? have you tried manually 'switching' the end stop ?



  • its a switch and i have tried manually pressing it when the printer was lowering while it was homing but it still didn't do anything.



  • Does the light on the Duet board light up or turn off when the switch is clicked?



  • @phaedrux it lights up



  • Is this a new setup or did it just stop working recently?

    Can you post your config.g so we can see how the endstop is configured?

    What kind of switch is it?



  • @phaedrux here are the switches Gowoops 5 PCS of Mechanical Endstop Switch with Cable for 3D Printer Makerbot Prusa Mendel RepRap CNC Arduino Mega 2560 1280.

    the setup is new and i have not printed anything yet.

    config.g:

    ; Configuration file for Duet WiFi (firmware version 1.17 to 1.19)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Thu Mar 29 2018 21:22:13 GMT-0400 (Eastern Daylight Time)
    ; Custom settings
    M584 X0 Y1:4 Z5:9:7:8 E3

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    M667 S0 ; Select CoreXY mode

    ; Network
    M550 PUnderground Printing- Jumbo ; Set machine name
    M552 S1 ; Enable network
    M587 S"KQVQM" P"SVLFBZMC3PK8893X" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S0 ; Drive 0 goes forwards
    M569 P1 S0 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S0 ; Drive 3 goes forwards
    M569 P4 S0 ; Drive 4 goes back
    M569 P5 S0
    M569 P6 S0
    M569 P7 S0
    M569 P8 S0
    M569 P9 S0
    M350 X32 Y32 Z32 E16 I1 ; Configure microstepping with interpolation
    M92 X160 Y160 Z4000 E1750 ; Set steps per mm
    M566 X900 Y900 Z12 E120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000 Y6000 Z220 E1200 ; Set maximum speeds (mm/min)
    M201 X500 Y20 Z250 E250 ; Set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X723 Y762 Z1117.6 S0 ; Set axis maxima

    ; Endstops
    M574 X2 Y1 S1 ; Set active low endstops
    M574 Z0 S1
    ; Z-Probe
    M558 P0 H5 F120 T6000 ; Disable Z probe but set dive height, probe speed and travel speed
    M557 X15:823.2 Y15:747 S20 ; Define mesh grid

    ; Heaters
    M140 H-1 ; Disable heated bed
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C



  • @puppet172 said in Z axis not stopping at Endstop:

    ; Endstops
    M574 X2 Y1 S1 ; Set active low endstops
    M574 Z0 S1

    Where you have that, try this:

    M574 X2 Y1 Z1 S0
    

    That's assuming you have the X end stop at the high end of travel and the Y and Z end stop at the low end of travel. S0 sets them to active low switches which should work with those makerbot switches.


Log in to reply