Problemas graves de temperarura en motores



  • Hola buenas
    since a week ago I have problems of overheating in my Cartesian printer with duet ethernet of my engines I have them at 800mA and before updating to 1.21 I did not have these problems as I could solve it? I want to go back to 1.21Rc3 that with this version I did not have these problems
    what would be the procedure to go from 1.21 to the previous version 1.21RC3 on my ethernet board


  • administrators

    Nobody else has reported the motor currents changing when they upgraded the firmware, so I think the problem must be in your configuration files, or perhaps your slicer is generating code that changes the motor currents (M906 or M913 commands).

    Do the motors start to get hot if you just move the axes around; or only when you do a print?

    To verify that the motor currents are set correctly, send M906 without parameters, and M913 without parameters. M906 should report that the currents are as you set them in the M906 command in config.g (800mA I presume), and M913 should report that the currents are at 100%.

    What model of stepper motor are you using?



  • @dc42
    Hi, thanks for your attention
    I have an ethernet duet in a creality CR-10 has a nema 17 and they end up heating up a lot when I make an impression until the extruder motor loses steps and stops extruating at that moment the Y and X motors along with the extruder are very very hot happens to me since I upgrade to 1.21 since before with the 1.21 RC3 had no problem
    When I send an M906 it puts me this:

    × M906

    Motor current (mA) - X: 800, Y: 800, Z: 800, E: 800: 800: 800: 800: 800: 800: 800: 800: 800, inactive factor 30%

    and M916 gives me this error:
    M916

    Error: M916: Resume prologue file 'resurrect-prologue.g' not found





  • @carlosspr
    M913

    Motor current % of normal - X:100, Y:100, Z:100, E💯100💯100💯100💯100:100



  • Hello
    I still have problems of excess temperature in the engines even Having passed the firm of the duet to the previous one that I had (1.21 RC3) that did not give me problems with the temperature of the engines I can not do any part since the extruder motor jumps and I stopped printing when I stopped printing the temperature of the engines low and stayed at room temperature only heated when it is printing and I do not know why I need help please this problem I did not expect it and I'm desperate I do not know what to do.
    Now I have the amperage of the 800mA motors as I had them since I mounted the Duet3d board but I have also tried to lower mA and keep doing it until the engines stop working



  • M122
    === Diagnostics ===
    Used output buffers: 3 of 32 (6 max)
    === Platform ===
    RepRapFirmware for Duet 2 WiFi/Ethernet version 1.21RC3 running on Duet Ethernet 1.02 or later
    Board ID: 08DGM-95BLL-N6PSS-6J9F2-3SN6M-1JUZJ
    Static ram used: 16144
    Dynamic ram used: 100056
    Recycled dynamic ram: 2584
    Stack ram used: 1224 current, 4496 maximum
    Never used ram: 7792
    Last reset 00:07:29 ago, cause: software
    Last software reset at 2018-06-05 14:16, reason: User, spinning module GCodes, available RAM 7856 bytes (slot 3)
    Software reset code 0x0003 HFSR 0x00000000, CFSR 0x00000000, ICSR 0x0441f000, BFAR 0xe000ed38, SP 0xffffffff
    Error status: 0
    Free file entries: 10
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 0.0ms
    MCU temperature: min 37.5, current 37.6, max 39.2
    Supply voltage: min 12.2, current 12.3, max 12.4, under voltage events: 0, over voltage events: 0
    Driver 0: standstill, SG min/max not available
    Driver 1: standstill, SG min/max not available
    Driver 2: standstill, SG min/max not available
    Driver 3: standstill, SG min/max not available
    Driver 4: standstill, SG min/max not available
    Date/time: 2018-06-05 14:23:55
    Slowest main loop (seconds): 0.004703; fastest: 0.000052
    === Move ===
    MaxReps: 0, StepErrors: 0, LaErrors: 0, FreeDm: 240, MinFreeDm 240, MaxWait: 0ms, Underruns: 0, 0
    Scheduled moves: 0, completed moves: 0
    Bed compensation in use: none
    Bed probe heights: 0.000 0.000 0.000 0.000 0.000
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1
    === GCodes ===
    Segments left: 0
    Stack records: 1 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is idle in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Responder states: HTTP(1) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0) Telnet(0)
    HTTP sessions: 1 of 8
    === Network ===
    State: 5
    HTTP sessions: 1 of 8
    === Expansion ===



  • ya no se que hacer alguna ayuda por favor?
    modelo de motor nema17HS4023


  • administrators

    According to https://www.olimex.com/Products/Robot-CNC-Parts/StepperMotors/SM-17HS4023/ that motor has a rated current of 0.7A. So I suggest you reduce the current to 500mA.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.