CoreXY mirror print



  • Hello.
    I make CoreXY printer and use duet wifi
    I have now p0 s1 nad p1 s1 in setting (so X and Y go forward) and my X,Y 0,0 is in right side close to nema.
    When i print (use simplify3d) my print is mirrored on X axis - what i cant do to print it ok. I print parts so mirrored prints is no to use 😕
    p.s. when i use another setting like s0 s1 i cant home because stop ends are in wrong side of table :[


  • administrators

    It sounds like your printer has a left hand coordinate system instead of the standard right hnand coordinate system. Viewed from above, the +Y direction should be 90 degrees anticlockwise from the +X direction.



  • Yes from above +Y is 90* clockwise so what to change in setting to print correct ??
    I will need to change hardware stopends ??


  • administrators

    1. Decide which directions you want +X and +Y to be in, and where you want X=0 Y=0 to be. The usual choice for a CoreXY printer is for X0 Y0 to be front left, +X to be towards the right, and +Y towards the back.

    2. Adjust the S parameter in the M569 P0 and M569 P1 commands (assuming you are using drivers 0 and 1 for the X and Y motors) between S0 and S1 and if necessary swap the X and Y motor connectors, to get the head moving in the correct directions when you jog X and Y.

    3. Finally, adjust your M574 commands and the moves in your homing files to account for any endstops that have changed from being at the axis maximum to the axis minimum, or vice versa.



  • But i cant move without homming axis and when i do i can hit not stop end site 😕



  • @kivlow To move the axes without homing you can type M564 H0 command 🙂



  • ok i change P0 and P1 between S0 S1 (all possibility + motor swap ) but i cant set to move X+ to right and Y+ to back :[.
    Is a command that swap not motor direction but axis (i can set X+ to right but Y+ to forward) ??



  • If only Y is moving in the wrong direction, you should be able to invert the Y direction of your coreXY by swapping the motor connectors.



  • Ok i swap cable and works fine - i only move Y stopend to front.
    Now i fight with blower on print - now its to high and cool hotend and duet stop print and send T0 fault 😕
    So i need to redesigne my fun duct.
    And i need to tune my simplifi3d settings because with titan extruder and e3d hot end i have
    gaps in flat layers instead of a solid surface have grid printed
    i use petg and now 0.5mm nozzle and i set 105% extrusion and 0.6 extrusion width



  • @kivlow did you run PID tune?



  • yes i tune PID and its work fine but if i turn on fan then my fan duct cool hotend and duet stop my print.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.