slic3r heatbed location start issue



  • I'm using the latest version of Slic3r 1.3 dev. I recently changed hotends and have not had this issue before the change. But nothing has changed in firmware or software. When I pick reprap as the gcode flavor, the print starts offset from where it should. I'd guess it's 10-20mm off. What would cause that? And how do I fix it?



  • Does your bed dimensions in Slic3r match what you have set for axis limits in config.g?



  • I did not. I just had it at 200x200. I hav a cartesian printer, so I set it no to 220x226. The reason being is my offset z origin is 16, 30. It doesn't look like anything has changed. My guess is the offset would matter. The current print started towards the front just like that last have rather than more in the middle as I specified in Slic3r.



  • It is still not working correctly after setting the parameters in Slic3r. Simplify 3d does the same. Is it possible it's something in the home all file?

    Here are the parameters:

    ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool on Mon May 21 2018 09:59:36 GMT-0500 (Central Daylight Time)
    G91 ; relative positioning
    G1 Z2 F6000 S2 ; lift Z relative to current position
    G1 S1 X-235 Y-205 F2400 ; move quickly to X and Y axis endstops and stop there (first pass)
    G1 X5 Y5 F6000 ; go back a few mm
    G1 S1 X-235 Y-205 F900 ; move slowly to X and Y axis endstops once more (second pass)
    G1 Z-230 S1 F100 ; move Z down until the switch triggers
    G1 Z2 F6000 ; go back a few mm
    G1 S1 Z-230 F900 ; move slowly to Z axis endstop once more (second pass)
    G90 ; absolute positioning
    G92 Z0.2 S2 ; tell the firmware that we are at z=.2mm
    G1 X16 Y30 F6000 ; go to first bed probe point
    ;G1 Z2 F100 S2 ; uncomment this line to lift the nozzle after homing



  • can you also post your config.g?



  • ; Configuration file for Duet WiFi (firmware version 1.20 or newer)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Mon May 21 2018 09:59:36 GMT-0500 (Central Daylight Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves
    M555 P1 ; Set firmware compatibility to look like RepRapFirmare

    ; Network
    M550 PP3Steel ; Set machine name
    M552 S1 ; Enable network
    M587 S"Gemini" P"0102030405066ml" I192.168.1.100 J192.168.1.254 K255.255.255.0 ; Configure access point and IP addresses. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S1 ; Enable FTP
    M586 P2 S1 ; Enable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X128 Y128 Z128 E128 I0 ; Configure microstepping without interpolation
    M92 X640 Y640 Z32000 E2386 ; Set steps per mm
    M566 X900 Y900 Z12 E120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X12000 Y12000 Z180 E12000 ; Set maximum speeds (mm/min)
    M201 X1400 Y1400 Z50 E9000 ; Set accelerations (mm/s^2)
    M906 X1000 Y1000 Z800 E1200 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X220 Y226 Z230 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 Z1 S0 ; Set active low endstops

    ; Z-Probe
    M558 P0 H2 F120 T6000 ; Disable Z probe but set dive height, probe speed and travel speed
    M557 X15:185 Y15:185 S20 ; Define mesh grid

    ; Heaters
    M301 H0 S1.00 P10 I0.1 D200 T0.4 W180 B30 ; Use PID on bed heater (may require further tuning)
    M305 P0 T100000 B4066 C9.264103e-8 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4725 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S300 ; Set temperature limit for heater 1 to 300C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T35 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1 T100 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured

    ; Miscellaneous
    T0 ; Select first tool


  • administrators

    @mlaustin6 said in slic3r heatbed location start issue:

    my offset z origin is 16, 30

    Please explain what you mean by that.



  • @dc42 said in slic3r heatbed location start issue:

    @mlaustin6 said in slic3r heatbed location start issue:

    my offset z origin is 16, 30

    Please explain what you mean by that.

    I meant that when it hits the x endstop it travels 16 and y endstop it travels 30. That would then be the origin of 0,0. I'm sure something is wrong in the home all file.



  • @mlaustin6 : that means that your axis minima are X:-16 and Y-30, update your M208 command in config.g to get the correct 0,0 position


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.